Remove All Ads from XDA
Honor View 10

[Q] Thumb Drive bricked

248 posts
Thanks Meter: 23
By Shofar1, Senior Member on 27th April 2012, 04:39 PM
Post Reply Email Thread
I have used my USB Thumb Drive with my TPTablet before but today it killed the drive.

Plugged it in and it was not recognized.
Went to setting and the "mount USB" was pale and I could not get it to go on.

When I plugged the TDrive back in my PC it told me that it had to be formatted.

What is going on??

This is 64 GB Kensington DataTraveler, formatted exFAT.
The funny thing is the same drive worked before. I'm afraid to try my new 128 GB drive now as I don't want it bricked.
28th April 2012, 10:58 AM |#2  
OP Senior Member
Thanks Meter: 23
Still not working
I found a utility that allowed me to format to FAT32 but the TPT is still not recognizing it.

I have tried it with the TPT on and with it off, it still tells me that there is nothing availale and I cannot click on the "mount the disk" tab in settings.
Help please
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes