FORUMS
Remove All Ads from XDA

How to root your HTC One S (for Windows, Mac and Linux)

5,274 posts
Thanks Meter: 7,354
 
Post Reply Email Thread
29th April 2012, 05:09 PM |#41  
Member
Thanks Meter: 14
 
More
Just wanted to thank you, I was able to root my tmobile htc one s, i am up and running folowed the steps worked great,
What is worth saing from what i found i dont know if it will help or know i am just stating it from my experiance, It did not work from the first time i think it worked after i enabled allow unknown sources in security and i had to reboot bootloader.
Thanks again
 
 
1st May 2012, 02:18 PM |#42  
Junior Member
Flag Jacksonville, Fl
Thanks Meter: 2
 
More
I also used this successfully with the T-Mobile One S. Much like the previous poster, it took two attempts to get it to stick. I also turned on "Unknown Sources" before the second attempt, but cannot verify whether or not that made a difference or was merely coincidence. Either way, T-Mo users should be safe with this tool. Thanks Paul.
The Following User Says Thank You to keverline For This Useful Post: [ View ] Gift keverline Ad-Free
2nd May 2012, 01:31 AM |#43  
Reviewers's Avatar
Senior Member
Flag Brooklyn, NY
Thanks Meter: 1,694
 
More
Thanks but this didn't root my device.
3rd May 2012, 10:20 PM |#44  
Member
Flag Augusta
Thanks Meter: 0
 
More
I was going through the process and got stuck at the place some other folks are; getting root to work. In an effort to troubleshoot this myself I reflashed the different recoveries and the interim one seemed to boot up fine. When root wouldn't stick I did a master reset.

This is where it gets bad - when root still wouldn't work I went to advanced and formatted everything. I did this because it worked on the GS2 when I would have problems. Now when I reboot it gets stuck on the HTC Quietly Brilliant screen. Please help even though I brought this on myself.

tl;dr

The phone is stuck on the htc start up screen and I cannot get it to boot up or into recovery. Please help!


Update: I can get into bootloader and also into recovery. I cannot mount the sdcard to push any files to the phone through adb though.
4th May 2012, 07:15 AM |#45  
Senior Member
Thanks Meter: 47
 
More
SD card? You have a HTC one S with a SD card? How come?
5th May 2012, 08:15 AM |#46  
Member
Thanks Meter: 0
 
More
T-MOBILE 2 tries
I guess its confirmed that T-Mo may take 2 turns. also as noted and as done the phone is tampered with when you mess with the "LOCKED" files. no need to worry it just voids the warrenty.
6th May 2012, 09:50 AM |#47  
Junior Member
Thanks Meter: 0
 
More
Hello Paul!

superboot does not work on my device. I got my One S from amazon last week. it is not network branded and comes as HTC device. CID is HTC__002.

I unlocked bootloader via HTCDev site and it worked OK. then I installed boot.superboot.img as instructed. that (according to the CMD window) was a success too. when booting into bootloader do get the red warning screen (which I understand is normal) and can see still S-ON and the TAMPERED sign as well.

I tried several times as on some devices you need to do it more often. still the same results.

any ideas?? thank you very much!

device info:
hboot 1.06.0000
radio 0.15.31501S.19
CWM recovery 5.8.3.1
software 1.53.401.2
kernel 3.0.8-01050

Stefan
7th May 2012, 04:50 AM |#48  
Member
Flag Miami
Thanks Meter: 7
 
Donate to Me
More
I cant unlock the bootloader to root, at htcdev, click unlock bootloader and nothing happens, no popup nothing, is it down? i know what I'm doing I've done this before but does anyone have a work around?
7th May 2012, 01:59 PM |#49  
ascot17's Avatar
Senior Member
Thanks Meter: 451
 
Donate to Me
More
Quote:
Originally Posted by juwls305

I cant unlock the bootloader to root, at htcdev, click unlock bootloader and nothing happens, no popup nothing, is it down? i know what I'm doing I've done this before but does anyone have a work around?

http://www.htcdev.com/bootloader/unl...uctions/page-3
8th May 2012, 06:50 PM |#50  
kwtf's Avatar
Member
Thanks Meter: 1
 
More
Works perfect!
9th May 2012, 10:29 PM |#51  
Senior Member
Thanks Meter: 6
 
More
woohoo, Titanium now working!

Thanks for your hard work.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes