Remove All Ads from XDA
Honor View 10

SD card not detecting after ext4 partition Milestone

66 posts
Thanks Meter: 5
Post Reply Email Thread
I am using Motorola Milestone.
I formatted my mobiles 8GB SD card creating two partitions, 7.4 GB FAT32 & remaining Ext4 for app2SD using MiniTool partition wizard.
After flashing latest MIUI ROM using OR, (at that time card was working). Once after booting to ROM milestone is not detecting the card. Options for mount card & format card are disabled.

Any solution?
18th April 2012, 10:41 AM |#2  
Thanks Meter: 42
Tried on a PC?
Have you tried using the card on a PC (using a SD Card adapter) ? If that detects, then milestone should detect it too. You can also try using parted that comes with Open Recovery. Try using this tutorial: www dot mrmuh dot com /2012/01 /update-a-motorola-milestone-from-motorola-firmware-to-cyanogenmod-7/. Look at the Step 4 Prepare for Apps2Ext. That has some details on partitioning.
18th April 2012, 08:30 PM |#3  
mikeszf's Avatar
Senior Member
Flag San Jose
Thanks Meter: 39
A bit late but you can try making the partition using gparted, it always worked for me...
5th May 2012, 07:38 AM |#4  
Junior Member
Thanks Meter: 0
i ever used ubuntu and gparted to formating sd card.
U set both partitions with primary? this can make a card not work!
3rd June 2012, 02:31 AM |#5  
Optyone's Avatar
Junior Member
Flag Burzaco
Thanks Meter: 0
See first the Class of SD the Class 2, only support Ext 3 & 4, this is depend the Class of the SD, pull the SD on Mobile, and insert again, the Android check to any errors, this not work, use a SD Card Reader, and use Partition Magic, and delete all partitions of the SD, in Androidiani Recovery, in the menu (i dont remember the sub-menu) this says to Apply App2SD, they create a partition ext3 or 4 in your SD and found perfect =)

Cyas and I wait my quickly reply found it =)
14th December 2012, 07:04 AM |#6  
Junior Member
Flag Timisoara
Thanks Meter: 0
Maybe your ROM doesn't support EXT4, try using EXT3 instead.

---------- Post added at 08:04 AM ---------- Previous post was at 07:59 AM ----------

Originally Posted by csdr

Maybe your ROM doesn't support EXT4, try using EXT3 instead.

Sorry, now I have looked at the date of your post and I think I am a little late with the explanation.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes