Remove All Ads from XDA

Root & Install CM7 on Mytouch 3G Slide 2.2.1

21 posts
Thanks Meter: 28
By insanityrains, Junior Member on 1st September 2011, 08:52 PM
Post Reply Email Thread
21st February 2012, 07:08 AM |#71  
kurplop's Avatar
Senior Member
Thanks Meter: 77
I found it @CM7 Web site. I had 2 days into the first one,I hear you. Google is your friend. Google Mt3gs CM7 , lots to read. Hope you get it figured out.
here is the esprimg file from cm7's web site copy it to your sd.
°··:··SGSII T989~ juggernaut v5.0~ synergy v.0.10··:··°
The Following User Says Thank You to kurplop For This Useful Post: [ View ] Gift kurplop Ad-Free
21st February 2012, 07:16 PM |#72  
Junior Member
Thanks Meter: 1
Originally Posted by insanityrains

Rooting & Flashing To Stock 2.1

8. In the mt3gs rooter program, click on "Root Me"
You will need to turn on the phones WIFI within 30 seconds so be quick and then wait for it to restart.

I can't this part right. I run the "adb" file in the mt3gs folder but nothing happens, I never see a program launch and certainly not a "Root Me" button.

So clearly something is wrong, but what?
2nd March 2012, 09:29 AM |#73  
Thanks Meter: 9
Originally Posted by rmbb

I can't this part right. I run the "adb" file in the mt3gs folder but nothing happens, I never see a program launch and certainly not a "Root Me" button.

So clearly something is wrong, but what?

You don't run the adb file, that doesn't help you at all. Run the file "mt3gs rooter"

That has the "Root Me" button.

Also, to all those having problems, make sure you have the HTC drivers installed (obtainable by installing the HTC Sync software), and then make sure the SDcard you're using is formatted in FAT32. Mine was formatted in FAT and caused problems~

After that, everything should flow smoothly!
20th March 2012, 09:30 PM |#74  
Junior Member
Thanks Meter: 0
Thank you greatly! This is the only thing that worked after trying 10 or so different methods.
1st April 2012, 12:16 AM |#75  
Junior Member
Thanks Meter: 0
Stuck on CM7 boot screen
So I followed all of the directions to a T and everything went super smoothly until I tried to reboot......well I rebooted into CM7 and the android on a skateboard flew by stopped with the arrow flying around him in a circle and now the arrow is just going around and a around and a around. You get the idea.

So I'm stuck on the boot screen. Any suggestions on what I can do? Please be explicit as I'm a noob and still trying to learn. Thanks!

(I've tried to go back to the recovery and reflash it (cleared cache, user data and what not.) But to no avail, still stuck on the boot screen)

Any help would be greatly appreciated as I currently have an unusable phone. Thanks!
1st April 2012, 04:07 PM |#76  
Junior Member
Thanks Meter: 0
Thumbs up Followed directions PRECISELY, works!
Finally, a solution that works!

I followed the directions precisely, though I did some preparation first:

Bought a new SDHC 4GB "4" blank card, and let the phone prepare it. I found I did NOT need to create a "goldcard" at all (which is not in the instructions <- hint). Following the instructions in the OP, both the phone and my Vista 64 PC were able to "see" the card as needed by each.

Downloading SuperOneClick 1.7 generated security warnings with Microsoft Security Essentials, with its response being to remove the zip file from the computer. I changed the setting for that particular program to "Allow," and then re-downloaded it. Thus far, I have yet to find the alleged security problem they claimed, and it worked just fine.

The only difference between the instructions in the OP and what I did was I installed CM 7.1.0 (instead of 7.0). This includes reverting the phone's OS from 2.2 to 2.1. Otherwise, I followed each step in the order told to, and there have been zero problems! I now have 100% use of my 3G Slide (no thanks to HTC or TMO).

One note to pass along: If you unlocked your phone and are now with a different carrier, you will have to redo the steps for entering the Access Point Names. The installation reverts the phone back to TMO settings, and the phone won't work (except through wifi) until you do this.

I couldn't find the "thanks" button to thank the OP, so I will express it here. Thousands of us with these phones had huge problems with TMO's forced update to 2.2, in my case 90% of my attempts at outbound calls resulted in the phone rebooting (including several 911 calls). My phone now not only works as it should have, it works better!

Thanks again!
3rd April 2012, 06:09 AM |#77  
Junior Member
Thanks Meter: 0
hey i've downloaded all the files that are listed except for the Google Apps-......The page is not loading so that i can download the file.... is there another link that you can give ??
7th April 2012, 04:48 AM |#78  
Junior Member
Thanks Meter: 0
ADB Troubles
Thanks so much for this guide, I'm glad that it is working for so many people. Unfortunately, despite spending at least a solid 8 hours trying to make this work on my computer and phone I have been totally unsuccessful from square one.

I am using a T-Mobile MyTouch 3G Slide with recently factory reset 2.2.1 firmware.

I have at my disposal several SIM cards, a Windows 7 computer, an Ubuntu 10.10 computer, and an Ubuntu 11.10 computer.

On all three systems, I have followed the various instructions online and on this post to try to get ADB to recognize the phone. For Windows 7 I tried the instructions on this post. On my Ubuntu 11.10 computer, I tried the instructions here:

and for my Ubuntu 10.10 computer, I tried the instructions here:

However, on all three computers, I see very similar errors. When I run adb with the "devices" argument (i.e. by running the rooting software on the Windows computer as specified here, or by running ./adb devices on my linux computers), it returns:

$ ./adb devices
List of devices attached


The same message is printed by the rooting software windows.

Now, this is not the permissions issue that everyone mentions. And the software is clearly running, but despite three different OS versions, all of them report the same thing. Nothing.

I did a lot of things to try to tease out why this problem is happening. On linux, I used lsusb to verify that it was attached (it was). I used dmesg to verify that it was detected (it was). I verified that debug mode was on the USB on the phone (it was). I turned off wifi and even 3g (didn't help). I made sure it was in charge-only mode (it was). I turned off the firewall (didn't change anything). I plugged into new USB ports (didn't help). I rewrote the rules files for udev several times and rebooted a few more (didn't help).

Nothing seems to make any difference, and since the problem is the same on windows 7 as it is on Ubuntu (at least from what I can tell), I have to assume it's the phone somehow.

Does anyone have any idea why this error might occur? I can't find it referenced anywhere, although it's kind of hard to search for a null return message. It's not even an error... just nothing returned. Very weird.

Anyway, if anyone has any ideas I'd be semi-eternally grateful (not sure about the afterlife, so no promises). I'm pretty computer literate (using linux after all, and have been for over a decade). I'm fairly confident that this is a communications level issue with the phone, and I can't find what is misconfigured or broken.

I wanted to post this to the person who put up the instructions for Ubuntu 11.10, but it seems that this is not allowed for noobs. Oh well, I'll assume that it will percolate up to her eventually.

Brian Neltner
12th May 2012, 03:24 PM |#79  
Junior Member
Thanks Meter: 0
I would like to thank insanityrains for the instructions and files. I am running CM7 and its Android version 2.3.3 Gingerbread and space on my phone now.
Once Again Thanks very much for this.

Sent from my T-Mobile myTouch 3G Slide using XDA
6th June 2012, 07:10 AM |#80  
Monster809's Avatar
Stamford CT
Thanks Meter: 3
very good tutorial really works fine with me!!!
9th June 2012, 11:37 PM |#81  
Junior Member
Thanks Meter: 0
Unhappy gingerbreak ! trying to root my phone !
i downloaded gingerbreak and when i click open it says...

data is in an unexpected location !
please report this in the XDA thread !

now what do i do ? help ?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes