Remove All Ads from XDA
Honor View 10

[US/WW/JP/TW/DE/TB] One-Click Universal root for stock firmware - V4

128 posts
Thanks Meter: 184
By rebound821, Senior Member on 2nd August 2011, 12:39 PM
Post Reply Email Thread
24th February 2012, 09:00 PM |#341  
Thanks Meter: 10
Originally Posted by KnightySU

Does the v4 still work with the new 4.0.3 update?

Yes, without any problems, this is a super tool
The Following User Says Thank You to bachmark For This Useful Post: [ View ] Gift bachmark Ad-Free
24th February 2012, 11:09 PM |#342  
Junior Member
Thanks Meter: 2
Tried it 4 times and it doesn't seem to work

edit: vipermod primetime v4.5 did the job...
25th February 2012, 12:34 AM |#343  
Thanks Meter: 7
Originally Posted by KnightySU

Tried it 4 times and it doesn't seem to work

edit: vipermod primetime v4.5 did the job...

Didn't work for me also. Every thing on screen went well and was told I was rooted by the script but Superuser says NO WAY hoseA.
25th February 2012, 12:45 AM |#344  
Junior Member
Thanks Meter: 2
Like written in the other thread i chose "1". What did you choose?
26th February 2012, 05:06 PM |#345  
Junior Member
Thanks Meter: 0
Originally Posted by bachmark

Yes, without any problems, this is a super tool

Hi. I have used V4 on my TF101 at least three times previously to get root only i.e. in order that I would get the OTA updates. I had used the bootable CD method which is very elegant. Yesterday, I received my OTA ICS update. Of course, root was removed by this. I had some weird behaviour (flickering desktop). Eventually, I did a factory data reset and the problem disappeared. I have only installed those apps that I need at this time.

I want to know whether V4 works for the ICS update. KnightySU says no. Have you tried V4 on the ICS update?
26th February 2012, 09:33 PM |#346  
Taomyn's Avatar
Senior Member
Thanks Meter: 133
Apparently this doesn't work and if you didn't use root keeper as I didn't, had to use Vipermod. It's for the Prime but option 1 works just fine on the TF101

Sent from my Galaxy Nexus using Tapatalk
13th May 2012, 08:07 PM |#347  
Senior Member
Thanks Meter: 20
This still works super as an unroot tool!

First download the tar ball. Then surf to and download From it, extract /usr/system/su and use that to replace the su binary that is in universal/root/su.

I've just used it to succesfully root on a B50 tablet. It's great to have an open SBK key!
5th April 2016, 05:59 PM |#348  
marathone's Avatar
Senior Member
Flag Toronto
Thanks Meter: 44
Originally Posted by rebound821

Here I am again...
This time I have written a shell script (linux only) and made a live-cd (for all windows/linux users) to automatically root the stock firmware on the TF101. Every stock firmware.

Today in Europe Asus rolled out the 3.2 upgrade. If you are on stock and you have alredy upgraded then download attached tar file and do as follows:

NOTE: Unfortunately, this script won't work with the latest revision of TF101 (3G version, B80 and some B70)

NOTE2: As someone pointed out (thank you Pieter) you need to be root on your linux box in order to make it work.

tar -xvf universal.tar
cd universal
In Ubuntu the last command would be:
sudo ./
Follow the instructions and you're done.
If you have a stock US/DE/TW/JP/TB firmware you can do the same.
If you are running an older version of Honeycomb the process is the same.
When ASUS will pull out another upgrade... same commands as above.
So this probably is the closest thing to one-click-root for the Transformer.

This won't install custom rom/CWM/strange other things (V2 version added the support for CWM); it's only root.
I've tested this morning after the 3.2 upgrade and it worked like a charm.

However this is in testing stage so, as always, if you brick/ruin/burn/crash something don't blame on me.

This package includes the Bootunpack tool, courtesy of Rayman84


It's based on slitaz (
Burn the image into a cd or if you want it on a thumb usb drive follow this (

Put the cd/usb in your pc and reboot.
Follow the indication on screen (for setting locale and keymap).
When the desktop shows up, double click on "Universal Root for ASUS TF101".
Again follow the indication and you'll be ok.

For a guide on how to boot from cd/usb try this:
or search with google.

The option to install a stock boot/recovery (added on V3) is working even if not fully tested.
The program has correctly rebuilt a stock recovery on my WW version.
From version V4 root checker correctly says that the rom is not rooted after you do an unroot.

If you like the work i did take a look at that funny button under my name with the "donate to me" caption
Seriously, I appreciate even only a "Thanks".


[Q] I'm running on Windows, how can I burn the live-cd?
[A] Try with cdburnerxp (it's the easiest way).
You can download one installer frome here:
or the portable package if you don't want to install other software:

Start the program (for the portable version the file is cdbxpp.exe) and click on "Burn iso image". Then select the .iso file you have downloaded and click "burn disk". All Done.

[Q] How can I reboot in APX/recovery mode?
[A] Do as follows:
VOL UP + POWER BUTTON for ~5sec = boot in APX mode. The screen will stay black as if it is turned off. This mode is used only when you use nvflash to flash boot/recovery/data partition (this is the first step in my script).
VOL DOWN + POWER BUTTON ~5sec = will appear a screen where it says to press vol down again to wipe all data (obviously you don't want to do it now), or press up to enter RCK (recovery mode). If you installed CWM you will see the main menu navigable with vol up / vol down / power button.
If you have the stock recovery you will see a green android with a esclamation mark on a yellow triangle.

[Q] Help! I can't reboot in recovery mode!
[A] I think the main problem here is that it is a bit tricky to get into CWM recovery, once you see the small text come up don't try to read anything, just hit volume up.
Hold volume down plus power until the text in upper left shows,if you let go too early it just boots up and you never see the text. If you wait too long you don't get the option to boot into recovery. Hope that helps..
Thx to ckuke4 for this answer

[Q] The live-cd gave me this error: "connection failed NvError 0x8" what is it?
[A] This means that either you are not in APX mode (read above), or that you have one of the latest revision of the tf101 (B7O) which have an unknown (for now) sbk.
For what i know, there's no knew method for rooting your device.
Maybe someone will find a way, but for now you have to be patient.

[Q] I'm running your scripts from my linux box, but it keep me saying "Permission Denied". Why?
[A] You need the root privileges on your local machine.
If you are running Ubuntu:
sudo ./
(it will asks for your password)
If you are running another linux distro:
(it will asks for your password)
[Q] I have rooted my tablet with this method, but I can't find the superuser app and Titanium Backup says that I am not rooted.
[A] The root script will asks you to reboot your tablet, make sure that usb debugging is turned on and then press any key.
You have to wait until you see a little bee on the bottom right of your tablet's screen, near the clock. Then press any key.

[Q] I've installed CWM but every time i try to do a backup, it says it can't find sdcard. But my microsd card work fine with root explorer!
[A] Don't get me wrong but, are you sure?
In root explorer you see a sdcard folder but it's not your microsd, it's the internal memory (it's weird, i know). In root explorer the microsd card is mounted under the "/removable/microsd" folder. You should also see a little sd card icon in the bottom right, near the clock.
Also you need to make sure the card is formatted correctly. Try reformat it with this:
Thanks to skeeterpro for the link (

[Q] The live cd stops at the command prompt, I can't see the desktop.
[A]The live cd doesn't include every driver for every video card, mouse, keyboard, etc.. (keep in mind that the original slitaz livecd is only 30MB).
You can do all the process in the text console, it's not much more difficult.
If it asks for a login insert "tux" (without quotes).
At the command line enter the following:
cd universal
Then the magic will start. The unroot script is called ./

- Corrected some text
- Added a link on the Desktop to this thread
- Added stock ramdisk for all SKU (though JP, CN and DE are not the latest versions) (thanks to kovla for the latest TB recovery)
- Added a script on the Desktop to increase the font size on the fly for those who are using a very high dpi monitor/tv.
- Changed compression algoritm. Now the iso is ~10MB smaller.
- Maybe I have found the way to make everyone read the faq...

- [BETA] added a second script to come back to stock.

- added the option to install CWM (thanks Roach!)
- more error check

First version

=====> DOWNLOAD LIVE-CD V4 - (Mirror)<=====

DOWNLOAD LIVE-CD V3 (previous version)


As always, keep your eyes open and
Have Fun!

Hi - mirror isn't working, not surprising given that it's several years back. Would it be possible to grab this file from you? Preferrably the v4 iso image? Thanks.
23rd May 2016, 08:34 PM |#349  
Junior Member
Thanks Meter: 3
Is it possible to get the files to root?
Post Reply Subscribe to Thread

one-click, root, stock, universal

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes