Remove All Ads from XDA

[Q] Proximity Sensor Issues- Samsung Focus

1 posts
Thanks Meter: 0
By Slowestofthepokes, Junior Member on 24th December 2011, 07:41 PM
Post Reply Email Thread
Hello all.

I have a Samsung focus with an "always on" proximity sensor. So the phone does not light up after it has moved away from ones face during a phone call, making it impossible to use after any call without a restart.

I have tried the following solutions.

1- Soft Reset by pulling the battery and waiting
2- Hard reset using numeric codes provided in the ref threads
3- Using the diagnostic menu.

With regards to the third one. The proximity sensor menu shows that the sensor is always "on" no matter where the phone is. But there is no "set" or "reg' button that I can find with which to recalibrate it, the only option is "exit"

It is quite possible that I am missing a feature or function or I need a new solution. If anyone has any insight that would be really helpful.

Thank you in advance.
11th February 2012, 12:04 AM |#2  
Junior Member
Thanks Meter: 0
I have exactly the same problem. Did you solve it ?
19th February 2012, 04:26 AM |#3  
Senior Member
Flag Chicago
Thanks Meter: 15
You will need to give a little more information. What os version are you running and what diagnostic app are you running. I think the most up to date diagnostic app is ver(.0103).

1. uninstall your diagnostic app
2. install the diagnostic app again to get latest app ##634#
3. open the diagnostic app and type *#0*#
4. tap the proximity sensor button and see if you see set reg and exit soft keys
3rd July 2012, 09:35 PM |#4  
Junior Member
Thanks Meter: 0
Unhappy Issue with proximity sensor in Samsung focus sgh i917
I have the same problem. My LED screen broke recently and replaced it.

It looks like after the screen replacement, the phone's proximity sensor is always in detected mode [in the diag]. So when ever a phone is made or answered the LED screen goes blank disabling all functionality till the other person disconnects.
I ran the diag but it doesn't give me an option to calibrate the sensor. I tried to install the latest diag tool too but same results. There is only one button, "EXIT".

The diagnostic app version is .0628
OS version is 7.10.7720.68
Please help.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes