FORUMS

Screen on when receiving a text? Anyway to disable?

1,057 posts
Thanks Meter: 144
 
By phyba, Senior Member on 2nd July 2012, 10:30 PM
Thread Deleted Email Thread
14th July 2012, 02:08 PM |#11  
dc82's Avatar
Senior Member
Thanks Meter: 268
 
More
Quote:
Originally Posted by srath16

Found a quick fix to this that is way better than defaulting to another SMS app. Simply download "SMS pop up" from the play store, make sure its enabled, and under additional preferences untick "screen on pop up" and then under notification settings untick "enable pop up" (unless you want the pop up of course). You will have to untick the regular SMS app notifications under settings but its a fix that's working for me that still keeps the stock messaging app intact.

That will stop the screen from waking every time but won't turning notifications off in sms settings also prevent the phone the phone from letting you know at all that you have a message?
14th July 2012, 02:26 PM |#12  
stu5797's Avatar
Senior Member
Flag Cleveland, Ohio
Thanks Meter: 497
 
More
that is a nice woorkaround but too bad we have to use double the battery and 2 apps running at once to stop it. There has go to be a solution !
14th July 2012, 03:07 PM |#13  
TokedUp's Avatar
Recognized Contributor
Flag Hellz Kitchen, NYC
Thanks Meter: 1,307
 
More
I made a thread about this yesterday. It happens to me everytime. On vzw
14th July 2012, 09:45 PM |#14  
Senior Member
Flag ORLANDO
Thanks Meter: 230
 
More
I'm running ATT variant and my screen wakes up when I get a text. Im currently rooted and looking through the messaging defaults with root explorer. Im sure theres a setting in there that is set to 1 or true that is doing this or vice versa for everyone else. I havent had an android device for quite some time so it might take me a bit to find it. If someone is a bit more experienced than me they'll probably find it faster.
15th July 2012, 12:24 AM |#15  
srath16's Avatar
Member
Clearwater, Florida
Thanks Meter: 19
 
More
Thumbs up
Quote:
Originally Posted by dc82

That will stop the screen from waking every time but won't turning notifications off in sms settings also prevent the phone the phone from letting you know at all that you have a message?

Following what I wrote: If you disable the stock sms notifications under messaging>setting then the phone will not recieve any notifications regarding new messages. This is why SMS Popup is used instead. It uses a notifications service in conjunction with an optional popup to notify you when a new message arrives. If you enable notifications in SMS Popup, you will still receive notifications when new messages arive. SMS Popup is the service that will receive and notify you of the message, not the stock messaging app. It also has some other features including color customization of the LED light and selecting a specific SMS vibrate pattern. Like I said if you disable the "Enable popup" setting under the "notification" menu in SMS Popup it can serve as a intermittent workaround. As for the need to install it to accomplish this simple setting, it has a low battery and memory footprint as it is mostly a simple service and not a fully effective SMS replacement application. I have spent countless hours trying different solutions to this issue and this seems to be the best most effective workaround I could find whilst dodging SMS replacement apps like handscent and chomp. It was imperative for me to not have my screen light up in my pocket as I choose to go without a lock screen. Hope this helps and is a worthy solution until some development ushers in a new more efficient solution. Cheers!
The Following User Says Thank You to srath16 For This Useful Post: [ View ] Gift srath16 Ad-Free
15th July 2012, 12:50 AM |#16  
Senior Member
Thanks Meter: 26
 
More
There's got to be a way using root privileges to stop this. Heck we can stop the annoying wifi pop ups.
Thanks srath16 for finding a hackish way around.
Sent from my SCH-I535 using Tapatalk 2
15th July 2012, 02:26 AM |#17  
dc82's Avatar
Senior Member
Thanks Meter: 268
 
More
Quote:
Originally Posted by srath16

Following what I wrote: If you disable the stock sms notifications under messaging>setting then the phone will not recieve any notifications regarding new messages. This is why SMS Popup is used instead. It uses a notifications service in conjunction with an optional popup to notify you when a new message arrives. If you enable notifications in SMS Popup, you will still receive notifications when new messages arive. SMS Popup is the service that will receive and notify you of the message, not the stock messaging app. It also has some other features including color customization of the LED light and selecting a specific SMS vibrate pattern. Like I said if you disable the "Enable popup" setting under the "notification" menu in SMS Popup it can serve as a intermittent workaround. As for the need to install it to accomplish this simple setting, it has a low battery and memory footprint as it is mostly a simple service and not a fully effective SMS replacement application. I have spent countless hours trying different solutions to this issue and this seems to be the best most effective workaround I could find whilst dodging SMS replacement apps like handscent and chomp. It was imperative for me to not have my screen light up in my pocket as I choose to go without a lock screen. Hope this helps and is a worthy solution until some development ushers in a new more efficient solution. Cheers!

I completely understand now. That's. Cool. There got to be a more in house way of doing this, but that would work in the meantime. Thanks for sharing.
15th July 2012, 03:11 AM |#18  
Senior Member
Thanks Meter: 56
 
More
This happens to me also and im running on Verizon at the moment would love if someone could find a way to fix this.
15th July 2012, 12:48 PM |#19  
stu5797's Avatar
Senior Member
Flag Cleveland, Ohio
Thanks Meter: 497
 
More
Quote:
Originally Posted by blackguy101

This happens to me also and im running on Verizon at the moment would love if someone could find a way to fix this.

+1. But maybe we are in the minority and others actually like this feature?
15th July 2012, 12:59 PM |#20  
dc82's Avatar
Senior Member
Thanks Meter: 268
 
More
Quote:
Originally Posted by stu5797


+1. But maybe we are in the minority and others actually like this feature?

Right. This isn't an "issue", it's just a feature that Samsung has deployed that some like and some don't. Being able to turn it on and off though would be nice.
15th July 2012, 03:22 PM |#21  
TokedUp's Avatar
Recognized Contributor
Flag Hellz Kitchen, NYC
Thanks Meter: 1,307
 
More
Feature my butt! It wastes battery and wakes my GF up from sleep which will eventually get my brand new phone thrown out the window. Im serious.
Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes