Remove All Ads from XDA

[Q] [HELP] Internal SD Card problem [HELP]

10 posts
Thanks Meter: 2
By Pindagus, Junior Member on 25th September 2012, 07:40 PM
Post Reply Email Thread
Hi guys,

This is my first post here, because this is the first time I’ve encountered a problem where I can’t find a solution for on the forums and or random google searches. So I decided to make this thread for myself and others that can’t find the solution to this problem.

So basically this is (I think) the main problem
The internal sd card of my Galaxy S GTI9000 is corrupt.
I can only read the files that are stored, when I try to write (copy a file, delete files or format the whole internal storage) the changes only have effect until the internal sd card is remounted.
This does let me think the internal sd card suddenly became write-protected.

The tricky thing is to know if this can be resolved or if this is truly a hardware problem.
I personally think making the external sd card the internal sd card could work.

What I’ve done so far
Running fine on Slimbean 2.2 until one day it suddenly was in Recovery mode; bootloop
- Reflashed with Slimbean 2.2; bootloop
- Wiped and reflashed; bootloop
- Wiped and flashed CyanogenMod 9.1.0; starting but encryption unsuccessful
- Wiped and flashed CyanogenMod 10 Build 20120920; bootloop
- Flashed 2.3.4_I9000XXJVP; starts fine but apps are crashing all the time
Here I discovered the internal SD Card writing problem

Flashed several official firmware versions with same outcome as the point above
Errors encountered while flashing these firmwares (not always):
- E:format_volume: rfs format failed on /dev/block/mmcblk0p2
- E:format_volume: rfs format failed on /dev/block/stl10
- E:format_volume: rfs format failed on /dev/block/stl11

Firmwares flashed
- I9000XWJS5 (JS5_JS3_JPY_ tar)
- I9000XWJW5_I9000XENJV6_XEN (JW5_JV6_JW4 tar)
- JW6_JW5_JW4 tar
- I9000XXJVT

Also tried
- Hard reset in JVP (gave errors mentioned above)
- Use external sd as internal sd (didn’t succeed in doing this)
(got stuck at repacking kernel, same as OP of that thread)

Best I could do
What works the best for me right now is flashing JVP, but:
Can make calls
Can send text messages
Apps are crashing often
No Wi-Fi
No mobile internet
Can’t get root access (with CF-Root)

I hope you can help me, thanks in advance.

I did this workaround:
Now I have a fully working phone again, but still the same problems with the internal sd card. (can still be accessed)

If you have the same problem and also have a external sd card the workaround mentioned above would definitely work!
Thanks to reganstott
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes