FORUMS
Remove All Ads from XDA

Fuhu Nabi2 Back to Stock from scratch in Ubuntu Linux

193 posts
Thanks Meter: 188
 
By t499user, Senior Member on 11th December 2012, 02:31 AM
Post Reply Email Thread
If you have/want to go back to stock, it is best to use the backup you made(of course you made a backup). If you somehow lost or didn't make a backup. Here are the directions for going back to version 1.9.12 from scratch.

I wrote these directions for Linux, but you can easily adapt them for WIndows(except installing adb and fastboot) by just removing 'sudo' from the commands.

Download and extract the following to your home directory: http://dl.dropbox.com/u/6529005/Fuhu...om_scratch.zip

Open a terminal(ctrl+alt+t) and run the following command to install ADB and Fastboot (Universe).
Code:
sudo apt-get install android-tools-adb android-tools-fastboot
With the Nabi2 fully charged and turned off, hold the vol+ and power button until the menu comes up. You use the vol- to navigate and the vol+ to select. Choose 'Fastboot Protocol', connect your USB cable.

We will flash the new TWRP recovery image using fastboot:
Code:
sudo fastboot flash recovery recovery.img
When fastboot is finished, boot the new recovery kernel on the Nabi2 by pressing vol+ then vol-(down to recovery) then vol+ to select.


Now the device is in TWRP, choose Wipe>Factory Reset>Slide to Wipe

We will now push the WiFi Fix that might be needed to restore wifi.
Code:
sudo adb push fuhu_nabi2_wifi_fix.zip /sdcard/fuhu_nabi2_wifi_fix.zip
Get your device id(unique to YOUR Nabi2), you will use the 16 character value returned in the next step to replace '___YOUR_DEVICEID_GOES_HERE__' :
Code:
adb devices
This will return something like:
PHP Code:
List of devices attached 
016b32201337rf0f    recovery 
Replace '___YOUR_DEVICEID_GOES_HERE__' in the following command with what was returned to you. This command is going to push a large file, so it will take some time, wait for it to finish. TWRP has a file manager if you need to free some space on your /sdcard/
Code:
adb push fuhu_nabi2_v1912_system.ext4.win /sdcard/TWRP/BACKUPS/___YOUR_DEVICEID_GOES_HERE__/oem/system.ext4.win
Now on the device in TWRP you can choose Restore>Using internal storage>oem>Swipe to Restore.
Once this step is finished you can Home>Reboot>Bootloader in TWRP.

Now your device is back to version 1.9.12, from here you can start doing your OTA updates, but before you do that, we have to go back to the original recovery image, otherwise the OTA will fail.
Lets flash the original recovery image:
Code:
sudo fastboot flash recovery nabi2_original_recovery.img
It is now possible to do your OTA updates. Either download them over WiFi from Settings>About Tablet> Update, or you can manually install them from a MicroSD card through the original recovery.
http://dl.dropbox.com/u/6529005/Fuhu...__1923_ota.zip
http://dl.dropbox.com/u/6529005/Fuhu...9_1937_ota.zip

If your system needs the wifi fix, you can flash the fuhu_nabi2_wifi_fix.zip in TWRP>Home>Install>fuhu_nabi2_wifi_fix.zip
The Following 20 Users Say Thank You to t499user For This Useful Post: [ View ] Gift t499user Ad-Free
 
 
12th December 2012, 04:08 AM |#2  
compta5's Avatar
Member
Thanks Meter: 9
 
More
Followed All The Steps But I Get A Error ...Status 7.

"assert failed: apply_patch_check ("/system/build.prop".

---------- Post added at 10:08 PM ---------- Previous post was at 10:06 PM ----------

I'm Assuming My Build Prop Is Different Not Sure How If I Applied The Backup That Is In The File You Provided. Would Anyone Have An Original Build.Prop?
12th December 2012, 10:32 PM |#3  
compta5's Avatar
Member
Thanks Meter: 9
 
More
NVM Just Did A Complete TWRP Backup From My Other Nabi Tablet And Transferred The Files To The "Broken" One & Success Got It Updated To Latest OS .Just Did A Factory Reset So That Way I Could Have A Different Login.
13th December 2012, 07:01 AM |#4  
OP Senior Member
Thanks Meter: 188
 
More
Added OTA updates to original post.
The Following User Says Thank You to t499user For This Useful Post: [ View ] Gift t499user Ad-Free
3rd January 2013, 10:37 AM |#5  
Senior Member
North Carolina
Thanks Meter: 3
 
More
So need a little help. I had the .23 on my nabi with a broken wifi. Followed your post to get back to .12. I did get back to .12 but wifi is still broke. I pushed the wifi fix like posted, but I did not flash before going back to .12. So I then flashed twrp again and flashed it once on .12, but it did not work. Stuck saying "updating partition details." Not sure what to do to get the wifi back. I made a nandroid of .23 before going through the process. Went back to .23 and tried flashing the wifi fix in twrp and still stuck with the same message.
Any ideas?
3rd January 2013, 12:24 PM |#6  
OP Senior Member
Thanks Meter: 188
 
More
Go back to .12, do a factory reset, flash the stock recovery, then install the OTAs from the stock recovery in proper order from a microSD card. Without using the wifi fix zip.
The Following 2 Users Say Thank You to t499user For This Useful Post: [ View ] Gift t499user Ad-Free
3rd January 2013, 12:39 PM |#7  
DarkAngel's Avatar
Senior Member
Flag Arizona
Thanks Meter: 359
 
More
Although weird, one of my daughters wifi stopped working even though all updates were performed and I have not rooted them as of yet. Stopped after about 8 days of use. Wasn't picking up any wifi anywhere at all. I tried everything and last was a full reset back to complete stock from the beginning like when she first got it. That solved the problem. Just thought I would mention it in case anyone gets this issue.

Sent from my SPH-L710 using Tapatalk 2
The Following User Says Thank You to DarkAngel For This Useful Post: [ View ] Gift DarkAngel Ad-Free
3rd January 2013, 11:43 PM |#8  
Senior Member
North Carolina
Thanks Meter: 3
 
More
Smile
Quote:
Originally Posted by t499user

Go back to .12, do a factory reset, flash the stock recovery, then install the OTAs from the stock recovery in proper order from a microSD card. Without using the wifi fix zip.

Quote:
Originally Posted by DarkAngel

Although weird, one of my daughters wifi stopped working even though all updates were performed and I have not rooted them as of yet. Stopped after about 8 days of use. Wasn't picking up any wifi anywhere at all. I tried everything and last was a full reset back to complete stock from the beginning like when she first got it. That solved the problem. Just thought I would mention it in case anyone gets this issue.

Sent from my SPH-L710 using Tapatalk 2

Thanks guys for the help. Did not know there was a factory reset on the tablet. Fixed it a little differently. I had another nabi for my other kid, and updated that to .37 and ran jmz script #2. Then copied the stockbackup to the broke nabi and wiped and restored. Did factory reset on tab and re-ran jmz's script. Back in business!
I must say that I screwed up the first time around by not updating twice to the .37. Then compounded it by doing a reboot recovery in cmd line while it was making a stock backup. It was sitting there for quite along time any my impatience got the best of me. I guess I am used to seeing the progress bar while it is performing backup or flashing new rom. The second one, I walked away and let the script do its thing.
Thanks for all the help!
7th March 2013, 09:45 PM |#9  
oniddy's Avatar
Senior Member
new york
Thanks Meter: 106
 
More
This wifi problem got me going nuts all my kids got a nabi 2 I got 4 kids and i got to keep restoring them and even the one that is not rooted I got to keep resetting all the time I'm about to sell them
26th March 2013, 06:31 PM |#10  
Member
Thanks Meter: 2
 
More
got the android recovery installed but it is stuck nothing happens except the dead android with an exclamation point coming out of his chest
27th March 2013, 04:54 AM |#11  
aicjofs's Avatar
Senior Member
Flag Portland, Oregon
Thanks Meter: 1,022
 
More
Quote:
Originally Posted by jd0819

got the android recovery installed but it is stuck nothing happens except the dead android with an exclamation point coming out of his chest

That's the stock recovery it always does that, unless you are performing OTA, you are trying to go back to stock? You want TWRP installed, until you have recovered the system(Android) to stock. Maybe I am reading you wrong but you need TWRP recovery to restore Android back to scratch.

http://forum.xda-developers.com/show....php?t=2074501
Post Reply Subscribe to Thread

Tags
fuhu nabi2, nabi 2, original, restore

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes