FORUMS
Remove All Ads from XDA

[UNOFFICIAL] CM10.1 for Advent Vega / PoV Mobii

2,156 posts
Thanks Meter: 3,754
 
By scanno, Senior Member on 31st December 2012, 02:03 PM
Post Reply Email Thread
[INTRODUCTION]
This ROM is mainly created by Scanno with the help of EJTagle (for kernel work and drivers). This ROM is based on the CM10.1 sources and has the most CM10.1 features included.

Why a CM rom after a couple of AOSP ROMS? Well the main reason is that android 4.2 has a new interface and i do not like it that much. CyanogenMod includes some inteface enhancements that i personally think adds some additional value.

Please remember that I and EJtagle are *NOT* professionals and do this in our spare time. We all have full time jobs and a family. So be happy that there is an Android ROM based on Android 4.2 / JellyBean for a device that was sold with Android 2.2 and never had an update.

We do our best to make this ROM as good as possible. With VegaCream and VegaBean we gave you a ROM that gave a new life to your tablet and unleashed its full potential. But we are not wizzards and there might be problems that we cannot solve or do not have time for.

[FEATURES]
This ROM is an unofficial CM10.1 and has most CyanogenMod features included.

[INSTALLATION]
As you all might know we have very limited internal storage space. So this ROM needs a different internal memory layout. The whole /data partition (where the user data and apps are installed) needs to be on the sdcard.

[SDCARD]
You SDCARD needs to be partitioned the following way:
- First partition needs to be FAT32
- Second partition needs to be EXT4
- Make sure there is NO extended partition

[FLASHING]
The first time you flash this ROM you *HAVE* to flash the NVFlash version to make sure the internal memory is formatted the correct way.
Make sure you have the GApps downloaded and put on your SDCard (see goo-inside.me/gapps)

[NVFLASH]
Download the NVFlash version and make sure your tabet is connected to the power supply and that the tablet is connected to your computer.
Put the tablet into NVFlash mode (by using 2 seconds back key, 2 seconds power key, 2 seconds back key)
Run the NVFlash executable and if everything goed right, the ROM will be flashed.
Reboot the tablet and as soon as the tablet finishes booting, reboot the tablet into recovery mode.
Once in recovery, do a factory reset and then right after that flash the Google apps zip file you downloaded.

[RECOVERY]
Download the zip file and put the file on your SDCARD.
Boot into recovery.
Do a factory reset (or you can try just clearing cache and dalvik-cache).
Flash the zip file.
Right after flashing the ROM, flash the gapps zip file.
Reboot.

[WORKING]
- 3G
- Audio
- Video
- Wifi
- Touchscreen
- Most regular things

[NOT WORKING]
- Bluetooth. Due to the fact that Google has introduced a new Bluetooth stack in 4.2, Bluetooth
*NOT* work. Efforts to get Bluetooth working has ended.

[CREDITS]
- Ejtagle
- Scanno
- CyanogenMod for their sources
- LeoP for his zRAM implementation
The Following 18 Users Say Thank You to scanno For This Useful Post: [ View ] Gift scanno Ad-Free
 
 
31st December 2012, 02:03 PM |#2  
[DOWNLOADS]

Gapps for android version 4.2.2: Goo.im Downloads - Downloading gapps-jb-20130301-signed.zip

Gapps for android version 4.2.1: gapps-jb-20121212-signed.zip

Here are some other Gapps that are specific for Tegra2 non neon devices. These Gapps fix the closing of the default keyboard. But it also disables the gesture typing. These GApps were made for the XOOM and can be downloaded over at XDA:
[ROM][4.2.2] My Android 4.2 for Xoom Wi-Fi (20130217) - xda-developers

[BUILD 20130815]
CWM-ZIP: http://www.mediafire.com/download/zu...AL-shuttle.zip
NVFLASH: http://www.mediafire.com/download/3j...AL-shuttle.exe

[BUILD 20130727]
CWM-ZIP: http://www.mediafire.com/?orvrlhdr5x58ahq

[BUILD 20130721]
CWM-ZIP: http://www.mediafire.com/download/rc...AL-shuttle.zip

[BUILD 20130712]
CWM-ZIP: http://www.mediafire.com/download/jz...AL-shuttle.zip

Build 18:
CWM-ZIP: http://www.mediafire.com/?u63rb3nt4dni37z

Build 17:
Only flash the CWM-ZIP if you already have a working Build 16 !!!
CWM-ZIP: http://www.mediafire.com/download.php?m2iakdr0x2j0lk0
NVFLASH: http://www.mediafire.com/?aeleqc618v21b3h

Build 16:
NVFLASH: CM10.1-Shuttle-P10AN01-build_16.exe

Build 15:
CWM-ZIP: CM10.1-Shuttle-P10AN01-build_15.zip
NVFLASH: CM101-Shuttle-P10AN01-build_15.exe

Alpha 10:
CWM-ZIP: CM10.1-Alpha10-Update.zip

Alpha 8:
CWM-ZIP: CM10.1-Alpha8-Update.zip

Alpha 7:
CWM-ZIP: CM10.1-Alpha7-Update.zip
NVFLASH: CM10-1_NVFlash_alpha7.exe

Alpha6:
CWM-ZIP: CM10.1-Alpha6-Update.zip


Alpha5:
CWM-ZIP: CM10.1-Alpha5-Update.zip
NVFLASH: CM10-1_NVFlash_Alpha5.exe
The Following 9 Users Say Thank You to scanno For This Useful Post: [ View ] Gift scanno Ad-Free
31st December 2012, 02:04 PM |#3  
[BUILD 20130815]
- Included a patch to dalvik for low memory devices.
- Synced with the CM10.1 repository

[BUILD 20130727]
- Synced with the CM10.1 repository

[BUILD 20130712]
- Synced with the CM10.1 repository
This version includes all the changes that the CM team has introduces, including
the privacy options.

Build 18:
- synced with the cm10.1 repository

Build 17:
- Synced with CM10.1 repo
- Two patches to the kernel from clemsyn that might solve some remaining SOD's

Build 16:
- This build will be the base that next builds will use !!!
- New partition layout. So only an NVFLASH version for build 16
- TWRP 2.5.0.0 recovery included
- Synced with CM10 repo


Build 15:
Well a lot of changes:
- synced with cm on march 7. 21:00 CET
- there should be no more SOD
- sdcard changes. EXT4 is now used as /data and as "internal" sdcard.
- a lot of optimalisations

Alpha 10:
- Android 4.2.2
- Refactored device make files

Alpha 8:
- 3G working

Alpha 7:
- Synced with CM repo on 13-01-2013
- Some more tweaking. Seems to work better. I have removed journaling from my sdcard and some more optimizing on my own sdcard. Perhaps i can do that in the update zip. Will have a loo at that.
- Included the RIL from VegaCream. Small change it will work. Cannot test myself.

Alpha6:
- Synced with CM repo on 04-01-2013
- Did some tweaking. Values can be changed as they are stored in /system/etc/init.d/rc1.d/01sysctl
The Following 3 Users Say Thank You to scanno For This Useful Post: [ View ] Gift scanno Ad-Free
1st January 2013, 01:05 AM |#4  
Member
Thanks Meter: 10
 
More
Nice to see, that you are working on a new ROM!
VegaBean ist not running stable. So i will go back to VegaCream!
( I'll hope that i can use 3G in this Case - if not - my modem is defekt. i'll see it. )
Pleas go on and don't stop working - so that i have many months fun with my new tablet!

Edit: After a few Test with the older ics Version, i will try to Test ths on. Ich think my 3g Modem is defekt.#


EDIT2: I have try to install this via CWM - First Result: BRICK. I landing in a bBootloop - now i will try to install this via the NVFLASH.
Damn, i flash my tab @Silvester - cause i am ill
I will report again

Edit3: After install via NVFLash i Brick the Tablet hard. Try the second time to install an older NVFLASH. No Chance, no way. Whats happen? I have no idea!
Damn i hope - i can fix this problem. but it seems hardly to solve!

Edi4: Try 4 flashs again. But every time its stucking at the point where i attached the picture below. After flashing bevor i do a reboot, is this screen showing me. But i cant read what is standing there on the top!

NEED HELP - PLEASE GIVE ME A SOLUTION... Will not brick my 6 day old tablet.


Edit5: I have start the tablet und forgott it by watching a film. What is happen? I see a screen and the OS.
But: the Problem 1 is: after restarting i have wait 15 minutes that the OS is start up.
Problem 2: The touchscreen isn't working. i cant touch nothing! so i have reflash again

Wait that the alpha is going to be a beta please keep on working!

Edit6: Okay, today i have found the cause of my problem. It was my problem! i have flash the rom in the first step wrong. So my Touchscreendriver are broken: With this Manual i solve the problem:
[GER] http://www.android-hilfe.de/point-vi...ml#post4332295
[ENG] http://www.modaco.com/topic/355021-m...iew-mobii-ect/

After this i flash this Alpha-Version new. And it is Insane FAST! For an Alpha very, very FAST and faster than the latest Version auf VegaBean. Only One thing is missing: The Playstore!
Now i'll try to Restore this.
In the Future, i'll hope that your work will going on.


FAZIT: THERE ARE NO PROBLEMS WITH THE ROM - IT WAS ALL MY FAULT! RUNNING VERY FAST AND ITS GOING IN THE RIGHT WAY! But only ONE SMALL bug, in the Craddle its reboot every 5 Minutes...
And shows me the error :"System UI" was accidently stopped ( in German is there standing: "Systen Ui" wurde beendet )
So i'll going back and will wait
Attached Thumbnails
Click image for larger version

Name:	WP_000110_bricked_screen.jpg
Views:	1015
Size:	152.2 KB
ID:	1608527  
2nd January 2013, 11:44 PM |#5  
DesertHawk's Avatar
Senior Member
Flag Dubai, United Arab Emirates
Thanks Meter: 5,215
 
Donate to Me
More
Nice. Will flash this 2moro and report back

Sent from my Nexus 4 using xda premium
3rd January 2013, 09:36 AM |#6  
Member
Thanks Meter: 0
 
More
Doesn't work.
I have tried flashing this about 12 times. It doesn't work. I have both files the nvflash and also the update. I have been able to flash beta6 just fine. but the nv alpha5 just sits on the boot tried leaving for 30 minutes no change tried over and over again. even tried isntalling beta6 and then doing the update to alpha5 with gapps and just got boot loop. Both of these files dont' work at all or in anyway. Again I have been installing this over and over and over and over and over this simply does NOT work.
3rd January 2013, 09:46 AM |#7  
Quote:
Originally Posted by Myah

I have tried flashing this about 12 times. It doesn't work. I have both files the nvflash and also the update. I have been able to flash beta6 just fine. but the nv alpha5 just sits on the boot tried leaving for 30 minutes no change tried over and over again. even tried isntalling beta6 and then doing the update to alpha5 with gapps and just got boot loop. Both of these files dont' work at all or in anyway. Again I have been installing this over and over and over and over and over this simply does NOT work.

Do you have a correctly partitioned sdcard?
3rd January 2013, 11:36 AM |#8  
Junior Member
Thanks Meter: 3
 
More
In my tablet infinite boot loop
3rd January 2013, 01:22 PM |#9  
Member
Thanks Meter: 6
 
More
this does work - use minitool partition wizard to create the EXT4 partition (i recommend 1gb)

http://download.cnet.com/MiniTool-Pa...-10962200.html
The Following 2 Users Say Thank You to bearkilla For This Useful Post: [ View ] Gift bearkilla Ad-Free
9th January 2013, 09:18 PM |#10  
Member
Thanks Meter: 10
 
More
Its working But following you have shoud to do:

Frist One:
- Flash The Beta 6 without the SDCARD in the Bay:
- Now Format your SDCard; First Partition FAT32, Secound Partition ext4. All Partition must SET UP as "PRIMARY"
- After this you can Copy the rom.zip on your FAT32 partition.
- Plugin your SDCARD in Tablet's SDBay and Reboot in CWM.
- With CWM you can flash the new ROM Now.

After this the Rom was working fine. Only the Reboots and the UI-Probs was getting on my nervs.
13th January 2013, 05:56 PM |#11  
New version posted. See second post.

Verstuurd van mijn Transformer Pad TF300T met Tapatalk
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes