FORUMS
Remove All Ads from XDA
Honor 7x
Win an Honor 7X!

[Fix]Unknown error code during application install: "-24"

10 posts
Thanks Meter: 197
 
By Qewbicle, Junior Member on 14th November 2012, 09:21 PM
Post Reply Email Thread
30th January 2013, 11:49 AM |#11  
Junior Member
Thanks Meter: 1
 
More
Thumbs up Working!
Thanx, it worked for me too!
I am on X8 with CM10 from NaA!!
 
 
4th February 2013, 01:30 PM |#12  
unknown_anonymous's Avatar
Member
Thanks Meter: 6
 
More
Quote:
Originally Posted by goldenninja

I'm also stuck. I was able to go to sdcard/data, but there is no second /data folder.

Anyone one you know anything about android..!?!?!?!
U need to root first...!!!
9th February 2013, 12:00 AM |#13  
krkeegan's Avatar
Senior Member
Flag Los Angeles
Thanks Meter: 68
 
More
Worked for me as well.

You need to use something like ES File Browser with Root access to get to /Data/Data
The Following 3 Users Say Thank You to krkeegan For This Useful Post: [ View ] Gift krkeegan Ad-Free
10th February 2013, 05:03 PM |#14  
Junior Member
Thanks Meter: 0
 
More
I'm running into this issue with a bunch of apps that got lost when flashing a newer CM10.1 nightly. I can't access those folders in data/data since ES File Manager is one of the apps that gets this error!

Is there any other way to fix this? I can't install anything, not even Chrome
16th February 2013, 03:00 AM |#15  
Junior Member
Thanks Meter: 2
 
More
It's worked for me, too!
Someone maybe didn't understand the meaning of the thread creater. You must have the root access. Then, open Root Explore and go to "data/data" NOT "sdcard/data/data"
The Following 2 Users Say Thank You to SlimAndwios For This Useful Post: [ View ] Gift SlimAndwios Ad-Free
18th February 2013, 03:42 AM |#16  
gastonw's Avatar
Senior Member
Thanks Meter: 1,773
 
More
Quote:
Originally Posted by SlimAndwios

It's worked for me, too!
Someone maybe didn't understand the meaning of the thread creater. You must have the root access. Then, open Root Explore and go to "data/data" NOT "sdcard/data/data"

Yeah, that's awesome, but how do you expect to get to that folder without a file explorer? because you cannot install one.....
24th February 2013, 07:16 PM |#17  
hunyadia's Avatar
Senior Member
Flag hungary
Thanks Meter: 19
 
More
Thumbs up
Thx mate, perfect!
Quote:
Originally Posted by Qewbicle

I don't know the cause. I have noticed that it has happened on different devices, there have been assumptions if it's because of a specific kernel or rom, although it may be, I beg to differ. I feel it is happening during the Android Upgrading Apps # of # process.

I noticed that this error pops up on most of the apps that I had installed, but are not there after my update. So far with me, it happened only to my paid apps, but not all of them.

When the app disappears, android thinks it's missing, but some files think it is still installed.

Regularly when you install an app over itself, there is a notice telling you that the application info will remain. That's where the problem lies once an app mysteriously disappears. Because part of it is still installed.

Go to

/data/data/

and search for your

com.application-address.whatever-it-may-be

28th February 2013, 12:47 AM |#18  
Junior Member
Thanks Meter: 7
 
More
Figure it out?
Quote:
Originally Posted by gastonw

Yeah, that's awesome, but how do you expect to get to that folder without a file explorer? because you cannot install one.....

I've got the same problem. Root explorer is one of the apps I didn't get back and ES won't give me access to data/data, and I am rooted BTW

---------- Post added at 06:47 PM ---------- Previous post was at 06:26 PM ----------

Quote:
Originally Posted by tt100b

I've got the same problem. Root explorer is one of the apps I didn't get back and ES won't give me access to data/data, and I am rooted BTW

In case it might help someone else I thought I'd pass along what I just did to fix the problem. I booted into recovery and found the com.speed.... file for root explorer that way and deleted it and then rebooted. I then was able to load and install root explorer from the play store and now I can sit back and delete all the rest of the apps that won't install correctly...

I guess I could have done it from recovery also but I forgot to write them all down before I rebooted!
The Following 2 Users Say Thank You to tt100b For This Useful Post: [ View ] Gift tt100b Ad-Free
14th March 2013, 03:06 PM |#19  
Junior Member
Flag sacramento
Thanks Meter: 6
 
More
Talking
Quote:
Originally Posted by Qewbicle

I don't know the cause. I have noticed that it has happened on different devices, there have been assumptions if it's because of a specific kernel or rom, although it may be, I beg to differ. I feel it is happening during the Android Upgrading Apps # of # process.

I noticed that this error pops up on most of the apps that I had installed, but are not there after my update. So far with me, it happened only to my paid apps, but not all of them.

When the app disappears, android thinks it's missing, but some files think it is still installed.

Regularly when you install an app over itself, there is a notice telling you that the application info will remain. That's where the problem lies once an app mysteriously disappears. Because part of it is still installed.

Go to

/data/data/

and search for your

com.application-address.whatever-it-may-be

Some of them you can tell what they are just by the names, the others, google-em.
If you wish to keep the information that it contains for the app, I recommend making a copy of it first.

Delete it

Install the application, it'll work, trust me.

Now replace it with your copy.

Done.

Stop factoring resetting if you don't want to. Of course, if you have a lot missing, it might be better.

If someone can automate this process by making something check the com.address to installed apps, that would be awesome.

Worked Like a Charm Thank you for you help
The Following User Says Thank You to rfj1979 For This Useful Post: [ View ] Gift rfj1979 Ad-Free
15th March 2013, 06:54 AM |#20  
Member
Nowhere
Thanks Meter: 0
 
More
can't find data
used es file explorer with root access can't find data/data
16th March 2013, 03:34 PM |#21  
Senior Member
Flag Singapore
Thanks Meter: 434
 
More
Worked great for me and saved my life!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes