Remove All Ads from XDA
Honor View 10

Guide Wifi Ad Hoc Working Samsung 10.1v

5 posts
Thanks Meter: 7
By drnackers, Junior Member on 17th May 2011, 01:14 PM
Post Reply Email Thread
18th December 2011, 08:50 AM |#51  
Junior Member
Thanks Meter: 0
Smile Another Solution
Hi All,

I have another solution if your phone/tablet supports wi-fi tethering you can act as a hotspot and connect your pc to your mobile device.
I have tested this and managed to perform a vnc connection from my SGSII to my Windows XP Laptop. There was no other connection between the devices.

If you turn on the wi-fi tethering and search for wireless network from your laptop/desktop you should see your Android Network. Finally, I haven't tested if i can share cable connected internet (Via LAN) or if more than one devices can connect to my android wi-fi network.

Be carefull!!! Close any 3G Internet connection in your phone/tablet or you'll be charged by your mobile Carrier.

Hope Helped,
11th January 2012, 09:47 PM |#52  
Junior Member
Thanks Meter: 0
Ad-Hoc on Galaxy Tab 10.1
I have a Verizon HDMA TP2 (Touch Pro 2) windows mobile phone. I have been wanting to teather it with my Galaxy Tab 10.1 which does not recognize Ad-Hoc. I have not had any luck thus far. My tab is rooted. I have WMWifi Router installed on this phone but it uses Ad-Hoc.........See my problem....
I have noticed many postings and directions on how to do this but wonder if they are referring to using an Android Phone connecting to an Android tab.

If anybody out there knows of a way to make this happen I am willing to listen.

Thank you,
16th January 2012, 07:03 PM |#53  
Junior Member
Thanks Meter: 0
Thank you, this is perfect and it worked first time with my retail Galaxy Tab 10.1 wifi only and my Sprint ET4G.

I couldn't get full file access with ES File Explorer but Root Explorer did the trick.

Thanks again.
7th March 2012, 12:33 PM |#54  
Junior Member
Thanks Meter: 0
Is there any way ( app or bug fix) to make the web browsing using 3g connection in full resolution like browsing using wifi ?
17th March 2012, 09:10 AM |#55  
Junior Member
Thanks Meter: 0
Unhappy help!
Originally Posted by Bashed

I got this thing to work eventually, everything you need to know is in this thread but there is a lot of stuff you don't need to know too so I hope to get this right first time. This is, I hope the definitive how to create ad hoc capability on your Samsung Galaxy Tab 10.1 without any noob confusion. There is some cut and paste from the thread here so thanks to the original authors.
Follow all these steps.

You will need;

1. a rooted SGT 10.1 - Do this by searching the forum for instructions. Do this first, then come back here and continue. [I do not know if or how it works on other devices - DON'T ASK]

2. ES File Explorer from the android Market

3. Download hacked the wpa_supplicant from this post to your SGT. [If you visit the page with your SGT, the file will download to 'home>download' on your device, if not, put it there yourself so it can be found later]


4. Open ES File Explorer and in settings menu select Root options. - menu>settings> tick root explorer and mount file system - say yes to popup.

5. Click the home button to get to your SGT home screen, tap the battery/wifi indicator at the bottom right of the home screen, select settings>wireless and networks and tick flight mode to on. [You can reboot here, it won't hurt]

6. Make sure airplane mode is on then using ES File Explorer on your SGT, navigate to 'system/bin to find the file called wpa_supplicant, do a long press on this file and select rename, keep the name but add .bak or.old to it so it is now called wpa_supplicant.bak or wpa_supplicant.old

7. Using ES File Explorer on your SGT 10.1 navigate to home>download and find the wpa_supplicant_wifi_adhoc folder, click it once to open it, long press on the file called wpa_supplicant and select copy.

8. Using ES File Explorer on your SGT 10.1 navigate back to system/bin then long press on an empty part of the screen and select paste. You should now have two wpa_supplicant files, one called wpa_supplicant.bak or wpa_supplicant.old and one called wpa_supplicant which is now the hacked version.

9. The wpa_supplicant needs to have the correct permissions to work properly so tap it twice, [don't open it] then with the file highlighted tap the file menu [3 lines at the bottom of the screen] select operations>properties>change, there are 9 boxes, make sure there is a green tick in all of the read column, all of the write column and the top line in the execute column. Like this


Click OK twice. [You can reboot here]

10. From the SGT home screen tap the battery/wifi indicator at the bottom right of the home screen, select settings>wireless and networks and tick flight mode to off. Turn on your phone's wifi sharing and hopefully your SGT will find it.

That's it. This is how I did it and it works with my Nokia N8 using Joikuspot premium, it should work with the free version too. GOOD LUCK!

OK, I followed all the steps, but probably at step 9 I ticked something wrong, now I don't have wifi at all..... .
I cannot remove, replace or change the file! (Read: yes; writ: no; hidden: no).

I also can't reset the GT P7510, Android 3.2, to the factory settings: network failure!

Who can help??
18th March 2012, 12:22 AM |#56  
Junior Member
Thanks Meter: 0
Problem solved
Problem "solved": just did a new installation of Android 3.2.
1st April 2012, 11:29 PM |#57  
Junior Member
Flag Morgantown, WV
Thanks Meter: 0
Cyanogenmod 9

I've flashed the Cyanogenmod 9 ROM to my GT10.1.

This method does not work for me. Maybe I'm doing something wrong, but I don't think so. After the hack, wifi will not turn on at all for me. Is anyone else having this trouble?
25th January 2013, 04:30 PM |#58  
Junior Member
Flag Rio de Janeiro
Thanks Meter: 0
Originally Posted by mrfrink

I followed the guide and now, i can access the internet via wifi-tethering through my Nexus One.

However, there is an issue when I set up an ad-hoc network via Ubuntu: When I try to connect to the ad-hoc network, my Galaxy Tab enters a loop: Obtaining IP address -> disconnect -> obtaining IP address ...
I tried it with both, an encrypted and an unencrypted ad hoc network.
Does anybody know a solution?

Hi, you need to use a DHCP server in your Ubuntu to provide an IP for you tablet. Or you can set a static IP.
Because, when your tablet connect in your adhoc network, it start to ask for an IP, so, if your Ubuntu does not
have a dhcp server, your tablet will never find an IP.

Sorry for my bad english
4th February 2013, 01:27 AM |#59  
Junior Member
Thanks Meter: 0
please tell me where the windows command ???
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes