Remove All Ads from XDA

(GOOGLE DOCS SPREADSHEET)ATT & Tmo IMEI thread/ Report issues & info here!

562 posts
Thanks Meter: 181
By androholic, Senior Member on 17th July 2012, 06:10 AM
Post Reply Email Thread
24th August 2012, 08:22 PM |#851  
Junior Member
Flag Los Angeles
Thanks Meter: 2
I had this problem but peoplearmy's system fixed me right up!

used Geek's method to backup NV tho just in case...i have backups everywhere now!
30th August 2012, 04:23 AM |#852  
Junior Member
Thanks Meter: 0
I have lost my IMEI on v05. I was able to reinject it, but can only connect to Edge (2G). Peoplearmy's tool does not succeed in generating a QCN - possibly due to being v05 vs v02?

Sent from my SAMSUNG-SGH-I747 using xda app-developers app
11th September 2012, 08:11 AM |#853  
HTC-187's Avatar
Flag Sacramento
Thanks Meter: 5
Is anyone else still having issues with lost IMEIs or not being able to get 3G/4G? or is this an official fix?

Also, just to add:

Originally Posted by Ratchet556

This happened to me last night and I don't think it has anything to do with the actual process of flashing the ROM. I had rooted and flashed recovery using the "dd" method and then flashed CM10 and CM9. Last night my battery died and after it was at 100% i turned it back on the BAM! no IMEI. So mine became corrupted out of no where. Not during rooting, not during flashing. I really hope we can sort this out because I want to be able to flash things on this without having to worry about this. Luckily it was pretty easy to go into a Bell store and get a new on

I had basically this exact thing happen to me. I flashed the root 66 stock Tar using ODIN. then i Tried to perform the OTA update and keep root. didn't work. So then I just used ODIN to flash the newer root 66 (which was basically the OTA with root). after that I decided to install Rom Manager and flash CWM and that went just fine. I did a Nandroid backup of my current ROM, cleared everyting, then flashed CM10 (CM-10-20120901-nightly-d2tmo). That was working fine, and overnight my phone batter died (I believe that it should have had enough battery to make it through the night). After charging my phone up a bit and turning it back on, I noticed I wasn't getting a signal. I check my phone info and my IMEI was definately gone (or changed, I can't remember 100%. I freaked out). I had already used the NV backup tool and tried to get into the qualcomm setting to restore my IMEI, however I coudn't access this on CM10. So I flashed back my original ROM, and BOOM!!! my IMEI was there... WTF?. I haven't tried anything since, but find this to be odd considering everything I read in this thread (yes, I read all 80 pages).

I have a SGH-T999 FYI
1st October 2012, 09:42 PM |#854  
irl9000's Avatar
Flag Austin
Thanks Meter: 14
Wow, so this thread has been quiet for 3 weeks. Does mean that PeoplesArmy has saved everyoneslife?
Or that the issue is stabilized???? I couldn't imagine a Sammy so sensitive to a flash job. And I would expect alot more instances still occurring.
Is it safe to go back in the water?
Edit- I do see PeoplesArmy thread has been visited as recently as the 30th. But still........
Sent from my SGH-I777 using xda app-developers app
4th October 2012, 04:38 AM |#855  
Flag San Antonio
Thanks Meter: 7
nope.....the guy whom mentioned the QCN issue.....hit the nail on the head i think. I re-injected my IMEI BUT i still am just stuck on EDGE...everything i have done has been completed successfully.....

my issue happened due to a ODEXing failure on FrostyJB now with IMEI injected....i need the next step....i been wondering if i copied another Tmobile Galaxy S2 or 3 EFS or IMEI folder then RE-Injected my backup IMEI over that?

OR like someone said would just ODIN fix everything? I have a good backup so i suppose im going to give it shot.....
5th October 2012, 12:44 AM |#856  
Junior Member
Portland, Oregon
Thanks Meter: 0
Donate to Me
hey folks just posting because I successfully injected my girlfriend's IMEI without a backup and got 4g back as if nothing was the matter. AT&T SGS3 here.

The whole process took me about four hours of trial and error, but it all worked out in the end, and peoplearmy's method works fine if you take each step carefully.

Here's what happened to me with her phone:

Flashed insecure boot for root, CWM, and busybox (all-in-one) by SGS3 Toolkit, did a nandroid.
Flashed MIUI, didn't like it.
Flashed AOKP jellybean.

Lost her IMEI during one of those steps. I realized after installing AOKP that she wasn't getting data, or at least it appeared to be stuck on "E" 95% of the time. Whenever she would reboot her phone, she would get 4g for a couple minutes before it would vanish. Her IMEI in About Phone > Status read as "0" at this time. ..restoring it to the first nandroid didn't restore her IMEI.

I tried unsuccessfully for awhile trying to get her phone into DIAG mode or whatever with the AOKP rom, but I couldn't get the scripts to execute properly in terminal emulator or perhaps I was doing it entirely wrong. Whatever the case, I restored the phone back to my first nandroid of the stock-rooted rom so I could use the stock dialer. Seemed like dialing *#7284# in the stock dialer was much easier, LOL.

Anyway, I put the phone into RMNET + DM + MODEM mode just fine. I made a backup of my QCN with QPSD and then opened the RF_NV_Manager. I searched for item number 550, but the key did NOT exist on her phone. Following instructions, I added the item. The nine boxes had no values.

Okay, so the thread peoplearmy started has "The IMEI is also listed in a special order so you must follow this guide to ensure your IMEI is correct." but there IS NO GUIDE or LINK as of yesterday other than the quoted text so this is the part that took me FOREVER to figure out. Lol. I tried writing random numbers and ****, and they would get her 4g LTE access for about 15 minutes before it would stop working again... eventually I figured out you need to reverse the numbers every two digits starting from the end, and add "a" to the last one.

not sure if posting her IMEI is a good idea so I'll do an example (your IMEI number is written underneath your battery). It's easier to do bottom to top in my opinion.

which is easier read as

6 57 09 10 51 09 42 76

should be input into the nine boxes as:
(first box is always 8)

1 (the 01 will make the zero vanish so don't worry. this threw me off at first.)

I don't have any clue as to what the original post or guide said about putting your numbers in properly, but this worked for me. It wrote successfully with RF_NV_Manager to her phone and I rebooted it. AND 4G WORKED!!! And her IMEI number in Settings > About phone > Status matched exactly to what was written under the battery!!

And uh, I didn't use the SGS3 Data Restorer App at all. I don't really understand what its purpose is, but perhaps others have used it to great success.
1st December 2012, 10:45 AM |#857  
Thanks Meter: 2
no matter what i do i cant get 4g, all i can get is edge...... i restored my imei, but i cant get 4g..............
11th December 2012, 01:02 PM |#858  
Inactive Recognized Developer
Flag Nottingham
Thanks Meter: 2,927
Donate to Me
I have a tool I made that lets you write IMEI direct to the device, converts it to hex and allows to write it to a qcn file.

It also backs up and restores the full range of NV items in CDMA Workshop format.

As for fixing data issues, I believe this is due to missing EVDO data and/or missing PRL.

I am currently working on this also.

Sent from my GT-I9305 using Tapatalk 2
21st December 2012, 07:05 AM |#859  
clninja's Avatar
Senior Member
Flag Denver
Thanks Meter: 361
Just lost my imei flashing a kernel.....

Just gonna do a warranty exchange.... easier to go back to stock and do warranty exchange than all of this.

Sent from my SGH-T999 using Tapatalk 2
6th February 2013, 07:30 AM |#860  
Flag Evansville
Thanks Meter: 7
Re: (GOOGLE DOCS SPREADSHEET)ATT & Tmo IMEI thread/ Report issues & info here!
Have the same issue going on. What do I need to do for a warranty exchange? Got it over the phone from att about 4 months ago. Its rooted obviously with cm.10.1 ROM. I don't have any backups saved or anything from when it wasn't rooted. Can I just unroot and then do a factory restore? I am hoping not to have to hook it up to a computer (no access to one at the moment).

Sent from my SAMSUNG-SGH-I747 using Tapatalk 2
25th February 2013, 07:05 AM |#861  
Junior Member
Thanks Meter: 2
Re: (GOOGLE DOCS SPREADSHEET)ATT & Tmo IMEI thread/ Report issues & info here!
Ty sir, saving this post in case I lose my IMEI

Sent from my SAMSUNG-SGH-I747
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes