[App]HTC CM Wifi Internet Sharing[21/07/2009]

5,326 posts
Thanks Meter: 148
By Noonski, Inactive Recognized Developer / Moderator Emeritus on 21st July 2009, 12:04 AM
Post Reply Email Thread
HTC CM Wifi Internet Sharing

Thanks To Tom_Codon For Sharing the Package from his New Tom Topaz Rom.

I resized and compressed The Graphics for VGA and Compressed The Exe File.

So this looks to be Working Without any Dependencies, Please Give feedback so others know where it is or isn't working.

I know people want this, so Getting it out there was Prime Directive. (Not sitting on something that will be out in a month or two, keeping it just for myself in roms i cook, sharing it)

Share Your Internet Connection As A Wifi HotSpot, Thank you HTC for looking at what users want.


It is adviced to install this with the Topaz CommManager as its an add on to a newer version.Does Not have a Shortcut in Programs because it has a Control Panel >> Connections entry!

QVGA Version By wapvirus + HTC Sroll
21st July 2009, 12:04 AM |#2  
Retired Moderator
Thanks Meter: 138
OK guys, I’ve collected all reports with links to the original reports. I only collected error reports of not being able to see the ad-hoc network created by the phone, NOT problems resulting from the lack of HTC Scroll.

PLEASE, when you do report FAILURE, try making sure alternative solutions all explained in my dedicated article ( ) (ICSControl, WalkingHotSpot or WMWifiRouter work. If they don’t, try installing kliptik’s ICS CAB and re-test all the apps. It’s only when they do work but HTC’s app doesn’t that you should send a failure report. Also, Omnia users will want to try the CAB at . (The latter can only be installed on genuine Omnias and nothing else, it seems.) Of the three, I recommend the WMWifiRouter trial (at ) as it’s much easier to use / configure than ICSControl and WalkingHotSpot doesn’t have a trial.)

If you report SUCCESS, make sure you do try the internet connection before doing so. Simply being able to install and start the app isn’t sufficient – you’ll also need to see (and connect to) the ad-hoc network it creates.

Also, please clearly state in all your success / failure posts the phone model and the ROM version you use. If you use a cooked (and not stock) ROM, make sure you also list the name / version of the cooked ROM. Thanks!

The state so far (07/23 13:00CET):


S-E Xperia X1 with Touch-It 7.1

HTC Kaiser WM6.5 PDACORNER ULTIMATE X2.V7 and 07/10[Super Ram][CHOME][Manilla] Josh's Kaiser Roms+Kitchen "21929 Hybrid" and TPC Elite V8 wm 6.5 build 21921

Samsung Omnia i900 and; the latter with

Samsung i910 omnia with the fix at . Note that this CAB,, file cannot be installed on other phones (tested this on my Universal).

Touch HD with Dutty's V3 XT, dutty's 3.9 turbo rom and Miri V19 WM 6.5 Build 21815

Touch pro with MightyROM 6 (WM 6.5)

HTC Touch Pro2 (german stock ROM) and ; another success report at and Also with with InterWrite 10.0 (Polish) / ROM: 1.19.401.0 (51489) WWE (dated 05/16/09) / Radio: / Protocol: 61.25t.25.19U / ExtPkg: 401.1739.12019.20655 . Also with uk stock rom

Diamond (WinMo 6.1 Pro build 21051 / ROM: Gen.Y D2 R1.1 / Radio: | Rilphone: Raphael / Hard-SPL: 1.93 OliNex) ; Sprint Diamond,, (w/latest stock ROM) and ; (MightyRom 6 (WM 6.5)) . Another Sprint user, with stock ROM, needed kliptik's cab for it to work . Also on German HTC Touch Diamond with Vodafone, ROM: WM6.5 SUN X - MANILA II [23004, rev2]

Topaz with stock ROM

Sprint Touch Pro with dcd 6.5 sys 23004 and EnergyROM 'Mercury' 21921 ; another success report with energy mercury rom at

AT&T Fuze WM 6.5 build 21921 ; with NATF's 4.7 ROM

Not working:

Diamond 1.93.405.1 WWE (origional) (origional) Orange UK ; Stock Rogers ROM 1.93 ; Verizon ROM 1.14.605.13

HTC Touch HD CE OS 5.2.20757 (Build 20757.1.4.0)

Sprint Touch Pro with stock rom ; another Sprint Touch Pro problem at , at (with WM6.1), at (stock rom) and (with mightyrom6 7-18) at

Verizon HTC Touch Pro with stock rom CE OS 5.2.20769 (build 20769.1.4.5) ; SSK 2.4

Alltel Touch Pro

Touch Pro wm6.1 build 20771

ATT FUZE ; HTC Fuze running WM 6.5 Pro (CE Os 5.2.21815 Build 21815.5.0.50)

Sprint Touch Pro, standard ROM version 1.03.651.4 ; another one with another standard ROM version

t-mo wing running JustHome v19

HTC Mogul Sprint WM 6.5


HTC TyTN II (ROM : shifu v11 Full / Radio : / SPL : cmonex 3.29 Hard)

HTC Wizard (character’s WM 6.1 AMP)

HTC Universal (WM6.1, Tomal’s 8.7)

HTC Advantage (AT&T; CE OS 5.2.19127 (Build 19217.1.0.6)) and HTC X7501 - ROM MiChy R6.1 WM6.1

Acer M9000

S-E Xperia X1 with stock rom
21st July 2009, 12:04 AM |#3  
Noonski's Avatar
OP Inactive Recognized Developer / Moderator Emeritus
Flag Amsterdam
Thanks Meter: 148
Donate to Me
There has been some posts in this thread, other threads and on other sites that got me a bit worried.
Especially a few comparisons between this HTC solution and Chainfire’s
WMWifiRouter solution.
CM internet sharing is a very simple solution that we have little to no control over. It’s nice to see that HTC is forced to innovate because of good ideas from developers. After letting users wait years for just such a solution, that should have been added a long time ago. And because it wasn’t added, a developer fills in the gap and makes the solution.
Looking at the response to Wifi sharing, it can be said that this is a much wanted and needed feature.
That said it is only logical that it has a market value.
Especially if it has more and better configuration options for some one that will actually NEED a solution like this.
XDA is not about getting everything for free, it is about understanding how things work and make them better and get them working on older devices.
And though not everyone might know this, but Chainfire is just the kind of developer that fills in the gaps that HTC refuses to fill, from working on Graphics drivers to releasing/opening GPS ports quicker and that nicely ported and Skinned Manila interface with CFC compression your probably looking at every day.
Yes getting stuff out there, that isn’t supposed to be out there, can be fun, unless it creates a reason for people to start vent their opinions in unfashionable manners.
So if you really like Wifi Sharing and believe it is something you really need, maybe it would be good to consider Actually buying a solution that can be configured. (personally i don't need Wifi Sharing but i do need a good alarm so i don't mind couching up some money for that)
And if you just want to try out the HTC version, then have fun with it.
But don’t go bitchin on someone’s hard work, or we will all find ourselves on a very boring XDA when there’s no one left to fill up the gaps HTC leaves behind.
I consider my enthusiasm to get CM internet Sharing out there a Fail towards someone I find has made more important contributions then mine to this forum, for that I am sorry.
21st July 2009, 12:04 AM |#4  
Noonski's Avatar
OP Inactive Recognized Developer / Moderator Emeritus
Flag Amsterdam
Thanks Meter: 148
Donate to Me
Some Q & AFound in the Thread
Temp Placeholder Q & A

Q: In running the app there's a possible resizing issue since you can't flick or otherwise use the DPad to go down. Regardless, you can still connect but my PC and another phone did not find the network that was supposed to be available when shared.[/QUOTE]

A: Don't Flick scroll Just press hold ad the heig of hwere your Provider connecction is mentioned and scroll a little bit up to get the rest of the menu.
A: If your using another phone to connect, you can find the Connection in the regular Wifi connection screen under "Computer to Computer" Connections.

Q: There is no Shortcut in Programs.
A: Initially the App can by found under Start Menu >> Control Panel >> Connections.

Q: Do we need to turn on the wifi in the device where the program is running?
A: The app starts the Wifi by itself.

Q: My PC or Laptop is not seeing the SSID.
A: For the people having trouble seeing the network, make sure your pc displays adhoc connections and not just access points.

Q: I have no menubuttons on a HTC TP2 (german stock ROM). Any ideas?[/QUOTE]
A: This app has a 0409.mui so it either needs that Mui translated to 0407 or a translated version, for now it's just English.

Wil this work on a QWVGA, QVGA or Non HTC Device.
A: There have been some confirms and spotted ports to Samsungs, so it is possible to make these versions

Q: I cannot scroll in any way?
A: It might be your rom is missing HTC Scroll package cooked in.

Beta Cab attached to Try, (since i can't right now ATM)

It places both Shortcut in Control Panel and in Programs.

Starting from Programs is regular
Starting from Control panel, will keep backlight on during use of app.

It Needs Mortscript Support in rom or installed by:

Do not link directly to this as it's just a test version.
Attached Files
File Type: cab XDA-Tom_Codon CM Wifi Internet Sharing - [Click for QR Code] (185.1 KB, 22441 views)
21st July 2009, 12:32 AM |#5  
Junior Member
Thanks Meter: 0
Very cool, thanks for the post!
21st July 2009, 12:32 AM |#6  
Noonski's Avatar
OP Inactive Recognized Developer / Moderator Emeritus
Flag Amsterdam
Thanks Meter: 148
Donate to Me
Translations and Versions
Rusian MUI posted by vadim_bogaiskov
Dutch MUI Posted By Mcune
French Cab Posted By faouzy42
21st July 2009, 01:37 AM |#7  
bugsykoosh's Avatar
Senior Member
Thanks Meter: 4
It installs fine and the initial screens are proper. In running the app there's a possible resizing issue since you can't flick or otherwise use the DPad to go down. Regardless, you can still connect but my PC and another phone did not find the network that was supposed to be available when shared. Any ideas? I'd love for this to work I can upload pics if needed.
21st July 2009, 02:29 AM |#8  
bedoig's Avatar
Senior Member
Thanks Meter: 119
Wow! Wouldn't have thought something like this would come from HTC. Very cool!
21st July 2009, 03:34 AM |#9  
Thanks Meter: 7
thank you. such a small file
21st July 2009, 03:50 AM |#10  
Thanks Meter: 7
Very cool! Just make a shortcut from the Windows file on the device and you are good to go. Works very well.
21st July 2009, 04:07 AM |#11  
Junior Member
Thanks Meter: 0
i downloaded the cab and put it on my TP. Installed the cab and then nothing. I tried to find it under "programs" and i couldn't find it. I tried installing it on the device and the storage card without any luck. what am i doing wrong? any and all help is appreciated. thanks!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes