Remove All Ads from XDA

[OBSOLETE] unofficial CyanogenMod 9/ClockworkMod Recovery 5 for Allwinner A10 devices

2,376 posts
Thanks Meter: 652
By fun_, Senior Member on 6th December 2011, 10:30 AM
Post Reply Email Thread
3rd September 2012, 02:24 PM |#771  
nyarnon's Avatar
Senior Member
Thanks Meter: 66
Originally Posted by fun_

I think you need to explain detail... at least about your A10 device and your TV before trying random things.

Originally Posted by fun_

my file for 4.0.4 is for 4.0.4, not for old en-us-NEW2-ak003.img. it may work, but no support.

I guess no usable TV mode can be detected... if you can use adb on CWM, please try to run "dispctl" command on adb shell, or please try another TV.

sorry for late reply.

Hmmm, Yes I suppose trying another TV will be the best option here. I will report back with the result.
8th September 2012, 03:36 PM |#772  
OP Senior Member
Thanks Meter: 652
Originally Posted by Christian Troy

this just let cedar compile (i did the same thing a couple of weeks ago), cedar fails here (while linking the static libraries):

target SharedLib: libCedarX (out/target/product/907/obj/SHARED_LIBRARIES/libCedarX_intermediates/LINKED/
/mnt/500G/A10/cm10/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.6/bin/../lib/gcc/arm-linux-androideabi/4.6.x-google/../../../../arm-linux-androideabi/bin/ld: ./external/cedarx/CedarX/../CedarAndroidLib/LIB_ICS_F23/libcedarxrender.a(subtitle_render_android.o): in function android::CedarXSub::startRender():(.text._ZN7android9CedarXSub11startRenderEv+0xdc): error: undefined reference to 'SkCanvas::setBitmapDevice(SkBitmap const&, bool)'
/mnt/500G/A10/cm10/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.6/bin/../lib/gcc/arm-linux-androideabi/4.6.x-google/../../../../arm-linux-androideabi/bin/ld: ./external/cedarx/CedarX/../CedarAndroidLib/LIB_ICS_F23/libcedarxrender.a(subtitle_render_android.o): in function android::CedarXSub::startRenderRegion(int, int, int, int):(.text._ZN7android9CedarXSub17startRenderRegionEiiii+0x118): error: undefined reference to 'SkCanvas::setBitmapDevice(SkBitmap const&, bool)'
/mnt/500G/A10/cm10/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.6/bin/../lib/gcc/arm-linux-androideabi/4.6.x-google/../../../../arm-linux-androideabi/bin/ld: ./external/cedarx/CedarX/../CedarAndroidLib/LIB_ICS_F23/libcedarxrender.a(subtitle_render_android.o): in function android::CedarXSub::CedarXSub(int, int, int, int):(.text._ZN7android9CedarXSubC1Eiiii+0x22c): error: undefined reference to 'SkCanvas::SkCanvas(SkDeviceFactory*)'
/mnt/500G/A10/cm10/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.6/bin/../lib/gcc/arm-linux-androideabi/4.6.x-google/../../../../arm-linux-androideabi/bin/ld: ./external/cedarx/CedarX/../CedarAndroidLib/LIB_ICS_F23/libcedarxrender.a(subtitle_render_android.o): in function android::CedarXSub::convertUniCode(SUBTITLE_ITEM_INF*):(.text._ZN7android9CedarXSub14convertUniCodeEP17SUBTITLE_ITEM_INF+0x170): error: undefined reference to 'ucnv_open_46'
/mnt/500G/A10/cm10/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.6/bin/../lib/gcc/arm-linux-androideabi/4.6.x-google/../../../../arm-linux-androideabi/bin/ld: ./external/cedarx/CedarX/../CedarAndroidLib/LIB_ICS_F23/libcedarxrender.a(subtitle_render_android.o): in function android::CedarXSub::convertUniCode(SUBTITLE_ITEM_INF*):(.text._ZN7android9CedarXSub14convertUniCodeEP17SUBTITLE_ITEM_INF+0x190): error: undefined reference to 'ucnv_open_46'
/mnt/500G/A10/cm10/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.6/bin/../lib/gcc/arm-linux-androideabi/4.6.x-google/../../../../arm-linux-androideabi/bin/ld: ./external/cedarx/CedarX/../CedarAndroidLib/LIB_ICS_F23/libcedarxrender.a(subtitle_render_android.o): in function android::CedarXSub::convertUniCode(SUBTITLE_ITEM_INF*):(.text._ZN7android9CedarXSub14convertUniCodeEP17SUBTITLE_ITEM_INF+0x21c): error: undefined reference to 'ucnv_convertEx_46'
/mnt/500G/A10/cm10/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.6/bin/../lib/gcc/arm-linux-androideabi/4.6.x-google/../../../../arm-linux-androideabi/bin/ld: ./external/cedarx/CedarX/../CedarAndroidLib/LIB_ICS_F23/libcedarxrender.a(subtitle_render_android.o): in function android::CedarXSub::convertUniCode(SUBTITLE_ITEM_INF*):(.text._ZN7android9CedarXSub14convertUniCodeEP17SUBTITLE_ITEM_INF+0x258): error: undefined reference to 'ucnv_close_46'
/mnt/500G/A10/cm10/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.6/bin/../lib/gcc/arm-linux-androideabi/4.6.x-google/../../../../arm-linux-androideabi/bin/ld: ./external/cedarx/CedarX/../CedarAndroidLib/LIB_ICS_F23/libcedarxrender.a(subtitle_render_android.o): in function android::CedarXSub::convertUniCode(SUBTITLE_ITEM_INF*):(.text._ZN7android9CedarXSub14convertUniCodeEP17SUBTITLE_ITEM_INF+0x260): error: undefined reference to 'ucnv_close_46'
/mnt/500G/A10/cm10/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.6/bin/../lib/gcc/arm-linux-androideabi/4.6.x-google/../../../../arm-linux-androideabi/bin/ld: ./external/cedarx/CedarX/../CedarAndroidLib/LIB_ICS_F23/libcedarxrender.a(subtitle_render_android.o): in function android::CedarXSub::convertUniCode(SUBTITLE_ITEM_INF*):(.text._ZN7android9CedarXSub14convertUniCodeEP17SUBTITLE_ITEM_INF+0x628): error: undefined reference to 'ucnv_close_46'
collect2: ld returned 1 exit status
make: *** [out/target/product/907/obj/SHARED_LIBRARIES/libCedarX_intermediates/LINKED/]
edit: i've get rid of skia with something really nasty... adding those functions to skia sources, i'll see if it breaks anything (i guess it will, but it's worth a try)... the other thing is from ICU, i'll see where are its' sources and try to do the same thing

probably cedar's subs will be borked but hopefully it will load, allowing camera and hw playback

edit2: that _46 refers to the icu version 4.6 and in JB it's 4.8, i guess replacing the whole icu with ics' will be a total fail

edit3: maybe i've found a less intrusive way... i've renamed ics' icu4c library appending a _ics suffix and linking cedarx to libicuuc_ics, in this way it worked now i'll have to see if it loads... i'm doing a nandroid backup right now
did you already try this one?

(I don't know detail about it...just asking)
27th September 2012, 07:41 PM |#773  
phil0sophic's Avatar
Senior Member
Flag Heber Springs
Thanks Meter: 40
Where can I find the latest CWM recovery version?
25th October 2012, 11:30 PM |#774  
dcoelho's Avatar
Senior Member
Flag Lisboa
Thanks Meter: 7
Hi. Is there a CWM recovery. for:
MAPAN MX913 - 9" AllWinner A13 and similars?

I tested some for A10 bt no luck..
21st November 2012, 05:38 AM |#775  
Thanks Meter: 18

Tablet is a Chinese Type Mid 7 "Android OS 4.0, 1.5 GHz processor, 512mb ram and 4 GB of internal memory. Type: A10 Serial:20080411. Disassembled on the motherboard number A291 MID-rev1.0, original rom (???) One day Android boot loop. Nowadays We are beyond about 20-25 rom I tried it on the plane."( sun4i_crane_pfd7__0505 )" This's rom It works well all sensor and touch screen. Display off by 1 cm below the right. Another ROM Display It works well "(sun4i_crane_q701_cpt_20120417 )" all the sensor does not work.I installed a CWM works well. I installed CyanogenMod9 ( ainol NOVO7 Advanced/AdvancedII/Aurora/Elf ) by fun_. I installed CyanogenMod 10 for many AllWinner A10 tablets by Christian Troy. Not work touch g-sensor / giroszkóp.

Please help!

I'm sorry Google Translate

12th June 2013, 05:09 PM |#776  
Flag Tetouan <3
Thanks Meter: 58
can you help me to get a recovery, I'm on stock 4.1.1 jb .. Allwinner A10, 1Gb DDR3 ram, 400mali, 10.1 screen, 16Gb storage
Attached Thumbnails
Click image for larger version

Name:	20130610_201805.jpg
Views:	171
Size:	255.5 KB
ID:	2037384  
Post Reply Subscribe to Thread


Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes