Remove All Ads from XDA

Reverting to official RUU with HardSPL

19 posts
Thanks Meter: 3
By flipside123, Junior Member on 28th August 2008, 09:53 PM
Thread Deleted Email Thread
6th December 2008, 10:49 PM |#11  
Senior Member
Thanks Meter: 11
This is stupid easy to do... im shocked there isnt a post going into detail.
5 steps to going back.
22nd December 2008, 06:03 PM |#12  
Flag Inglis, Florida
Thanks Meter: 0
Originally Posted by smokeingit

This is stupid easy to do... im shocked there isnt a post going into detail.
5 steps to going back.

Did not work. Do I need to install the cab files again? I know I deleted a file out of the stock rom so it would not overwrite or verify or something but I put that file back, should I not have? This has been a few weeks and still can't get the yang off. Screen on my girls phone is almost dead, she can't even slide it any more so I need to fix the spl so I can send back to t-mobile....anyone ?
6th January 2009, 07:25 AM |#13  
Smoke362's Avatar
Flag Kansas City, MO
Thanks Meter: 2
this is what i do to get back to the tmobile orginal. download the software from tmobile. I downloaded the newest update from tmobile site. REMOVE YOUR SD CARD. Connected my phone via usb. Launched the update. It has never failed me yet. It is just like updating your phone. tmobile has to take it, it is their update. They sent me a new phone noproblem, matter of fact i have to do it again, the back on the phone keeps getting loose on me. so they are sending me another phone again. hope this helps.
12th January 2009, 07:10 PM |#14  
Junior Member
Thanks Meter: 0
Alternatively you can use the combination of uspl and stock rom ruu to return your device to stock tmobile rom...

1. Enter in to uspl like you were falshing one of ttran001 roms... You can get this HERALD-USPL-beta3 from

2. ONLY use steps 1 and 2 from the black screen (getting the white screen on your device)...

3. For step 3 in the flasher exit out of the black screen (windows cmd screen) by pressing ctrl+C...

4. Fire up the official ruu from tmobile found here or alternatively if you have a tmobile account still active you can get the most up to date rom from

5. Fallow on screen instructions...

6. Back to stock rom...
18th January 2009, 02:08 PM |#15  
Junior Member
Thanks Meter: 0
Question Brick dopod C858
Originally Posted by ttran001


Remove HARD-SPL On The Wing

This is the same tool used to flash your device when it was not HARD-SPL.
I replaced the RUU_Signed file and SPL.nh file already.

It will bring your wing back to the stanard rom as when you first got it.

Hello freind,

I have been downloaded the above "Remove_HARD-SPL_On_The_Wing.rar" files and flash it to my Dopod C858 which has the Chiness language, I suppose to change the language from chinesse to Englis, After flashing the above files, now the phone is only in bootloader mode.
If you start the phone it will stuck on white screen and turn off.

Please help me how to revive my phone back.

Thanks and best regards

10th March 2009, 04:39 AM |#16  
QwErTy1235's Avatar
Junior Member
Flag Brooklyn
Thanks Meter: 0
Hey I'm having the same problem as most of these guys who tried the file. The phone just idles on the white Tmobile screen... does anyone know what to do or how to help?

Please and thank you!
7th August 2009, 01:47 PM |#17  
Flag Easton
Thanks Meter: 5
Originally Posted by angest90

wen i did this i think i bricked my fone now its at the tmobile screen and it jus staying there

im having the same problem can anyone help me please?
7th August 2009, 02:08 PM |#18  
ivanmmj's Avatar
Retired Moderator
Thanks Meter: 49
Donate to Me
Originally Posted by hotsammysliz

im having the same problem can anyone help me please?

Being stuck at the Tmobile screen isn't a true brick. Just reflash your ROM. (If you're not HardSPL'd, reflash your RUU.)
10th April 2011, 07:36 PM |#19  
Junior Member
Thanks Meter: 0
Remove Hard SPL from bootloader

Anyone out there knows if we can remove hardspl from bootloader of Wing. Problem is my mobile displays splash screen, then switch offs by itself. Its been quite some time that I have hardspled it and have been using it. But recently I am facing this issue, so I am trying to move to original RUU and try if it works.

So for that anyone knows if we can remove hardspl from bootloader, because I am only able to enter bootloader. Moreover I tried several original roms from Flash Center as well as through SD card as well, but still be SPL version is 4.70.yang. Anyone knows any other alternative.

Also, if anyone has faced similar problem then kindly advice how you resolved.

Thanks in advance!

Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes