FORUMS
Remove All Ads from XDA

[ROM][CM10][CM10.1][CM-10.2][CM-11.0][GT-S7710] Samsung X Cover 2

101 posts
Thanks Meter: 163
 
By flxo, Senior Member on 29th July 2013, 07:38 PM
Post Reply Email Thread
This is a dedicated thread for the CM10, CM10.1 and CM10.2 port for the Samsung X Cover 2 (GT-S7710). The port is in a beta state. The source is based on the CM port for golden from OliverG96!

Recovery

A working CWM port with minor issues is discussed and available here.

Download

All files are available here or here.

Changelog CM 10:
  • 2013/07/26: Initial preview
  • 2013/07/27: Fixed Wifi
  • 2013/07/29: Fixed GPS
  • 2013/09/04: Userdebug build to get rid of red frame
  • discontinued, but porting changes for the camera, USB etc from cm-10.1 branch should not be a big deal

Changelog CM 10.1:
  • 2013/09/15: Alpha release 0:
    • Phone and mobile data
    • GPS
    • WIFI (tethering is untested and probably broken)
    • Bluetooth (tested a2dp and a headset/car)
    • Audio (EQ is untested)
    • Front and rear camera work. Video recording is broken!
    • USB MTP works. PTP is untested.
    • SD card
    • adb
    • Flash light
    • Video playback is broken.
  • 2013/09/30: Alpha release 1:
    • Fixed video playback and recording.
    • CM updates and account wizard added.
  • 2013/10/14: Alpha release 2:
    • AOSP lpm animation
    • Updated video processing (Thanks Oliver)
    • CM Updates
  • 2013/10/20: Alpha release 3:
    • Fixed Torch
    • Removed automatic brightness menu
  • 2013/10/27: Alpha release 4:
    • Fixed WIFI tethering

Changelog CM 10.2:
  • 2013/11/02: Alpha release 5:
    • Bump to CM 10.2 - same functionality as in Alpha 4.
    • CWM build on cm-10.2 branch is broken - use from cm-10.1 if needed.... fixed.
  • 2013/11/19: Alpha release 6:
    • CM Updates
    • Added fix for low volume in incoming calls (Thanks Oliver!)
    • Some source cleanup
  • 2013/11/24: Alpha release 7:
    • CM Updates: Wallpaper, Bootanimation
  • 2013/12/05: Alpha release 8:
    • CM: Build with cm-10.2 stable sources
  • 2014/01/12: Alpha release 10:
    • CM: Source update.
  • 2014/02/04: Alpha release 11:
    • CM: Source update.
    • Fixed random reboots.

Changelog CM 11.0:
  • 2013/12/31: Alpha release 9:
    • Preview CM11 image. OMX/Camera is broken. Just for testing and not ready for daily usage. Needs latest recovery and full wipe.

Known Issues
  • BT hands free. Connection/pairing works, but the audio path is broken.
  • stock MMS app


Source

The source is stored in my github account.

Questions and Bug

Please do not contact me directly if you encounter bugs or you have questions about the port. When you're not yet allowed to post is this thread - post somewhere else, but don't send me a PM. Thanks for that.

Disclaimer

Don't flash this image unless you really know what you're doing! I'm not responsible for any damage what-so-ever done to your phone, as with any ROM, you accept this risk. You use this software at your own risk.

Thanks to:

OliverG96 for his CM10/CM10.1/CM10.2 port of golden.
TeamCanjica for the u8500 common stuff.
TheBoegl for hosting the images
The Following 61 Users Say Thank You to flxo For This Useful Post: [ View ] Gift flxo Ad-Free
 
 
29th July 2013, 08:00 PM |#2  
Member
Thanks Meter: 2
 
More
You're great, its super

That's the problem with me -
The Following User Says Thank You to p.Lipov For This Useful Post: [ View ] Gift p.Lipov Ad-Free
29th July 2013, 09:02 PM |#3  
Member
Flag Oberhof / Thuringia
Thanks Meter: 3
 
More
And again you did a very good job
Can I flash the new rom with GPS like an update, so that i do not have to install everything again?^^ just wipe cache and dalvik and leave the rest as it is?
Btw now the camera is the last thing missing for my holiday^^, then I can test your rom for 2 weeks outdoor

So keep on your excellent work

after flashing your latest rom, there is sometimes a red frame around the display.
30th July 2013, 05:14 PM |#4  
Member
Thanks Meter: 2
 
More
Hello, I used the new Custom ROM, I liked but did not know why constantly loses coverage of the mobile operator. I have not tried GPS, WIFI is working well.
I hope you like comment on Custom ROM to help clear the error that occurred. This is not a criticism. I have great respect for you and what you do with it.
Cheers.
31st July 2013, 12:48 PM |#5  
Member
Flag Oberhof / Thuringia
Thanks Meter: 3
 
More
BTW battery lifetime is much better than on stock rom. 6 h without charging, gps and wifi off, a lot of facebook, whatsapp, email and some gaming, 91% left seems to be that you can use the Xcover now for a couple of days without charging
31st July 2013, 08:28 PM |#6  
OP Senior Member
Flag Munich
Thanks Meter: 163
 
More
Quote:
Originally Posted by p.Lipov

Hello, I used the new Custom ROM, I liked but did not know why constantly loses coverage of the mobile operator. I have not tried GPS, WIFI is working well.

Thanks for testing! I didn't notice any difference by now - the link has been pretty poor with the stock image as well. I'll put it on my list and make a comparison. Anyone knows a app to plot the link quality?

cheers,

flxo
The Following User Says Thank You to flxo For This Useful Post: [ View ] Gift flxo Ad-Free
31st July 2013, 08:34 PM |#7  
OP Senior Member
Flag Munich
Thanks Meter: 163
 
More
Quote:
Originally Posted by aufdroge

And again you did a very good job
Can I flash the new rom with GPS like an update, so that i do not have to install everything again?^^ just wipe cache and dalvik and leave the rest as it is?

In this special case: yes. The image from the 29th just has one config file added. Sometimes it's simple

Quote:

after flashing your latest rom, there is sometimes a red frame around the display.

Yep. I noticed that also. No concrete idea where it comes from but I think there's a problem with the settings provider....

cheers,

flxo
The Following User Says Thank You to flxo For This Useful Post: [ View ] Gift flxo Ad-Free
1st August 2013, 10:48 AM |#8  
Member
Flag Oberhof / Thuringia
Thanks Meter: 3
 
More
GPS is not working for me, any idea how to fix it?

Sent from my GT-S7710 using xda app-developers app
1st August 2013, 05:51 PM |#9  
Junior Member
Thanks Meter: 1
 
More
Camera and flashlite(torch) not work
USB connection - windows cannot find drivers
Red frames around display

Wifi ok
Gps ok
Bt not tested

Nice work, thx
2nd August 2013, 03:16 PM |#10  
OP Senior Member
Flag Munich
Thanks Meter: 163
 
More
Hi guys,

thanks for testing! I will be off for a week. So maybe you can fix some issues in the meantime?

cheers,

flxo
6th August 2013, 07:49 AM |#11  
Member
Thanks Meter: 2
 
More
I like the Custom ROM. I can not wait to get the new clean fix. Phone with him is not the same, it is great. Thank flxo
Post Reply Subscribe to Thread

Tags
xcover-2

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes