[S4][DEVs only] Zoe development

1,145 posts
Thanks Meter: 1,555
 
Post Reply Email Thread
Using this mod: http://forum.xda-developers.com/show....php?t=2436347
we are currently stuck here (no front camera and zoom bug), enabling front camera we got this:

Code:
E/        (  274): [AWB Calibration] read fuse ID fail
E/mm-camera(  274): [sensor_getVersion] get version fail
E/mm-camera(  274): MCTL_COMPID_ACTUATOR handle is NULL
E/QCameraHWI_Parm(  260): Video HDR mode is not supported for this sensor
W/QCameraHWI_Parm(  260): setVideoMode is not supported if PHOTO MODE
W/QCameraHWI_Parm(  260): setVideoMode is not supported if PHOTO MODE
W/QCameraHWI_Parm(  260): android::status_t android::QCameraHardwareInterface::captureModeInitConfig(): other capture mode 1
D/Vold    (  245): Receive camera burst event
E/mm-camera(  274): MCTL_COMPID_ACTUATOR handle is NULL
W/S_CameraController( 4045): OIS is not supported.
W/S_CameraController( 4045): Video slow motion is not supported.
W/S_CameraController( 4045): Video Stabilization is not supported.
W/S_CameraController( 4045): Video 720p 60fps is not supported.
W/S_CameraController( 4045): Video HDR is not supported.
W/S_CameraController( 4045): Photo HDR is not supported.
E/S_CameraController( 4045): SupportedList.FlashMode == null
W/S_ZoeController( 4045): exitZoeMode() - Zoe mode is not entered
D/Property( 4045): [ICaptureResolutionManager.PhotoResolution] PHOTO_16_9_3264x1840(3264x1840) -> PHOTO_4_3_640x480(640x480)
D/Property( 4045): [ICaptureResolutionManager.VideoResolution] QHD(960x544) -> VGA(640x480)
E/S_CameraController( 4045): not support FlashMode !!
E/QCameraHWI_Parm(  260): Video HDR mode is not supported for this sensor
W/QCameraHWI_Parm(  260): setVideoMode is not supported if PHOTO MODE
W/QCameraHWI_Parm(  260): setVideoMode is not supported if PHOTO MODE
W/QCameraHWI_Parm(  260): android::status_t android::QCameraHardwareInterface::captureModeInitConfig(): other capture mode 1
E/QCameraHWI_Parm(  260): android::status_t android::QCameraHardwareInterface::setFocusMode(const android::CameraParameters&):Could not look up str value
E/QCameraHWI_Parm(  260): Invalid focus mode value: continuous-picture -> need framework fix, but it's not a big problem
E/QCameraHWI_Parm(  260): android::status_t android::QCameraHardwareInterface::setParameters(const android::CameraParameters&): 2171, rc = -22
D/Vold    (  245): Receive camera burst event
E/mm-camera(  274): MCTL_COMPID_ACTUATOR handle is NULL
E/S_CameraController( 4045): setParameters exception -> it should be important
E/mm-camera(  274): camif_client_set_params: camif has associated with obj mask 0x1
E/mm-camera(  274): config_MSG_ID_RESET_ACK CAMIF_PARAMS_ADD_OBJ_ID failed -1 
F/libc    (  274): Fatal signal 11 (SIGSEGV) at 0x00000000 (code=1), thread 4116 (mm-qcamera-daem) -> i think it's crashing because of other problems
I/DEBUG   (  257): debuggerd: 2013-09-20 03:00:40
I/DEBUG   (  257): *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
I/DEBUG   (  257): Build fingerprint: 'htc/htc_europe/ville:4.2.2/JDQ39/240250.1:user/release-keys'
I/DEBUG   (  257): Revision: '3'
I/DEBUG   (  257): pid: 274, tid: 4116, name: mm-qcamera-daem  >>> /system/bin/mm-qcamera-daemon <<<
....
I/DEBUG   (  257): backtrace:
I/DEBUG   (  257):     #00  pc 00000000  <unknown>
I/DEBUG   (  257):     #01  pc 0005ce0d  /system/lib/liboemcamera.so
I/DEBUG   (  257):     #02  pc 0002484d  /system/lib/liboemcamera.so
I/DEBUG   (  257):     #03  pc 0000e4b8  /system/lib/libc.so (__thread_entry+72)
I/DEBUG   (  257):     #04  pc 0000dba4  /system/lib/libc.so (pthread_create+160)
I/DEBUG   (  257): 
I/DEBUG   (  257): stack:
I/DEBUG   (  257):          4078e800  0003eed4  
I/DEBUG   (  257):          4078e804  4043ce21  /system/lib/liboemcamera.so (vfe_config_mode+732)
I/DEBUG   (  257):          4078e808  00000005  
I/DEBUG   (  257):          4078e80c  404a32c0  
I/DEBUG   (  257):          4078e810  00000001  
I/DEBUG   (  257):          4078e814  4078e88c  [stack:4116]
I/DEBUG   (  257):          4078e818  00000000  
I/DEBUG   (  257):          4078e81c  407b738c  [stack:4116]
I/DEBUG   (  257):          4078e820  40436179  /system/lib/liboemcamera.so
I/DEBUG   (  257):          4078e824  4043909d  /system/lib/liboemcamera.so
I/DEBUG   (  257):          4078e828  40438e7d  /system/lib/liboemcamera.so
...
E/mm-camera( 4144): qcamsvr_load_gesture_lib Error opening gesture library
E/mm-camera( 4144): Cannot init Gesture library -> missing libs? not a big problem btw
W/S_OperationTimeoutController( 4045): [Timeout] Name : Start preview
W/S_OperationTimeoutController( 4045): [Timeout] Start time : 1379638840004
W/S_OperationTimeoutController( 4045): [Timeout] Timeout : 5000
W/S_OperationTimeoutController( 4045): [Timeout] Call-back executor : [email protected]
W/S_HTCCamera( 4045): notifyCameraThreadBlocked(BlockedInCameraDriver)
W/S_HTCCamera( 4045): onCameraThreadBlocked(BlockedInCameraDriver)
W/S_AutoFocusController( 4045): unlockAutoFocus() - Null handle
W/S_ImageSettingsController( 4045): unlockAutoExposure() - Null handle
W/S_ImageSettingsController( 4045): unlockAutoWhiteBalance() - Null handle
W/S_HTCCamera( 4045): onPause() - mIsUIReady = false
W/AudioService(  920): stream was not muted by this client
E/AudioService(  920): Could not get client death handler for stream: 5
W/S_HTCCamera( 4045): onPause mIdle is false
W/S_HTCCamera( 4045): OnPause - Freeze UI !!!
W/S_HTCCamera( 4045): doOnPause() - start
W/S_HTCCamera( 4045): stopAccelerometer() - isAccelerometerStarted = false
W/S_HTCCamera( 4045): OnPause - hide UI, set mMainLayout invisible
W/S_HTCCamera( 4045): doOnPause() - end
E/mm-libcamera2(  260): mm_camera_stream_fsm_reg: ioctl VIDIOC_STREAMON failed: rc=-1
E/mm-libcamera2(  260): mm_camera_ch_fn: Failed in STREAM ON
E/mm-libcamera2(  260): mm_camera_action_start: rc=-1 -> very important
E/QCameraHWI_Still(  260): android::status_t android::QCameraStream_Snapshot::startStreamZSL(): Failure starting ZSL stream
E/mm-camera( 4144): qcamsvr_find_mctl_inst: no match for mctl_id = 1
E/mm-camera( 4144): qcamsvr_process_server_node_event: MSM_V4L2_* - cannot find mctl, id = 1 -> it should be important
is there a dev that already encountered this problem, and can help us?
@ImagioX1 @E.Cadro @olvrick @Turge @Zarboz
The Following 6 Users Say Thank You to pirlano For This Useful Post: [ View ] Gift pirlano Ad-Free
20th September 2013, 02:37 PM |#2  
Zarboz's Avatar
Known Scammer
Flag Denver
Thanks Meter: 9,259
 
Donate to Me
More
Quote:
Originally Posted by pirlano

Using this mod: http://forum.xda-developers.com/show....php?t=2436347
we are currently stuck here (no front camera and zoom bug), enabling front camera we got this:

Code:
E/        (  274): [AWB Calibration] read fuse ID fail
E/mm-camera(  274): [sensor_getVersion] get version fail
E/mm-camera(  274): MCTL_COMPID_ACTUATOR handle is NULL
E/QCameraHWI_Parm(  260): Video HDR mode is not supported for this sensor
W/QCameraHWI_Parm(  260): setVideoMode is not supported if PHOTO MODE
W/QCameraHWI_Parm(  260): setVideoMode is not supported if PHOTO MODE
W/QCameraHWI_Parm(  260): android::status_t android::QCameraHardwareInterface::captureModeInitConfig(): other capture mode 1
D/Vold    (  245): Receive camera burst event
E/mm-camera(  274): MCTL_COMPID_ACTUATOR handle is NULL
W/S_CameraController( 4045): OIS is not supported.
W/S_CameraController( 4045): Video slow motion is not supported.
W/S_CameraController( 4045): Video Stabilization is not supported.
W/S_CameraController( 4045): Video 720p 60fps is not supported.
W/S_CameraController( 4045): Video HDR is not supported.
W/S_CameraController( 4045): Photo HDR is not supported.
E/S_CameraController( 4045): SupportedList.FlashMode == null
W/S_ZoeController( 4045): exitZoeMode() - Zoe mode is not entered
D/Property( 4045): [ICaptureResolutionManager.PhotoResolution] PHOTO_16_9_3264x1840(3264x1840) -> PHOTO_4_3_640x480(640x480)
D/Property( 4045): [ICaptureResolutionManager.VideoResolution] QHD(960x544) -> VGA(640x480)
E/S_CameraController( 4045): not support FlashMode !!
E/QCameraHWI_Parm(  260): Video HDR mode is not supported for this sensor
W/QCameraHWI_Parm(  260): setVideoMode is not supported if PHOTO MODE
W/QCameraHWI_Parm(  260): setVideoMode is not supported if PHOTO MODE
W/QCameraHWI_Parm(  260): android::status_t android::QCameraHardwareInterface::captureModeInitConfig(): other capture mode 1
E/QCameraHWI_Parm(  260): android::status_t android::QCameraHardwareInterface::setFocusMode(const android::CameraParameters&):Could not look up str value
E/QCameraHWI_Parm(  260): Invalid focus mode value: continuous-picture -> need framework fix, but it's not a big problem
E/QCameraHWI_Parm(  260): android::status_t android::QCameraHardwareInterface::setParameters(const android::CameraParameters&): 2171, rc = -22
D/Vold    (  245): Receive camera burst event
E/mm-camera(  274): MCTL_COMPID_ACTUATOR handle is NULL
E/S_CameraController( 4045): setParameters exception -> it should be important
E/mm-camera(  274): camif_client_set_params: camif has associated with obj mask 0x1
E/mm-camera(  274): config_MSG_ID_RESET_ACK CAMIF_PARAMS_ADD_OBJ_ID failed -1 
F/libc    (  274): Fatal signal 11 (SIGSEGV) at 0x00000000 (code=1), thread 4116 (mm-qcamera-daem) -> i think it's crashing because of other problems
I/DEBUG   (  257): debuggerd: 2013-09-20 03:00:40
I/DEBUG   (  257): *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
I/DEBUG   (  257): Build fingerprint: 'htc/htc_europe/ville:4.2.2/JDQ39/240250.1:user/release-keys'
I/DEBUG   (  257): Revision: '3'
I/DEBUG   (  257): pid: 274, tid: 4116, name: mm-qcamera-daem  >>> /system/bin/mm-qcamera-daemon <<<
....
I/DEBUG   (  257): backtrace:
I/DEBUG   (  257):     #00  pc 00000000  <unknown>
I/DEBUG   (  257):     #01  pc 0005ce0d  /system/lib/liboemcamera.so
I/DEBUG   (  257):     #02  pc 0002484d  /system/lib/liboemcamera.so
I/DEBUG   (  257):     #03  pc 0000e4b8  /system/lib/libc.so (__thread_entry+72)
I/DEBUG   (  257):     #04  pc 0000dba4  /system/lib/libc.so (pthread_create+160)
I/DEBUG   (  257): 
I/DEBUG   (  257): stack:
I/DEBUG   (  257):          4078e800  0003eed4  
I/DEBUG   (  257):          4078e804  4043ce21  /system/lib/liboemcamera.so (vfe_config_mode+732)
I/DEBUG   (  257):          4078e808  00000005  
I/DEBUG   (  257):          4078e80c  404a32c0  
I/DEBUG   (  257):          4078e810  00000001  
I/DEBUG   (  257):          4078e814  4078e88c  [stack:4116]
I/DEBUG   (  257):          4078e818  00000000  
I/DEBUG   (  257):          4078e81c  407b738c  [stack:4116]
I/DEBUG   (  257):          4078e820  40436179  /system/lib/liboemcamera.so
I/DEBUG   (  257):          4078e824  4043909d  /system/lib/liboemcamera.so
I/DEBUG   (  257):          4078e828  40438e7d  /system/lib/liboemcamera.so
...
E/mm-camera( 4144): qcamsvr_load_gesture_lib Error opening gesture library
E/mm-camera( 4144): Cannot init Gesture library -> missing libs? not a big problem btw
W/S_OperationTimeoutController( 4045): [Timeout] Name : Start preview
W/S_OperationTimeoutController( 4045): [Timeout] Start time : 1379638840004
W/S_OperationTimeoutController( 4045): [Timeout] Timeout : 5000
W/S_OperationTimeoutController( 4045): [Timeout] Call-back executor : [email protected]
W/S_HTCCamera( 4045): notifyCameraThreadBlocked(BlockedInCameraDriver)
W/S_HTCCamera( 4045): onCameraThreadBlocked(BlockedInCameraDriver)
W/S_AutoFocusController( 4045): unlockAutoFocus() - Null handle
W/S_ImageSettingsController( 4045): unlockAutoExposure() - Null handle
W/S_ImageSettingsController( 4045): unlockAutoWhiteBalance() - Null handle
W/S_HTCCamera( 4045): onPause() - mIsUIReady = false
W/AudioService(  920): stream was not muted by this client
E/AudioService(  920): Could not get client death handler for stream: 5
W/S_HTCCamera( 4045): onPause mIdle is false
W/S_HTCCamera( 4045): OnPause - Freeze UI !!!
W/S_HTCCamera( 4045): doOnPause() - start
W/S_HTCCamera( 4045): stopAccelerometer() - isAccelerometerStarted = false
W/S_HTCCamera( 4045): OnPause - hide UI, set mMainLayout invisible
W/S_HTCCamera( 4045): doOnPause() - end
E/mm-libcamera2(  260): mm_camera_stream_fsm_reg: ioctl VIDIOC_STREAMON failed: rc=-1
E/mm-libcamera2(  260): mm_camera_ch_fn: Failed in STREAM ON
E/mm-libcamera2(  260): mm_camera_action_start: rc=-1 -> i don't think it's too much important
E/QCameraHWI_Still(  260): android::status_t android::QCameraStream_Snapshot::startStreamZSL(): Failure starting ZSL stream
E/mm-camera( 4144): qcamsvr_find_mctl_inst: no match for mctl_id = 1
E/mm-camera( 4144): qcamsvr_process_server_node_event: MSM_V4L2_* - cannot find mctl, id = 1 -> it should be important
is there a dev that already encountered this problem, and can help us?
@ImagioX1 @E.Cadro @olvrick @Turge @Zarboz


grep is your friend
MCTL_COMPID_ACTUATOR
The Following 3 Users Say Thank You to Zarboz For This Useful Post: [ View ] Gift Zarboz Ad-Free
20th September 2013, 03:05 PM |#3  
OP Senior Member
Flag Valle Castellana, L'Aquila, Groningen, Madrid, Bruxelles, Abu Dhabi
Thanks Meter: 1,555
 
Donate to Me
More
Quote:
Originally Posted by Zarboz

grep is your friend
MCTL_COMPID_ACTUATOR

i know, the problem is in liboemcamera.so, mctl_init & sensor_init are changed, and i'm looking at this
i was just asking if One XL devs already solved this problem in the past or not, or if you have some hints

In One S liboemcamera there is one only "MCTL_COMPID_ACTUATOR handle is NULL" reference:
.rodata:000BBAEA aMctl_compid__0 DCB "MCTL_COMPID_ACTUATOR handle is NULL",0xA,0

In One liboemcamera there are three reference:
.rodata:000AAB54 aMctl_compid_ac DCB "MCTL_COMPID_ACTUATOR handle is NULL",0xA,0 ; DATA XREF: sub_1F240+A64o
.rodata:000C650C aSMctl_compid_0 DCB "%s MCTL_COMPID_ACTUATOR handle is NULL",0xA,0
.rodata:000C7EF4 aSMctl_compid_2 DCB "%s: MCTL_COMPID_ACTUATOR handle is NULL",0xA,0

the one causing the error is the first

in dmesg, error happens beetween this two lines:

<6>[ 141.009064] c1 4731 [CAM] mt9v113_ioctl, cfgtype = 10
(reached with original cam and zoe mod)
it's in drivers/media/video/msm/sensor/mt9v113_v4l2.c
function: int mt9v113_sensor_config(void __user *argp)

<6>[ 141.009430] c1 4731 [CAM] vfe32_proc_general: cmdID = START
(start is not reached with Zoe mod)
it's in drivers/media/video/msm/vfe/msm_vfe32.c
function: static int vfe32_proc_general(
struct msm_cam_media_controller *pmctl,
struct msm_isp_cmd *cmd,
struct vfe32_ctrl_type *vfe32_ctrl)
The Following User Says Thank You to pirlano For This Useful Post: [ View ] Gift pirlano Ad-Free
22nd September 2013, 01:32 AM |#4  
blade_h's Avatar
Member
Thanks Meter: 5
 
More
Will be great to be ported this feature and new [ROM] MaximusHD 10.0.0 - 4.2.2 Sense 5 -> will be the best one for ONE S
Will wait this with big impatience to be fixed and work of my favorite phone - One S
Thanks
22nd September 2013, 08:09 PM |#5  
OP Senior Member
Flag Valle Castellana, L'Aquila, Groningen, Madrid, Bruxelles, Abu Dhabi
Thanks Meter: 1,555
 
Donate to Me
More
i'm using this tutorials to try to debug liboemcamera.so:
http://forum.xda-developers.com/show....php?t=2050393
http://forum.xda-developers.com/show....php?t=1374345

but i'm currently stuck here:
http://forum.xda-developers.com/show...6&postcount=13

EDIT: solved few problem

but now, i'm stuck, again

ptrace: I/O error.
The Following User Says Thank You to pirlano For This Useful Post: [ View ] Gift pirlano Ad-Free
23rd September 2013, 04:08 PM |#6  
OP Senior Member
Flag Valle Castellana, L'Aquila, Groningen, Madrid, Bruxelles, Abu Dhabi
Thanks Meter: 1,555
 
Donate to Me
More
If someone want to try to debug native android library using IDA Pro...

[console 1] -> one time only
adb push the gdbserver from ndk to data/local/tmp
adb shell su
adb chmod 755 gdbserver

[console 2] -> don't forget it or debug client will not connect!
adb forward tcp:1111 tcp:1111

[console 3] -> start binary you want to debug (or binary that load library that you want to debug liboemcamera.so in my case, using mm-qcamera-app) -> leave it opened
adb shell
su
echo 0 > /proc/sys/kernel/randomize_va_space (this is to disable ASLR, that cause library to be loaded at random address)
cd system/bin
./mm-qcamera-app
1 or 2

[console 4]->leave it opened
adb shell
su
echo 0 > /proc/sys/kernel/randomize_va_space (just to be sure)
ps (look at PID of mm-qcamera-app)
cd data/local/tmp
./gdbserver --attach :1111 PID_NUMBER_of_mm-qcamera-app

[console 5]
(adb pull system/lib and system/bin here->C:/android-ndk-r9/toolchains/arm-linux-androideabi-4.6/prebuilt/windows-x86_64/bin)
(start gdb from ndk from command line)
gdb.exe
(gdb) set height 0
(gdb) set solib-search-path ./
(gdb) directory C:/android-ndk-r9/toolchains/arm-linux-androideabi-4.6/prebuilt/windows-x86_64/bin
(gdb) target remote 127.0.0.1:1111
Remote debugging using 127.0.0.1:1111
0x4005fe48 in ?? ()
(gdb) info sharedlibrary
Reading symbols from C:/android-ndk-r9/toolchains/arm-linux-androideabi-4.6/preb
uilt/windows-x86_64/bin/mm-qcamera-app...done.

WARNING: no debugging symbols found in C:/android-ndk-r9/toolchains/arm-linux-an
droideabi-4.6/prebuilt/windows-x86_64/bin/mm-qcamera-app.
Either the binary was compiled without debugging information
or the debugging information was removed (e.g., with strip or strip -g).
Debugger capabilities will be very limited.
For further information: http://wiki/Main/GdbFaq#No_debugging_symbols_found

From To Syms Read Shared Object Library
0x40003240 0x4000b978 No C:/android-ndk-r9/toolchains/arm-linux-andro
ideabi-4.6/prebuilt/windows-x86_64/bin/system/bin/linker
0x40055940 0x40085d0c No libc.so
0x400a07f4 0x400a0998 No libstdc++.so
0x400a4e80 0x400b5164 No libm.so
0x40044180 0x40045d44 No liblog.so
0x40027a18 0x4003059c No libcutils.so
0x4025f6a0 0x40263008 No libgemini.so
0x4022f578 0x402543cc No libmmjpeg.so
0x400ca8b0 0x40161250 No liboemcamera.so
0x40296638 0x40296b50 No libmmstillomx.so
0x402a1494 0x402a1630 No libimage-omx-common.so
0x4029a658 0x4029e414 No libimage-jpeg-enc-omx-comp.so
0x4028a284 0x40291a5c No libmmcamera_interface2.so
(gdb)

NOW you have information about library base address! Nice! Copy and paste these information
Now you can just use CTRL+C on console 4, and execute instruction for console 4 again, so we can debug using IDA this time

(IDA)
for new versions->Debugger, Debugger option, option, uncheck "Use hardware temporary breakpoints"
Debugger,Switch Debugger,Remote GDB debugger and check Set as default debugger
Debugger, Process option, applicazion path (../system/bin/blabla), input file (same or ../system/lib/libblabla.so if debugging lib), Hostname: localhost, Port 1111 (or select youself, you will need to use it for all commands) and check "Set as default network setting"
Now load the file you want to debug
File->Open->liboemcamera.so in my case->Ok/Load->Check "Manual load" from the popup->OK->Input 0:400ca8b0 in my case (base address)->Load all section or section that you need->Yes
Wait for autoanalysis, and do some static analysis by yourself, set some breakpoint, etc,etc
When you are ready to debug: Debugger,Start process, Yes
TADA! The ****ing IDA+gdb should now be able to do step by step debug, but i got a ****ing ptrace: I/O error.
The Following 4 Users Say Thank You to pirlano For This Useful Post: [ View ] Gift pirlano Ad-Free
26th September 2013, 03:54 PM |#7  
OP Senior Member
Flag Valle Castellana, L'Aquila, Groningen, Madrid, Bruxelles, Abu Dhabi
Thanks Meter: 1,555
 
Donate to Me
More
using HTC One Mini libs + updating kernel camera parts from HTC One Mini source, front camera is working good, but rear camera quality is really really bad, need a fix
i'll post an alpha mod soon

zoom bug (green rectangle on jpeg) is still present

EDIT: quality became bad because of wrong Auto White Balance not working good with M4 libs, so with a clean installation it will still working good, but if you came from Zoe fix from Magio, you will need to go back to stock libs/camera apps or do a fresh installation

zoe is working but need camera.apk modding to force it (it should be easy, since apk can be decompiled almost to source code)
The Following 5 Users Say Thank You to pirlano For This Useful Post: [ View ] Gift pirlano Ad-Free
28th September 2013, 12:31 AM |#8  
OP Senior Member
Flag Valle Castellana, L'Aquila, Groningen, Madrid, Bruxelles, Abu Dhabi
Thanks Meter: 1,555
 
Donate to Me
More
install over a stock camera
kernel with M4 kernel camera patch: http://www.4shared.com/zip/CRNRFvCD/...6_09_13_v.html
test M4 libs+camera: http://www.4shared.com/zip/wW302ToJ/..._M4_ville.html
front facing camera is working, zoe needs to be enabled camera.apk side
28th September 2013, 01:53 AM |#9  
Flashalot's Avatar
Senior Member
Flag Chicago
Thanks Meter: 2,674
 
More
Quote:
Originally Posted by pirlano

install over a stock camera
kernel with M4 kernel camera patch: http://www.4shared.com/zip/CRNRFvCD/...6_09_13_v.html
test M4 libs+camera: http://www.4shared.com/zip/wW302ToJ/..._M4_ville.html
front facing camera is working, zoe needs to be enabled camera.apk side

Well this work over your old kernel to make the one xl roms boot

Sent from my HTC One S using Tapatalk 2
28th September 2013, 01:55 AM |#10  
OP Senior Member
Flag Valle Castellana, L'Aquila, Groningen, Madrid, Bruxelles, Abu Dhabi
Thanks Meter: 1,555
 
Donate to Me
More
yes, camera part only is changed, tomorrow i'll work on camera.apk
The Following 2 Users Say Thank You to pirlano For This Useful Post: [ View ] Gift pirlano Ad-Free
28th September 2013, 03:18 AM |#11  
Flashalot's Avatar
Senior Member
Flag Chicago
Thanks Meter: 2,674
 
More
Quote:
Originally Posted by pirlano

yes, camera part only is changed, tomorrow i'll work on camera.apk

Ok cool need any help send me a pm

Sent from my HTC One S using Tapatalk 2
The Following User Says Thank You to Flashalot For This Useful Post: [ View ] Gift Flashalot Ad-Free
Post Reply Subscribe to Thread

Tags
development

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes