FORUMS
Remove All Ads from XDA

[ODIN][TAR] I9505G modems

3,418 posts
Thanks Meter: 2,220
 
By SamuriHL, Senior Member on 20th September 2013, 05:58 PM
Post Reply Email Thread
9th December 2013, 02:09 AM |#41  
SamuriHL's Avatar
OP Senior Member
Thanks Meter: 2,220
 
More
I don't know anything about using heimdall. I'd ask in the heimdall thread. And yes, you need both files.
 
 
9th December 2013, 02:33 AM |#42  
Chahk's Avatar
Senior Member
Flag New York
Thanks Meter: 232
 
Donate to Me
More
Quote:
Originally Posted by SamuriHL

I don't know anything about using heimdall. I'd ask in the heimdall thread. And yes, you need both files.

I finally figured it out. The problem was (of course) on my end. Apparently ages ago I installed Kies, which came with its own set of crappy Samsung drivers, and those were interfering with both ODIN and Heimdall (couldn't even flash recovery.) The moment I uninstalled that p.o.s. software, everything started working.

For reference, in order to flash with Heimdall you need to rename the .tar.md5 file to just .tar, extract the 2 BIN files to the Heimdall folder, place the phone in Download mode (Vol Down + Home + Power), connect it to PC, run zadig.exe utility (located in "Drivers" folder of Heimdall), find the GS4 and replace the driver, and finally in command prompt flash with the following:
Code:
heimdall flash --APNHLOS NON-HLOS.bin --MDM modem.bin --no-reboot
9th December 2013, 02:39 AM |#43  
SamuriHL's Avatar
OP Senior Member
Thanks Meter: 2,220
 
More
Glad you figured it out.
10th December 2013, 11:18 PM |#44  
Member
Thanks Meter: 0
 
More
Got my phone back today, its been broken for a couple of months.

I tried to flash a rom to my phone and it did not work, it goes into cyan screen or bootloop.

I came across your thread after i tried to flash, of course, and thought i should do this.

But it is failing. What am i going wrong?

S4 I9505G - Odin 3.09 - Drivers 1.5.27.0 - Standard Samsung USB which came with the phone.

<OSM> Enter CS for MD5..
<OSM> Check MD5.. Do not unplug the cable..
<OSM> Please wait..
<OSM> modem_mfd.tar.md5 is valid.
<OSM> Checking MD5 finished Sucessfully..
<OSM> Leave CS..
<ID:0/003> Odin v.3 engine (ID:3)..
<ID:0/003> File analysis..
<ID:0/003> SetupConnection..
<ID:0/003> Initialzation..
<ID:0/003> Get PIT for mapping..
<ID:0/003> Firmware update start..
<ID:0/003> SingleDownload.
<ID:0/003> NON-HLOS.bin
<ID:0/003> NAND Write Start!!
<ID:0/003> Transmission Complete..
<ID:0/003> Now Writing.. Please wait about 2 minutes
<ID:0/003> FAIL! (Auth)
<ID:0/003>
<ID:0/003> Receive Response from boot-loader
<OSM> All threads completed. (succeed 0 / failed 1)
10th December 2013, 11:23 PM |#45  
SamuriHL's Avatar
OP Senior Member
Thanks Meter: 2,220
 
More
No idea. Not enough information to tell you.
11th December 2013, 01:48 PM |#46  
Chahk's Avatar
Senior Member
Flag New York
Thanks Meter: 232
 
Donate to Me
More
Quote:
Originally Posted by dy_domyoung

<OSM> All threads completed. (succeed 0 / failed 1)

Make sure no other Samsung drivers are installed (from Kies for example.) Un-install and re-install the drivers again. If that still fails, try Heimdall with my instructions a few posts up. Again, make absolutely sure no other sammy drivers are on your machine.
14th December 2013, 02:51 PM |#47  
SamuriHL's Avatar
OP Senior Member
Thanks Meter: 2,220
 
More
ML4 modem posted.
The Following 2 Users Say Thank You to SamuriHL For This Useful Post: [ View ] Gift SamuriHL Ad-Free
15th December 2013, 12:14 AM |#48  
Junior Member
Thanks Meter: 4
 
More
Quote:
Originally Posted by SamuriHL

ML4 modem posted.

Thanks ... working as always
4th June 2014, 02:55 AM |#49  
SamuriHL's Avatar
OP Senior Member
Thanks Meter: 2,220
 
More
NE3 modem posted.
26th June 2014, 12:57 AM |#50  
SamuriHL's Avatar
OP Senior Member
Thanks Meter: 2,220
 
More
NF3 modem posted.
The Following User Says Thank You to SamuriHL For This Useful Post: [ View ] Gift SamuriHL Ad-Free
27th June 2014, 05:27 PM |#51  
Chahk's Avatar
Senior Member
Flag New York
Thanks Meter: 232
 
Donate to Me
More
I just figured out something interesting and thought I'd share my findings.

I was trying to flash the new modem, but wasn't installing even though Odin reported success. I must've tried 5 or 6 times, and then it finally took. The only difference was that the last time I completely turned the phone off and manually started in Download mode (Power + Vol Down,) while all the previous times I was rebooting via CM11's "advanced reboot" dialog (power button -> Reboot -> Download). I guess something either in the ROM or the phone itself isn't properly starting when you reboot to Download mode from within the ROM.

TL;DR - power off your phone and manually boot into Download mode for proper Odin/Heimdall flashing.
The Following User Says Thank You to Chahk For This Useful Post: [ View ] Gift Chahk Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes