Remove All Ads from XDA

[Q] Modem Help after 4.3 Flash with new board

3 posts
Thanks Meter: 0
By airwreck, Junior Member on 5th January 2014, 01:36 PM
Post Reply Email Thread
My trusty N7100 had an allergic reaction to saltwater about 3 weeks ago. It only got the top of the phone but it shorted out and would freeze on the boot screen until the battery was pulled. I took it to a few shops here in the Philippines but wasn't much they could do. From the tear down vids, etc, I figured it needed a new board. I took it to Hong Kong for New Year's and a friend found a shop that was able to get it up and running for $100 but couldn't get any info on what work was done. The phone was still rooted/unlocked and worked on my prepaid HK data sim as well as my local carrier when I returned to the Philippines two days ago. But it was showing as "Modified" in device status and wouldn't do OTA updates. I decided to flash it from 4.1 to 4.3 with ODIN and now its "Not Registered on Network".

Looks like a common error for the 4.3 upgrade but after hours of research, I'm in the dark as to the best path forward. IMEI, s/n, etc., in device status have remained unchanged and show out of the box numbers (the one thing I did record. Based on the below I am trying to figure out if I should be flashing Globe Philippines rom's or HK rom's... or just need to change to a HK modem?

Before the dunking:
Philippines Globe phone. I bought it in Oct2012, rooted it to unlock but that's about it. Unfortunately it was my first Android phone and I didn't record the system specs anywhere. I have some Titanium BU's but no images (doh)

After resuscitation in Hong Kong, everything was all good (but I didn't make a recovery image of this either = doh x2):
Android 4.1.1
Baseband N7100XXALJ2
Kernel: 3.0.31-343940
Build: JR003C.N7100ZSALJ7

I flashed the ROM with what I thought was the recommended 4.3 stock rom for Philippines Globe. I have Wi-Fi but can't connect to mobile networks. I tried three different sims for two different carriers.
Android 4.3
Baseband: N7100XXUEMK1
Kernel: 3.0.31-2229877
Build: JSS15J.N7100XXUEML3

This one has got me stumped as I'm not sure what flavor my phone is after its organ transplant. Now that its mostly alive, I could take it back over to the boys at the mall but that would be too easy. Thanks for any help. I've been a lurker on here since I first looked at buying this phone and have learned a lot from this site.

I'm running ODIN via Virtualbox with a Kubuntu host and W7 guest.
6th January 2014, 10:16 AM |#2  
OP Junior Member
Thanks Meter: 0
Sorry for long winded question... really just need point in right direction. Try switching modems? If so which one? Or just reflash with HK stock ROM? Thanks!
6th January 2014, 02:10 PM |#3  
Junior Member
Thanks Meter: 1
I'm not so sure if this will work but try to reflash again but before that wipe data 1st then followed by wipe cache partition and wipe dalvik cache.
The Following User Says Thank You to lexsam-bb For This Useful Post: [ View ] Gift lexsam-bb Ad-Free
7th January 2014, 06:39 AM |#4  
OP Junior Member
Thanks Meter: 0
Thanks! Before I saw this reply, I tried flashing to latest HK version of 4.3 - N7100ZSUEML1 with no success but didn't wipe caches. Rooting failed this morning but I read up on here that doing the factory reset is supposed to flash the davlik. After reading this, I did the factory reset/wipe and then wiped the cache and reflashed ZSUE with ODIN3. After I got the language switched from Chinese to English, I was hopeful as I went through set up process of "new" phone but no dice. I was going to try to flash back to N7100ZSALJ7 but I didn't back it up and can't scare up that ROM on the net. I have found a HK 4.1.2 version (N7100ZSDMA4) that I may try but after three days of solid computer time, I'm getting tempted to just take it down to the guys at the mall and see what they can do. Being a Kubuntu user for several years, I'm used to solving my tech problems on the net but still low on the Android food chain and committed cardinal sin #1, always have a viable backup. There is a lot of great information on here and the net in general but with so many variants of phones, ROM's, regions, etc., it is hard to find the right needle in this haystack!

I'm down but not out so if anyone has anymore suggestions, I'm all ears. IMEI, etc., are still in tact. I'm wondering if I'm running into the regional issue. I was reading up on the Note 3 and thought I remember seeing something that said Sammy might roll regional coding backwards along with Knox. With an "official" 4.3 running on this Note 2, I've got Knox now. So turning a new ROM on in the Philippines for the first time with a HK board could possibly be the issue but I think that's a dark horse as its unlocked and my new Note 3 isn't having regional issues after I unlocked it (but I unlocked the Note 2 with root and unlocked the Note 3 the easy way - via $ and the IMEI for unlock code. I'm missing something easy. I've got good signal strength. I can see all the usual suspects here under Mobile Networks/Network Operators - Globe, Sun, Smart. It even says I'm registered on Globe when I click on it. But when I try for mobile data or to make a call, "Not Registered on Network".

Thanks for any and all help.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes