Remove All Ads from XDA

[Q] Cubot A890/M6589 Bricked?

3 posts
Thanks Meter: 0
By agentnerdo, Junior Member on 7th January 2014, 10:44 PM
Post Reply Email Thread

So I finally figured how to update the phone, following the steps on the site;

I used the 1st file on there, labeled just "CUBOT M6589" (I figured, on top of the list, must be most recent)

I did the update and it showed me an error, and after wards the phone would not turn on. If I plug it in, the computer does recognize something is installed.

I tried flashing it with an older version, and I did get the screen to "turn on", but nothing shows on it. I have also tried flashing it with the suggestion given on "", but it has gone back to not responding to anything (other than connecting to my computer).

The other thread did have a link to another users backup..(which I am downloading, please see the link up, as the backup is linked on it), but I was hoping there was another way? Could I flash it back to working? Reason I prefer to flash it, is because the only instructions I could find to use a backup where in I rather stay away from unchartered waters. Unless someone has great English instructions!

Or is the phone a total loss now?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes