Remove All Ads from XDA
Honor View 10

[Q] Mytouch 4g problem

2 posts
Thanks Meter: 0
By bullethawk, Junior Member on 8th January 2014, 06:37 AM
Post Reply Email Thread
So I was downloading a app on mytouch 4g phone then it froze so I took out the battery and put it back in and stays on my touch 4g logo screen forever till I take out battery. So I went on the hboot menu ... ThIs what it say

Glacier pvt ship s-on
July 15 2011, 16:45:17
Factory reset
Image crc

I've tried factory reset it frezzes, tried recovery goes on on a picture with a phone with green arrows then turns off and vibrates 4times.

Please HELP
8th January 2014, 07:11 AM |#2  
I believe there was an issue with some of these phones having an emmc prone to failure, I hope this isn't your case. As of right now you have a shipped bootloader and a stock recovery so there may not be too many likely fixes, did you every root it?
I would try to see if cache may be corrupt to start
fastboot erase -w
Note this will wipe all data from phone if your bootloader even allows for the command. If not then your next step you will have to look for an RUU for phone and try to flash this, I would advice to seek the glacier forum here on xda
Best of luck!

Sent from my Nexus 7 using XDA Premium 4 mobile app
8th January 2014, 08:43 AM |#3  
OP Junior Member
Thanks Meter: 0
My phone is not rooted, when I click on reboot it get stuck on the mytouch 4g screen and when I click reboot boot loader it frezzes.
What's Ruu and how do get and do it
8th January 2014, 09:17 AM |#4  
romuloxiii's Avatar
Senior Member
Thanks Meter: 48
You should look here to find an answer to your problem. Most likely you will have to place a file on your SD card known as a PD15IMG and this will return your phone to stock settings. Please look in the MyTouch forum as there is a wealth of knowledge there.

good luck!!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes