Remove All Ads from XDA

[Q] Partition eMMC

68 posts
Thanks Meter: 14
By JulioQc, Member on 7th January 2014, 01:41 PM
Post Reply Email Thread

I running into some trouble using Parted via adb shell to resize some partition on eMMC chip on my Gnote (SGH-i717D). So basically, i'm following this guide:

However, parted will give the the error "Can't have a partition outside the disk!" at any query I submit. After investigating (using fdisk), indeed some partitions are outside the "disk":

... total 30775296 sectors...
end of mmcblk0p4 = 30777343
end mmcblk0p28 = 30777343

Not too sure how this happened... I know how to ajust under Linux (i.e. this guide) but thru adb shell, I cant use most tools I normally have at hand under linux. I was thinking a full format of the device under recovery and reinstall the ROM would maybe fix the issue? (although I doubt it will touch partition size, only wipe them)

Any ideas, workarounds, suggestions?

I run this ROM:
I run this Kernel:

8th January 2014, 05:16 PM |#2  
OP Member
Flag Montreal
Thanks Meter: 14
Really? nobody has an idea?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes