Remove All Ads from XDA

[Q] Reverting from Kit kat back to HTC One stock with RELOCKED bootloader...

4 posts
Thanks Meter: 0
By Noor440, Junior Member on 8th January 2014, 02:28 PM
Post Reply Email Thread
I have a black HTC One PN07120 and I bought it used. It came with stock android (kit kat). I am trying to unlock my phone so I can use it with t mobile but when I put my code in it give me an error saying "Network Unlock Request unsuccessful". I was looking around and read that custom roms aren't good with unlocking networks so I have to return to htc one stock sense and then put in the code.

When I boot into bootloader, it shows it is *** RELOCKED ***

I have tried using the RUU but that gives me an "unknown error". I also downloaded the "root checker" app and that says I don't have root access. I went to and did the unlock bootloader thing. Got the file, when I run the "fastboot flash unlocktoken Unlock_code.bin" command, It says successful but doesn't unlock the bootloader.

How can I get my HTC One back to stock. I have tried a lot of things and nothing seems to work. Any help would be appreciated.
9th January 2014, 05:30 AM |#2  
Junior Member
Thanks Meter: 3
Are you s-off? If not, you may need s-off to flash the ruu that you downloaded.
9th January 2014, 05:47 AM |#3  
OP Junior Member
Thanks Meter: 0
Found a simple solution...

Go to google and search "htc one ruu zip" Go to the first link.

And download the RUU that corresponds with you phones original carrier.

(You need to have fastboot and adb and all the drivers setup)
Enable USB debugging.
Go to the home screen on your phone
Open up a command prompt and enter:
adb reboot bootloader
fastboot oem rebootRUU
fastboot flash zip

after this it will zip and give you an error.You have to enter the previous command again.
fastboot flash zip

After it says "finished." You are done. the last command is to reboot
fastboot reboot

Hope this helped for the people that are in the same situation.
9th January 2014, 05:32 PM |#4  
Junior Member
Thanks Meter: 3
Ah, you may have had the wrong RUU that didn't match your CID or MID, or a decrypted one, which would have only allowed you to run it if you had s-off.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes