Remove All Ads from XDA
Honor View 10

[Q] NST False Empty Battery

1 posts
Thanks Meter: 0
By Joe2987, Junior Member on 10th January 2014, 11:22 PM
Post Reply Email Thread
I've had my NST Glowlight for roughly a year (so the warranty's run out). I haven't used it since October or so, and when I tried to charge and boot it recently, it doesn't do anything. When I plug it in, the green LED immediately turns on, and if I wiggle the charging cable a bit, it'll turn to amber, but no matter what I do, the thing won't turn on. However, the backlight will work (for as long as it's plugged in; the backlight will turn back off after about 30 seconds if I unplug it). I've taken off the back panel to have a look at the battery. It seems fine: the positive and negative terminals read ~4.10V, and like I said, the backlight works. I've also tried all of the standard reset things such as holding the power button for 20-30 seconds, holding both the power and the N button for 20-30 seconds, leaving the battery unplugged for a while then trying to charge it, trying to charge it for a long period of time (about 6-8 hours).

In any case, nothing I've tried has worked, and I'm starting to get frustrated. The other two times this has happened, I could just return it and get a new one, but now that that warranty's gone, I'd have to buy a new one, which I'm not really all that willing to do.

If anyone has any ideas or insight, I'd be very grateful. Thank you in advance.
11th January 2014, 02:35 AM |#2  
Renate NST's Avatar
Inactive Recognized Developer / Recognized Contributor
Thanks Meter: 1,034
A voltmeter on the battery with no load might be a red herring.

A 100 ohm to 1K should be enough of a load.

A Nook without a battery will refuse to boot, however it will pop up in bootloader mode for a bit.

If you just plug in a USB cable does it popup on your PC "New device found"?

This thread might be of interest:
You can probably skip to the end.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes