Remove All Ads from XDA

[Q] encrypted tablet, "factory data reset" not working

4 posts
Thanks Meter: 0
By scolazz, Junior Member on 8th January 2014, 04:37 PM
Post Reply Email Thread
Hey all. I have a rooted TF700 with CM 10.2 on it. I have encrypted the tablet (via SETTINGS - SECURITY - ENCRYPTION). I'd like to do a "Factory Data Reset" - it's my understanding that this will remove the encryption, along with all my user data. This is what I'd like to do.

However, when I go to SETTINGS - BACKUP & RESET - FACTORY DATA RESET, it doesn't work. It asks me to enter my password, then asks me to 'erase everything', and when I click it, it reboots as if to perform the reset. I get the little android guy after it reboots, then the ASUS screen, then CM boot screen. However, the tablet boots like normal, is still encrypted, and all my user data is still there.

I recently upgraded from CM 10.1 to 10.2 - getting the gapps package to install took several tries for some reason, but eventually it worked. I have clockwork recovery installed, but because the tablet is encrypted I am unable to mount or format the /data partition from clockwork.

Anyone have a clue how I can get the 'Factory data reset' to work, or otherwise decrypt my tablet? Thanks!
8th January 2014, 08:12 PM |#2  
Recognized Developer / Recognized Contributor
Thanks Meter: 4,114
Donate to Me
Factory reset is done by your recovery. Which recovery (and version) is currently installed? Maybe you need to choose "format data" explicitly in the recovery.
8th January 2014, 09:29 PM |#3  
OP Junior Member
Thanks Meter: 0
Originally Posted by _that

Factory reset is done by your recovery. Which recovery (and version) is currently installed? Maybe you need to choose "format data" explicitly in the recovery.

I cannot touch (either mount or format) /data from Clockwork recovery because it is encrypted by android. any attempt to do so, and I get an error

"ERROR cannot (mount/format) /data!"

doing the 'Factory Data Reset' from within Android is supposed to decrypt and wipe /data, but that is not working.
10th January 2014, 02:31 AM |#4  
OP Junior Member
Thanks Meter: 0
I flashed TWRP and got rid of Clockwork recovery - that enabled me to mount /data in recovery (TWRP asks for my password to decrypt /data when TWRP starts), which is something. However, when I go into /data using the terminal I only see the lost+found directory and nothing else?

However, formatting /data from TWRP doesn't work, neither does a reset. They just give me errors.

I then tried abd shell - mke2fs -T ext4 /dev/block/mmcblk0p8

but that gives me a '/dev/block/mmcblk0p8 is apparently in use by the system; will not make a filesystem here!' error, even after unmounting it manually (umount -a)

Next, I tried using TWRP to reinstall CM 10.2. After that, the boot process took 40 minutes or so. Once it came up, there was no user data and cyanogenmod was fresh (yay!) - but the partition is still encrypted - it asks for password during boot, even though the OS has no password lock on it.

In addition, my WIFI is now not working!

anyone have a clue here? I REALLY want to remove the encryption on the /data partition!
11th January 2014, 04:27 AM |#5  
OP Junior Member
Thanks Meter: 0
I wanted to follow up here with closure. Im not exactly sure WHY what I did worked, but it did, and maybe it can help someone else.

last I left off, I had CM11 installed, but no wifi, and the partition was still encrypted. At this point, I decided to try to downgrade again to CM10.2

Now, when the tablet was booting, it was asking me for my password to decrypt so it can boot. Except now, after loading CM11 and going back to 10.2, the password wasn't working and couldn't boot. I was convinced I was bricked.

I went back into recovery, and reloaded CM11. This time, when it came up asking for my password to decrypt before booting, it worked. So something in CM11 changed the encryption on /data so that CM10.2 couldn't read it anymore.

once I was booted into CM11 (still with no wifi), I went to SETTINGS - BACKUP & RESET - FACTORY DATA RESET again. This time, it worked! Asked for my password, said are you sure, then rebooted. BOOM, /data was no longer encrypted! CM11 came up, and with the fresh /data partition, wifi even worked!

For other reasons (Netflix) Ive since gone back to 10.1, but now /data isn't encrypted, so wiping and flashing is easy and works great now.

It seems there is a bug in CM10.2 (or android) where the FACTORY DATA WIPE doesn't work with encrypted /data partitions, but CM11 was able to do that just fine.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes