Remove All Ads from XDA

[Q] supersu cant update binary after 4.3 and reroot?

34 posts
Thanks Meter: 0
By slreno, Member on 12th January 2014, 11:46 PM
Post Reply Email Thread
ok here is what i have done and need to know how to get it working again,
i had stock root before the new 4.3 update. flashed a stock rom to the phone to get rid of root so i could get the ota for 4.3. worked fine and got the ota. then i flashed the cf auto root for this device and for the 4.3 and it installed fine via odin. but here comes the problem,
everytime i do something that requires root i get that damn knox warning saying something has tried to access areas of the phone that is not alowed.
i have searched and searched how to diable knox? but i cant even find the app anywhere to open it? to disable or even uninstall. i found it in security and developer options but when i open it there is no way to access settings as described in other threads to uninstall it. only opion i have is to activate it?

what do i need to do to get rid of this annoying warning from know and get supersu working correct.
thanks for any help.
13th January 2014, 01:51 AM |#2  
OP Member
Thanks Meter: 0
got it fixed!!!
ok after hours of searching found the fix

this is for the ones not getting the disable knox option when supersu runs.

here is directions from jamal at android central

Follow these steps

1) goto your settings , more , and than app manager

2) scroll over to ALL tab , click on superuser which would bring up settings. Click turn off

3) open up a explorer app ( i believe any file explorer app would work ) but i used -->

4) NOW the important step.. in the explorer go to your root. Not your sd card data or external card data. Your Root.

5) Once your in the root look for a folder named SYSTEM . from there open the folder APP.

6) Now scroll down untill you see superuser.apk . Click it and install

7) open superuser its going to ask do you want remove KNOX (dont know the exact wording) . Click yes

BINGO Your Rooted...
I ran root checker to verify it and rooted apps working fine.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes