Remove All Ads from XDA
Honor View 10

[Q] Can't mount SD Card

39 posts
Thanks Meter: 3
By danny-k, Member on 9th January 2014, 08:51 AM
Post Reply Email Thread
I posted this in the General section by mistake.

My HTC desire won't read the SD card. It is not a problem with the card since I tried it on Windows & other phones and it works + Tried cards that work in other phones and won't work on mine.

What do I have access to:

- The phone is S-OFF
- I have Clockworkmod Recovery
- I can't see the card from the recovery either ("Can't mount /sdcard")
- my phone is not rooted
- I have stock 2.2 android (2.29.405.5)
- I have the drivers installed on my PC and I can access the phone via abd or fastboot

I have tried:
  1. "fastboot oem enableqxdm 0" from fastboot, it didn't fix it.
  2. Unbrick from 4eXT Recovery:
    Asked a coworker for his working SD Card
    Used the "fastboot oem enableqxdm 0"
    Installed "4eXT Recovery Touch v1.0.0.5 RC9"
    Entered Recovery with msg "Error mounting your card .... "
    Tools > Usb unbrick
    "Your CID: HTC__032
    Patching misc image..
    Your misc partition size: 640kb
    Writing mtd0..
    Done.. please reboot!"
    After reboot the same issue "Error mounting your card .... " in Recovery, loaded rom: No SD card
    Returned the card to my coworker, card is still functional in his phone.

I am opened to suggestions. Worst case scenario: Hardware malfunction

9th January 2014, 11:57 AM |#2  
OP Member
Flag Timisoara
Thanks Meter: 3
One additional question:
Assuming that I can't get my SDcard to work. Is there a way to install custom rom's?
I have s-OFF, Clockworkmod and adb + fastboot access. Can I flash a new rom from fastboot?

I tried like this with no success:
fastboot erase cache
erasing 'cache'...
OKAY [ 0.284s]
finished. total time: 0.284s
fastboot oem rebootRUU
OKAY [ 0.092s]
finished. total time: 0.092s
fastboot flash zip
sending 'zip' (146730 KB)...
OKAY [ 21.102s]
writing 'zip'...
(bootloader) zip header checking...
(bootloader) zip info parsing...
FAILED (remote: 24 parsing android-info fail)
finished. total time: 29.371s

9th January 2014, 03:52 PM |#3  
SaySayonara's Avatar
Senior Member
Thanks Meter: 64
Im not an expert but it seems to be a hardware issue.
Also, if i would be in your situation i would try to change the hboot. Not sure if it has anything to do with it though. Like i said, not an expert.. but id try it anyway hehe..
Wait for someone with more knowledge on this matter to reply or take it to the service.
9th January 2014, 05:29 PM |#4  
eddiehk6's Avatar
Senior Member
Flag London
Thanks Meter: 670
Please don't change hboot, it has nothing to do with your problem...

You only change hboot before you flash a rom to match the rom's /system size in order to maximize /data (internal memory)

To flash a rom you don't do it thru fastboot, you need to do it thru recovery like normal (full wipe then install zip from sdcard)

However it's strange why your phone can't detect your sdcard. suspect might be hardware after your current logical testing.

Last thing I would try is to delete all partitions and reformat to FAT32 partition using gparted, see if phone detects it after that
10th January 2014, 03:12 PM |#5  
zinconnu's Avatar
Senior Member
Thanks Meter: 23
What is the capacity of your SDcard? (32Gb maximum for Desire if i'm right)
14th January 2014, 11:54 AM |#6  
OP Member
Flag Timisoara
Thanks Meter: 3
Originally Posted by zinconnu

What is the capacity of your SDcard? (32Gb maximum for Desire if i'm right)

Just 2 GB and I also tried a 8 GB
16th January 2014, 11:14 AM |#7  
Flag Praha
Thanks Meter: 12
If your sd-card is working in computer, so that is something wrong with the phone. Can you access your sd-card from recovery? If not, the system won't too.
Post Reply Subscribe to Thread

sdcard malfunction, usb brick

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes