Remove All Ads from XDA
Honor 9 Lite

[Q] Issues with Kindle Fire - Please Help!

1 posts
Thanks Meter: 0
By lwaite9, Junior Member on 17th January 2014, 12:09 AM
Post Reply Email Thread
Hello everyone! I'm not exactly new to rooting, roms, or XDA, but I am a new member, so as such, the forums system forced me to post here...

What I am having trouble with:
twa_priv's CM11.0/SGT7 For kindle fire.

Issue description:
I flashed this rom today to my 1st gen kindle fire. (I used KFU 0.9.9 a few days ago to get root, and everything's good there.)
I'm using TWRP and the ROM mentioned above. After flashing, I tried to connect to my home wifi. But the tablet said "Could not connect". So I thought, "well I'll try setting my router to 'insecure' and see if it works." and it worked fine. Then I tried switching the router back to secure. Nope. Rebooting the kindle? Nope. Wiping and re-flashing? Nope. Clearing Dalvik and Cache? Nope.
So I played around with everything else that ROM had for a little while and couldn't find any other problems...

But not having secure wifi was a dealbreaker for me. I'm still upset, as I very much like KitKat, and that ROM in general...

So, instead of sitting there with a [unusable - to me at least] device, I decided to flash the previous version of the ROM. That would be CM10.1/SGT7 For the Fire, by the same author.
Unfortunately, this ROM also has some issues, although I have mostly been able to ignore them so far (they are not as destructive as the wifi issue). Those issues would be: 1) For whatever reason the microphone no longer works, and 2) Trebuchet force closes from time to time.

Okay, so you may be thinking, well the KF doesn't have a mic. Yes, I know. I'm using an ifrogz headset w/inline mic. How do I know that headset works? I was able to use it with google voice search on the rooted stock ROM, as well as a free voice recording app. I happen to be slightly paranoid though, and tested the headset in a android phone I have. I was able to successfully make recordings there.

So, I tried a favorite app of mine called Soundabout, which allows me to force the system to use the speaker or headset, the bluetooth (if equipped), etc.
Still nothing.

Allow me to describe what happens when I try to record using the built in voice recorder app: kkkkssssshhhhhhhhhhhhh.....
(Something like a very noisy PC fan.)
This sound was generated regardless of the headset being plugged in or not.

I forgot to test this recording issue on the CM 11 ROM, and I don't have time (or patience) to do that tonight

So, please, please help!

I apologize for having such a lengthy post, but I've read complaints of not "describ[ing] in detail your problem" so I figured I would err on the sive of being too descriptive
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes