Remove All Ads from XDA

Xperia x10i Radio capability lost, How to Repair if possible

3 posts
Thanks Meter: 0
By ifinau, Junior Member on 17th January 2014, 01:51 PM
Post Reply Email Thread

I believe that my phones radio capabilities may be disabled. I tried to root my phone but ended up flashing it with an ftf file and now i cant connect to my mobile network with my phone, Ive tried multiple simcards and flashing my phone a few times with different ftf files.

Everything else on my phone seems to be working fine except ability to connect to mobile network carrier.

I cant unlock the bootloader or use s1tools because it cant recognise the certificate or something like that, I can flash and root the phone though.

can i save my phone and how?


Today i flashed and rooted my unlocked xperia x10i with flashtool and the provided .ftf file, "X10_V1_BLRelock.ftf". Pretty much after that my phone had been reset and i couldn't connect to my mobile network.

During the initial setup after the flash, my phone asked me to "Please insert sim card and restart your phone", Now in the drop down bar is has a "No service, selecting network (yes optus) is unavailable). Originally with this phone and my x10a the other networks had a red circle indicating i couldn't access them however right now i can try to connect to all of them but fail. everytime i try to connect i get the message "Your simcard does not allow connection to this network". My APN list is blank but it has always been blank.

My simcard works in another phone, other simcards dont work in my phone. I tried flashing my phone again and rooting it again, with multiple ftf files. I was going to try installing another rom for jellybean, but i cant because my adb drivers are stuffed and ill figure that out later if need be.

I live in australia and the imei is fine, hasnt changed and im not even sure if that would effect the phone from functioning here. I have no idea is its affected the phones radio or frequencies if supposed to function on, help would be greatly appreciated.

I cant receive or make phone calls, texts messages, anything that relies upon me being connected to my carrier. everything else seems to work fine including my home internet. i also used that *#*#4636#*#* and that didnt really tell me anything i dont think.

Phone: Xperia x10i, unlocked
Running: android 2.3.3,
baseband version: 2.1.71

If you require any other information, ill post it up, not that sure what would be needed to figure this out.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes