FORUMS
Remove All Ads from XDA

[FIX][LEAKED 4.4]External Sdcard Mount Perms fix

8,333 posts
Thanks Meter: 3,226
 
By deathnotice01, Senior Member on 12th January 2014, 04:01 AM
Post Reply Email Thread
17th January 2014, 05:33 AM |#51  
Senior Member
Thanks Meter: 326
 
More
This also works for the latest leak
The Following User Says Thank You to AMoosa For This Useful Post: [ View ] Gift AMoosa Ad-Free
17th January 2014, 07:11 AM |#52  
TheJeremyWhite's Avatar
Senior Member
Flag Surrey, BC
Thanks Meter: 31
 
More
Quote:
Originally Posted by vivelafrance

Are you talking specifically about Poweramp here or more generaly about the SD card mount fix?

Not specifically, but it has worked for every app that I had an issue with

---------- Post added at 06:11 AM ---------- Previous post was at 06:05 AM ----------

Quote:
Originally Posted by ascanio1

I did everything exactly as instructed in post#1.
I used File Explorer PRO to reset the permissions.
It didn't work.
I even tried by ticking every box (read, write, execute) for every category (owner, group, all).

Still nothing: File Explorer PRO cannot read the card and apps can't write on it.

Please help!
----------------
N9005, 4.4.2 polish, root

File Explorer didn't work for me either, but Root Browser did. Try that.
The Following User Says Thank You to TheJeremyWhite For This Useful Post: [ View ] Gift TheJeremyWhite Ad-Free
17th January 2014, 09:31 AM |#53  
ascanio1's Avatar
Senior Member
Flag Tokyo
Thanks Meter: 10
 
More
@TheJeremyWhite
Quote:
Originally Posted by TheJeremyWhite

File Explorer didn't work for me either, but Root Browser did. Try that.

Thanks.
Yes, Root browser and Astro file manager work. But that doesn't solve the problem.

I gave all the permissions to all the categories but my apps still cannot access the microSD card memory! it's driving me crazy!

---------- Post added at 05:31 PM ---------- Previous post was at 05:27 PM ----------

@ AMoosa
Quote:
Originally Posted by AMoosa

This also works for the latest leak

Not for all latest leaks. Mine is a polish 4.4.2 and this fix does not work.
17th January 2014, 10:02 AM |#54  
TheJeremyWhite's Avatar
Senior Member
Flag Surrey, BC
Thanks Meter: 31
 
More
@ascanio1
Just to be clear, you downloaded, edited and replaced the platform.xml file according to the OP's instructions, changed the permissions; changed the permissions on the Media_rw folder; Then you KILLED (or Force Stopped) the application you want to access the SD card with and restarted it; and didn't reboot your phone?

If you did all that and its still not working I have no clue.

Sent from my ProBAM Atrix HD MAXX using xda app-developers app
The Following 2 Users Say Thank You to TheJeremyWhite For This Useful Post: [ View ] Gift TheJeremyWhite Ad-Free
17th January 2014, 01:19 PM |#55  
magikmichael's Avatar
Senior Member
Flag Arnhem
Thanks Meter: 305
 
More
Quote:
Originally Posted by TheJeremyWhite

Not specifically, but it has worked for every app that I had an issue with

---------- Post added at 06:11 AM ---------- Previous post was at 06:05 AM ----------



File Explorer didn't work for me either, but Root Browser did. Try that.

Thanks. But i dont have root. I dont want to trip my knox counter. But i will try it when there is a safe way to root without tripping knox.

Verstuurd vanaf mijn GT-I9505 met Tapatalk
17th January 2014, 05:16 PM |#56  
ascanio1's Avatar
Senior Member
Flag Tokyo
Thanks Meter: 10
 
More
Quote:
Originally Posted by TheJeremyWhite

changed the permissions on the Media_rw folder;

No, I did not change the permissions in the media folder. This instruction was not in the original post. Did I miss something?
Where is this media folder? Which permissions should I give to it?

Sent from my SM-N9005 using Tapatalk
17th January 2014, 05:32 PM |#57  
vivelafrance's Avatar
Senior Member
Flag United Kingdom
Thanks Meter: 102
 
More
For me, most apps are working now, but the solution was NOT to replace the platform.xml file with the one attached to this thread. This, on the contrary, made things worse.
What I did, is just add a simple line to the platform.xml file:
(the one added is the 4th line below, in bold)

<permission name="android.permission.WRITE_EXTERNAL_STORAGE" >
<group gid="sdcard_r" />
<group gid="sdcard_rw" />
<group gid="media_rw" />
</permission>


And that's it. Now, I still have issues with Poweramp but I think that's because the path name of the ExtSdCard changed from 4.3, as they had changed it from 4.2 also.
Other Music players are not working either because they can't find the sdcard. JetAudio Plus can find it though.
The Following 6 Users Say Thank You to vivelafrance For This Useful Post: [ View ] Gift vivelafrance Ad-Free
17th January 2014, 06:29 PM |#58  
TheJeremyWhite's Avatar
Senior Member
Flag Surrey, BC
Thanks Meter: 31
 
More
Quote:
Originally Posted by ascanio1

No, I did not change the permissions in the media folder. This instruction was not in the original post. Did I miss something?
Where is this media folder? Which permissions should I give to it?

Sent from my SM-N9005 using Tapatalk

In the /mnt directory like so /mnt/media_rw

Set permissions to 777 or rwxrwxrwx, see screenshot

Sent from my ProBAM Atrix HD MAXX using xda app-developers app
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1389979641740.jpg
Views:	607
Size:	23.9 KB
ID:	2522123  
The Following User Says Thank You to TheJeremyWhite For This Useful Post: [ View ] Gift TheJeremyWhite Ad-Free
17th January 2014, 07:40 PM |#59  
vivelafrance's Avatar
Senior Member
Flag United Kingdom
Thanks Meter: 102
 
More
Quote:
Originally Posted by ascanio1

No, I did not change the permissions in the media folder. This instruction was not in the original post. Did I miss something?
Where is this media folder? Which permissions should I give to it?

Sent from my SM-N9005 using Tapatalk

you can find full instructions here: http://forum.xda-developers.com/show....php?t=2537793
The Following 2 Users Say Thank You to vivelafrance For This Useful Post: [ View ] Gift vivelafrance Ad-Free
17th January 2014, 08:01 PM |#60  
denski101's Avatar
Senior Member
Thanks Meter: 73
 
More
Quote:
Originally Posted by vivelafrance

you can find full instructions here: http://forum.xda-developers.com/show....php?t=2537793

Poweramp still a no go?

Sent from my SM-N9005 using xda app-developers app
17th January 2014, 08:32 PM |#61  
vivelafrance's Avatar
Senior Member
Flag United Kingdom
Thanks Meter: 102
 
More
Quote:
Originally Posted by denski101

Poweramp still a no go?

Sent from my SM-N9005 using xda app-developers app

No it actually works doing the instructions mentioned in the link above and what TheJeremyWhite did (which is the same thing basically).
I totally missed the part where I had to change the permissions on that folder. That FINALLY solves every single issues I had with my Ext SDCard now!
The Following 3 Users Say Thank You to vivelafrance For This Useful Post: [ View ] Gift vivelafrance Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes