Remove All Ads from XDA

[Q] Can't root optimus 2x *PLEASE HELP*

38 posts
Thanks Meter: 0
By luka.kopricanec, Member on 19th January 2014, 10:13 AM
Post Reply Email Thread

probably this question was asked a lot but I can't find anything that can help me.

I've latest ICS software on my LG Optimus 2X (4.0.4) and I would like to root my phone. I've checked USB debugging mod and unknown sources, tried every method I've found and still can't root my phone. Also I've installed drivers for my phone and tried on other pc, same think. I've tried method without PC, Z4root. It starts to root and in one moment app crashes and I must restart my phone to open it again. Super one click stuck on step 5 or 7. I read threads about that problem and I couldn't find any usefull. Please help. What's wrong? I really need to root my phone because it starts to be slow and I'm already sick of running background apps.

Thank you for help
19th January 2014, 11:14 AM |#2  
OP Member
Thanks Meter: 0
I've finally made it. I've download all in one tool kit and in main windows pressed ''I'' button and installed NVFlash and it worked finally
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes