Remove All Ads from XDA

[Q] Parse error on recompiled framework-res.apk?

2,450 posts
Thanks Meter: 4,103
By WhiteNeo, Senior Member on 20th January 2014, 01:08 PM
Post Reply Email Thread
Hey everyone..
Currently, I am trying to change one value in the res/values/drawables.xml file of the Xperia V .145 framework-res.apk file...
Decompiling works perfectly, no errors..
When recompiling, Apktool shows a warning, that one string is missing in some languages.. Should not be much of an issue.
When recompiling is done, the framework file shows a parse error.. I have tried signing it, but this didn't work... Any ideas what I am doing wrong?

Btw, would it work to paste the resources.arsc file from my modified framework into the base framework-res?

Any help would be appreciated!
(Also, if I don't get it to work myself, might there be a nice guy that does the mood for me?
It's only replacing two numbers, no problem usually

Sent from my LT25i using xda app-developers app
20th January 2014, 03:00 PM |#2  
WhiteNeo's Avatar
OP Senior Member
Thanks Meter: 4,103
Donate to Me
Update... Just tried another framework-res.apk.. Works perfectly after recompiling..
So it must be an issue with the .145 framework..

Hmm.. Can I mix frameworks of different firmware versions?

Edit: Nevermind.. Even framework-res.apk from .140 firmware has the parse error after recompiling.

I have no idea how to do this! >.<
Might it be an issue with Apktool app for Android?

Sent from my LT25i using xda app-developers app
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes