Remove All Ads from XDA
Honor 9 Lite

[Q] Unable to connect to Mac w/ Remote Storages via File app

39 posts
Thanks Meter: 1
By Bluebird01, Member on 4th January 2014, 02:32 AM
Post Reply Email Thread
Hi everyone,

I appreciate any help you can give "the newbie" here.

I swear I'm not a total moron, but I can't get this to work. I've tried searching the forums and google, and I've found posts with similar problems, but no solutions. Until I can get another computer to test this on, I don't know if the problem is with my Droid Bionic (unrooted, running JB stock 4.1.2), or my computer (Mac OSX 10.8.3) or my modem.

I would LOVE to root my phone, but I can't even get the darned thing to connect to my computer through the file app!

The phone is on the same wifi network as my computer. Both have no trouble accessing the internet. Both can ping each other (packets sent and received fine). But I can't connect one to the other.

I turn on file sharing on my computer with SMB only
select a folder on my computer to share
Assign a user and password permission to access that folder
make sure permissions for that folder are set to read and write
then go to my phone, open the stock file app
Select "Remote Storages" and "add storage"

Then I enter the IP address for the computer
WORKGROUP for the domain name
The name of the shared folder
The user name and password
then I try to connect.

And I get an alert box on the phone that says
"Network Error
There is a problem in your network connection with remote host. Please repair your network connection and try again."

I'm doing everything that's obvious to do, so I'm guessing there's something "not obvious" that I'm missing. - Anyone here had a similar problem and solved it?

Some things I've tried:
Moving the shared folder to different directories including root, desktop, and "public folder" (each time I moved it, I removed it from the shared list and re-added it)
Creating a guest account and allowing it access to the shared folder - no password needed
Creating a 2nd admin account and allowing it access to shared folders (password)
Turning off computer's firewall
Seeing if I could connect through the computer and phone's browsers (no go!)
Lots of turning things on and off (sharing, users, permissions, wireless...etc.)
Gone into recovery mode on the phone and done a factory reset and wiped the cache partition.

When I check my modem's admin page, I can see both the computer and phone listed there as connected devices. The modem sees them both, and they can ping each other. Why the heck can't I connect them to each other?

Oh, and though I don't think this is relevant, when I connect via cable in USB Storage mode, I can see the internal and external cards on my Mac just fine. They both mount as drives and I can drag stuff back and forth. - Wish I could find instructions to root THAT way!

I finally get the nerve to try to root this and get it on TMobile, and I can't get past the part that should be a no-brainer!

Any help would be appreciated.



Editing on 1/8/14 to add that the problem may be related to a Samba issue in OSX Mountain Lion. I'm also wondering if it could be an issue with my modem, which is several years old. I'm going away for about a week so I may try this on a friend's computer. I'll report back WHEN I am successful with this (because I will be!)
21st January 2014, 06:53 PM |#2  
OP Member
Thanks Meter: 1
Thumbs up Can't root through Mac Mountain Lion. Use Easy Root in VB
Replying to my own post, to follow up. I was unable to connect through samba on my mac running Mountain Lion, while at a friend's house. So the problem was not the modem, but my OS itself.

I'd read that Easy Root ( ) using Virtual Box hadn't worked on a Mac, but I decided to try it anyway. I had to change one setting in Virtual Box from NVidia to "en1: Wi-Fi (AirPort)", and then the Easy Root worked flawlessly. When it got to the part about connecting the Bionic to the Remote Storage folder, I thought "Here we go... this is the part that won't work!" but with Easy Root running in Virtual Box, the bionic connected to the shared folder perfectly.

Mac users with Mountain Lion or above, use Easy Root in Virtual Box to root your Droid Bionic running Jellybean 4.1.2 (here's the link again: ). I know there are posts by people who were able to root their droids through the Mac terminal, but I'm guessing they were on an older OS where smb still worked correctly.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes