Remove All Ads from XDA

[Q] Lots of questions. Need help

1 posts
Thanks Meter: 0
By Surgical007, Junior Member on 20th January 2014, 09:16 PM
Post Reply Email Thread
Well first off I'd like to thank all the guys here on the forums and the devs for all the hard work they do. So i decided to flash my kindle to android, I really wanted to try jellybean. So after watching 4 to 5 videos and downloading the Kindle fire utility and a few roms. I managed to get TWRP 9.9 installed and I got Energy.7.31.2012.Kindle.Fire.CM9.ICS ROM working. I tried jellybean afterwards but had issues with google services running, it kept crashing so i decided to focus on the icecream build. Everything was going well. I downloaded a few apps, including the Kindle Reader app. I loaded like 40 books on to it and it was working fine. A few hours later the kindle app stopped working so i hit the forums once more and found the Build.prop Editor fix. That worked great, the Kindle App booted up with no problem after changing the build and device to asus Nexus 7. But.... like 5 minuets later the kindle lost internet connection, everything i tried to get it reconnected to the internet did not work. From turning off the wireless adapter to reboots of the kindle, the internet just wouldn't connect. During one reboot the kindle wouldn't boot up at all. I'd get the blue kindle fire logo but it would not boot the CM9.ICS ROM all i got was a backlit black screen. So i went into TWRP and reflashed the rom. Kindle boots up and connects to the net with no problem. So now i'm sitting with a kindle with TWRP and android icecream. I haven't tried to put anything on it yet because I have few questions I'd like to ask and hopefully answered before loading up all my books and apps again.

#1 I guess i messed up and didn't back up the original kindle software. So i can't get the kindle to revert back to stock. I've tried loading the stock kindle software using TWRP but i'm getting the same error that i seen alot of other folks on the forums get when they try the same process.
My question is, how do i get the kindle back to stock settings so i can try to reroot it and start over?

#2 I also do not know how to use the the kindle fire utility if the kindle is not booted up in stock rooted mode. Is this possible? Can the utility be used with TWRP to install firefirefire and other options?

#3 The Energy.7.31.2012.Kindle.Fire.CM9.ICS ROM ... Is this rom stable? Is there a better one i should be using? I seen a few posts about a CM10 and CM11 rom but i didn't really read up on it because i had CM9 working and was satisfied with it until my kindle bricked up. I'd hate to load my apps and books up again only to have to reflash and lose everything again. Also is there a way to back up my apps and books with TWRP? So if i do have to reflash i can just load the back up, after reflashing.
21st January 2014, 08:39 PM |#2  
serendipityguy's Avatar
Senior Member
Flag Sunny, CA
Thanks Meter: 496
Prompt Do you have the JAVA SDK & The Android SDK installed?
Do you have the JAVA SDK & The Android SDK installed? If not you will need these tools to recover from your soft brick.

Google YouTube setting up the Android SDK and from there, uninstall and reinstall the Kindle Drivers.
Once you have the device identified in Windows, Google some Android commands such as Side - Load or Push...

I was in the same spot and dug in deeper into the Android SDK and end up pushing in the rom into the Kindle.
You can push in any file such as the stock Kindle Rom and you will be set.

Once you do this, you will have a new love for your device.

There was a lot of content at YouTube which I was able to find and having those videos did a world of wonder for myself.

There are alot of Utilities here at XDA as far as root kits and ways to install TWRP like you have in the past that will assist you on your way towards recovery.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes