Remove All Ads from XDA

Bad boot animation bricked nexus 7 2012 edition

144 posts
Thanks Meter: 25
By urhaxable, Senior Member on 20th January 2014, 06:51 AM
Post Reply Email Thread
I made my own custom boot animation. I used an existing boot animation structure. Difference was mine used *.png files instead of *.jpg files. Which I thought all boot animations were supposed to be png. The other difference is the fps, I changed fps from 24 to 4

I renamed /system/media/ to /system/media/bootanimation.bak

Copied my custom boot animation to /system/media/


Google appears with the small unlocked icon for a few seconds, then disappears to blank screen, which I'm assuming is my boot animation. It never shows, never boots, just sits on blank screen.

Tried turning it off, it auto reboots, never powers off. If I hold all three buttons it will reboot and pull up the boot loader. I try going into recovery, google appears with unlocked icon, and never goes black never loads recovery.

This nexus 7 is running paranoid Android 4 beta1 or 3.99 rc2 can't remember..

Twrp for recovery..

As of now I'm letting it show the black screen waiting for battery to die in hopes that I can charge it, without it powering on, then hold all three buttons, load boot loader, then load recovery and it work.. But I don't think this will help..

I've tried a bit of googling for nexus 7 bad boot animation, and found nothing useful.. Hope someone can help, thanks!
20th January 2014, 07:10 AM |#2  
urhaxable's Avatar
OP Senior Member
Thanks Meter: 25

The nexus 7 is not bricked.. When it loads black screen it is loading my boot animation, and obviously fails, the tablet dies finish booting, even though I didn't think it was.. If I turn tablet horizontal I can see the right 2-3 inches appear, apps, lock screen, etc.. But rest of screen is still black, but if I touch other part of screen while in app drawer, it does open that app.

So in vertical mode I have a black screen overlay.. In horizontal I have only about a 75 percent black overlay that is left justified.

I'm hoping I have adb enabled so I can go in and delete the custom boot animation I made and all will be well.. Or at least see if I can navigate only seeing the right part of screen so I can enable adb or even delete the boot animation itself..
20th January 2014, 08:13 PM |#3  
Never heard of this issue, even if you put in an incompatible bootanimation and forget to change permissions to it (which I don't believe you did) your tablet should still boot fine and perform just fine just get a blank screen during boot up
Is it possible you did something else? As this issue seems yo be more than just a bootanimation
If I were you right now I would attempt to flash or at least boot a new recovery through fastboot
fastboot erase recovery
fastboot flash recovery nameofrecovery.img
Or just
fastboot boot nameofrecovery.img
In this recovery adb should work fine
adb pull /system/media/bootanimation.bak /location/on/pc
Now change it back to
adb push /location/on/pc/ /system/media/
Now either fix permissions in recovery or chmod with adb, also may need to mount system first
And for future reference always make a backup first

Sent from my Nexus 7 using XDA Premium 4 mobile app
21st January 2014, 09:01 PM |#4  
urhaxable's Avatar
OP Senior Member
Thanks Meter: 25
I did nothing else, the tablet actually boots, but all black screen in vertical mode.. In horizontal mode you can see maybe 25% of the screen, the rest is black, but still functions..

If I adb in from Linux, move original boot animation back, reboot, works fine.. I think it's something to do with my zip file or something, I've even took original stock boot animation and edited its images, created a zip, installed, reboot, same thing..

Adb in, move original, reboot, good to go again..

Today I'm going to try unzipping, and just rezip, install without changing any files and see what happens..
22nd January 2014, 05:51 AM |#5  
If you want upload me a copy of original along with a copy of the new one you made and I'll have a go at it

Sent from my Nexus 7 using XDA Premium 4 mobile app
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes