Remove All Ads from XDA

[Q] Fix for "Couldn't install on USB Storage or SD card" on CM11?

16 posts
Thanks Meter: 1
By skullman012291, Junior Member on 8th January 2014, 05:08 PM
Post Reply Email Thread
21st January 2014, 04:24 PM |#11  
OP Junior Member
Flag Toronto
Thanks Meter: 1
So it's been a few days and I've got an update to share.

I was too lazy over the weekend to try out the Jan. 17 build, so I instead tried out the Jan. 20 build when it was released yesterday. But before I did, I made a backup of everything (Apps with TiBu, and NANDroid backup with TWRP) just in case something went haywire.

I wiped everything except my SD Cards in TWRP, and then installed the 01/20/14 build alongside the PA Mini Modular Gapps. I then accessed my bootloader and installed the boot.img 3 times to ensure that it sticks (not required to do, but more like OCD lol ). Once that was done, I powered off for a few minutes, unplugged the micro USB cable and then powered back on.

As it was running through the initial setup, I went through all the usual steps, but after I entered my Google Account info and had that verified, I decided to uncheck the Backup & Restore option, but had everything else checked.

You might be wondering, "Why'd you uncheck that option?". Essentially, I had the thought that there might have been a setting that corresponds to Google Sync Services and Gmail from earlier builds that kept messing up the default options in CM11 builds and thus making it unworkable (hence my earlier issue with Gmail not syncing and sending me notifications).

So after I ran through that and installed all my programs again (from the Play Store, not from TiBu for testing reasons), I opened up Gmail after a reboot and I noticed that the notification push was working! I also sent myself an email from my desktop and checked to see if my phone would notice it, and that worked too!

So to recap, here's what I did:

1) Backed up everything
2) Wiped everything in Recovery except for SD Cards
3) Installed Jan. 20 build and PA Mini Modular Gapps
4) Installed boot.img 3 times via fastboot, powered off
5) Unplugged USB cable, powered on
6) Went through initial setup
7) Unchecked "Backup & Restore" setting during setup
8) Installed all apps from Play Store, powered off
9) Powered on, opened Gmail
10) Noticed that Gmail was working, celebrated

I'm sure all of this could have worked in earlier builds too, but I never thought about unchecking the "Backup & Restore" setting during the initial setup until yesterday. So now all that remains as a WIP is to get MMS working, but that's the least of my worries for now :P
22nd January 2014, 04:27 PM |#12  
OP Junior Member
Flag Toronto
Thanks Meter: 1
Jan. 20 Build Update
Huh, well apparently it only decided to work that one time...

Upon that first clean install and boot, it notified me about all new emails that were coming in. The next day however, it decided to just stop. I have to do a manual sync (moving my thumb from the top to the bottom of the screen while using Gmail) to get my new emails to appear, and there's still a chance that it won't fetch new emails

Not only that, but I noticed that there's still a few apps that don't work out completely. An example of this is The Simpsons: Tapped Out. It was working fine in earlier builds (I believe it was the 15th or 17th, can't recall right now), but on the 20th build, it just force closes after the first screen.

Also, some apps disappear from my home screens after a reboot. I don't get why this happens, but it's ultimately not a big deal. But hey, at least cLock survives a reboot when using launcher3

Anyone else have similar problems/issues?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes