Remove All Ads from XDA
Honor View 10

[Q] Problem with updating apps in Market (insufficient space)

27 posts
Thanks Meter: 0
By SergSlim, Junior Member on 20th January 2014, 10:51 PM
Post Reply Email Thread

Some of the apps in Play Market are saying that I have insufficient space when I try to update them.

At the same time, some apps update successfully, while others report about insufficient space.

For example:
Samsung Print Service Plugin - 10,42 MB - insufficient
Asphalt 8 - some small update slightly bigger than 10 MB - successfully update.
Revolt Classic - 114 MB app, update for 30 MB. Downloaded and updated without any problems
Facebook - 10+ MB. - insufficient

At the same time - update which is 100% of an app's size report about insufficient space, even when it's only 10 MB, while updates which are a smaller than the whole app, but are twice or more times bigger then those small updates - are installing just fine

Device memory - free 493 MB.
SD card - free 4.98 GB

I read somewhere that Samsung devices (or was it Android devices overall) have some limits for particular memory partitions so to say (cache, data, etc). And even when overall device's memory will have enough free space to install apps, it may report insufficient space due to overlimit of some memory partitions. Not sure how accurate I am saying this.

I tried looking at ADB to figure that out, but without much luck:

I tried clearing Cache partition from stock 3e recovery, but it behaves strangely - at first I see Android robot lying with red triangle or exclamation mark, and then the phone restarts itself. Dunno if it was successful.

I have an all stock firmware with root and reflashed stock recovery.

Do you have any ideas why does it behave this way?
21st January 2014, 05:49 PM |#2  
ewa12321's Avatar
Senior Member
Thanks Meter: 55
Im having those problems when my free phone memory drops below 500 MB. Have you tried to delete unused apps and having over 500 MB free trying to update them again?

Maybe some stuff from those updates are automatically installing on sd card? Idk

from S4 Active Blue Ocean
21st January 2014, 06:22 PM |#3  
SergSlim's Avatar
OP Junior Member
Flag Lviv
Thanks Meter: 0
I was just able to install a new game, which is 150+ MB, but am still unsable to update an app which is less than 2 MBs... Very strange.

I don't think it's really an actual free memory size's problem, and rather some part of it...
23rd January 2014, 12:32 AM |#4  
Senior Member
Flag Dauphin Island, AL
Thanks Meter: 66
Try clearing data from Google Play Services.

Sent from my SAMSUNG-SGH-I537 using Tapatalk
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes