Remove All Ads from XDA

[Q] Charging only when turned off, 4.1.1.

4 posts
Thanks Meter: 0
By Giant Robot, Junior Member on 16th January 2014, 12:12 PM
Post Reply Email Thread
Hi, everyone. I've seen the other threads and no one had a problem quite like mine.

Yesterday I've upgraded my Alcatel OT-997, ICS 4.0.4. with Kuano's TWRP and now it's:
Alcatel OT-997D, JB 4.1.1. - (details in this thread, 5th post)
D means I can now use two SIM cards, which is cool.

The problem is the damn thing doesn't charge when it's turned on. It shows the lightning bolt over the battery icon, but in settings shows that charger is not connected. However, when it's turned off it charges, normally. I tried different settings in USB menu: Mass storage, MTP, Camera mode and Charge. Tried with and without Debugging mode. All of those work when connected to a computer in the sense that I can use internal storage, access both SD cards, and so on. But it doesn't charge.

I have tried 3 different cables, 3 wall outlets, and 2 PCs so it's not that. I suppose it's not a hardware problem otherwise it wouldn't charge properly when it's turned off.

So now I use schedule to turn it off before I go to sleep, and to turn on before I wake up, so it would charge while I'm sleeping. Anyone's got any ideas how to fix it?
22nd January 2014, 01:47 PM |#2  
OP Junior Member
Thanks Meter: 0
23rd January 2014, 11:51 AM |#3  
OP Junior Member
Thanks Meter: 0
Thumbs up Well I solved it with reinstall
Finally I've lost my patience so I tried the only thing that was left.
  • First I did a backup with TWRP.
  • Then, factory reset from TWRP.
  • Then, restore system from One Touch Upgrade 2.8.0 - lost the DUAL capability, software restored to 4.0.4.
  • Now comes the interesting part. It had the same problem as before, did not charge while on. So I tried a solution I found online a while ago but I never tried when on 4.1.1: Turn it off, connect charger, remove battery, wait a bit, press power button for approx 10 sec (nothing hapens), wait a bit, instert battery, turn it on and there it is. I'm not sure if it was this procedure that did the trick or it simply needed a reboot after update but it worked. It showed "charging" in battery stats.
  • Finally, restore with TWRP as Kuano explained in his post. Mind you, when I did the restore it was connected to my PC all the time.
Now two things I you should know:
First, before I did all this I connected it to my PC while turned off i.e. (PC - ON, phone - OFF). I noticed this: it was constantly connecting and disconnecting (the "piano chord" notification was coming from the computer speakers every 5 sec) like I was pulling the cable in and out. That is all I know about this, I didn't have the nerves to work on it.

Second, now that it is restored and charging, when I connected it to PC it couldn't change USB setting from Charge to MTP. It reported an error something like "service stopped". This happened only once and I did not try to do it again, I just don't have the energy for any more problem fixing right now. It charges, and I use airdroid for file transfer, that is all I need for now. If and when I get around to take a look at it I'll post here if there's something interesting.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes