Remove All Ads from XDA

[Q] [SOLVED] Compiling modules for the stock Ray kernel (

10 posts
Thanks Meter: 0
By dsvilko, Junior Member on 23rd January 2014, 12:03 PM
Post Reply Email Thread
I'm trying to compile usbserial-related modules for my Xperia Ray that's still on stock GB. What I have done:
  1. downloaded the correct SE kernel sources
  2. installed the latest Google's NDK
  3. loaded the default Ray kernel config (make semc_urushi_defconfig)
  4. set up usbserial and pl2303 as modules (make menuconfig)
  5. export ARCH=arm
  6. export CROSS_COMPILE=......./android-ndk-r9c/toolchains/arm-linux-androideabi-4.6/prebuilt/linux-x86/bin/arm-linux-androideabi-
  7. edited Makefile and set KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -Wno-unused-but-set-variable -o-uninitialized -fno-strict-aliasing -fno-common -Wimplicit-function-declaration -Wno-format-security -fno-delete-null-pointer-checks
  8. make CFLAGS_MODULE=-fno-pic modules
The build goes without an error and I get my modules. The problem is when I try to insmod them on my Ray I get "invalid module format" with no additional errors reported in dmesg. The only thing (I think) I know is that it's not the problem with the 'magic version' string as I have tried changing the default in the Makefile and then I do get that that it's a wrong magic version.

Any ideas?
23rd January 2014, 01:19 PM |#2  
OP Junior Member
Thanks Meter: 0
I have tried compiling using the DooMLoRD's 4.4.3 toolchain and that did the trick!
Just a note if someone else wants to compile additional modules... don't use the no-pic flag! Simply do 'make modules'.
Now to see if I can talk to my old Garmin GPS through a newly created ttyUSB0
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes