Remove All Ads from XDA
Honor 9 Lite

[Q] Stuck on HTC logo. The phone may be bricked.

2 posts
Thanks Meter: 0
By petjkalv, Junior Member on 25th January 2014, 03:09 PM
Post Reply Email Thread
Hi there.
The problem is that I can't turn on my phone as it gets stuck no that green HTC logo.
It all started when I installed an app from google market. The phone was restarting every time I launched the app. Eventually it stopped turning on and got stuck. Also, I tried doing hard reset and other things from HBOOT menu, but there's the same problem if I choose anything except recovery— it gets stuck. I searched for the issue on the internet. So, I decided to flash a newROM. I downloaded 2.42.405.4 — Android 2.3 (with root+busybox, installs from Recovery). Renamed it as and put it on a SD card. Then I tried to run a recovery through HBOOT. After few seconds phone with a circle of arrows appeared and phone turned off and did 7 short vibrations. Now, I guess, it's bricked completely as it doesn't respond to my actions at all. Neither the red light in the corner after I connect the phone to computer.
I managed to get some information from HBOOT menu:
Apr 11 2011, 23:36:27
Before the issue I downloaded official 2.3 upgrade.

Some help would be appreciated, thanks
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes