Remove All Ads from XDA

[Q] My Galaxy Mega has a problem.

4 posts
Thanks Meter: 0
By drcirno, Junior Member on 26th January 2014, 06:12 PM
Post Reply Email Thread
I think this is the right place to post questions?

So I tried the rooting method here:
But it doesn't boot and stuck on "SAMSUNG" screen.
I tried using factory reset and simply trying again, but it still doesn't work.
What do I need to do to make it boot?

BTW the phone model is Galaxy Mega 6.3 LTE (SCH-R960).
27th January 2014, 12:38 AM |#2  
OP Junior Member
Thanks Meter: 0
Can this thread be deleted? I found a better place to post this question.
27th January 2014, 01:28 AM |#3  
hnkotnis's Avatar
Senior Member
Flag Sangli, Maharashtra, India, Asia, Earth, Solar System, Milky Way Galaxy, Local Galaxy Group,Universe
Thanks Meter: 513
Originally Posted by drcirno

Can this thread be deleted? I found a better place to post this question.

If you are having a computer, you will see a triangular mark at then place where you see Title, last edited etc on right hand side. Press that button, report to moderator and request him to delete the thread. You must do it because mods only do that only if OP asks them.

Speaking about your phone stuck at Samsung, it is just a soft brick. No need to panic. It happened me 10-15 times so far. Use Odin to flash your phone stock ROM. Search in Galaxy Mega forum for Odin and Compatible firmware.

Sent from my GT-S5360 Gadget of Mass Destruction using xda-app
Using CWM........Busybox Commands........No I use my hands
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes