Remove All Ads from XDA

[Q] Play Services cut-off my cellular abilities when there's no internet

5 posts
Thanks Meter: 0
By Vla3d, Junior Member on 25th January 2014, 02:35 AM
Post Reply Email Thread
Hi everyone - I actually don't know who else to ask but this issue has been driving me mental for the last couple of months. After days and nights of investigating and looking through various forums and articles, I think I can find (or try at least) the words to describe my problem more...technically))

So OK, first off the device is Huawei Ascend G510-0100 running KitKat under the Cyanogenmod platform but the issue was already present with the factory's 4.1 ROM. I thought rooting the phone, installing just brand-new everything and having a bloatware/clutter-free Android OS would rectify all the causes of this nightmare but no. I'm not the only one with this problem: Google-search the issue and you'll find numerous forum threads where users seek for a solution to this "software loophole" as well as one of my friends (Galaxy S2) and another one with the HTC One X+ so I rule out my phone's model, OS version or just my device being faulty from the list of potential causes.

So - every time I turn my WiFi off on purpose or when I go out of my house (where logically my phone looses home's wireless signal) - the location services and the app synchronization processes stumble, mess up, run into and furthermore cause internal system mess-ups from such "unexpected" losts of internet. After that I can't make a phone call, send SMS or run USSD codes (checking credit balance etc) but I can still receive calls and texts - basically I fail to reach my cellular services but the service can still reach me. Turning Airplane Mode on and then off or simply restarting the phone altogether temporary fixes the cellular problem until the next time the internet becomes unreachable to Play Services. I tried turning location and sync off, tried different location/sync options...I wish I could disable Play Services but then I wouldn't be able to use the Play Store - | tried messing around with probably every single option available and possible but the Play Services still failed me and.......I honestly don't know what am I missing and where to look next
Edit: (I never use the mobile data btw)

Any suggestions? Anybody? I'm hopeless at this point
Thank you all...
29th January 2014, 01:51 AM |#2  
Vla3d's Avatar
OP Junior Member
Thanks Meter: 0
Anyone? Please...
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes