Remove All Ads from XDA

[Q] Apps crash post nandroid restore (system apps removed before restore)

8 posts
Thanks Meter: 0
By lascerius, Junior Member on 31st January 2014, 01:05 PM
Post Reply Email Thread
First post, read the rules, hopefully I didn't forget any before posting this. Searches weren't helping as much as I'd hoped. If trying to help you likely don't need to read most of this, I provided a lot of detail and history at the end in case some may be relevant.


I removed system apps using Titanium Backup Pro. Things seemed to work okay but then I restored nandroid backup(s). The restored phone has a ton of things crash and I think that the nandroid restore did *not* restore system apps I removed.

Shouldn't a nandroid restore put things back as though I never touched it post that backup?
I have a stock ROM for my phone of 4.3 (not the one from Kies). Is my best option to copy it as on my phone and use CWM to install it, then nandroid restore again?

During all of this I did two nandroid backups to the phone SD and never found them on it (only found ones on the external), but according to the free space, something has taken up roughly 4GB from when I first started playing.

Long-winded version:

I did a nandroid backup in CWM recovery mode. I then did a backup of all apps and data using Titanium Backup Pro. After both backups I used Titanium Backup Pro and removed most of two lists of apps, link reference below, including system apps. I made a second nandroid backup at this point.

I restored my phone to the first nandroid backup. It seemed okay but then a number of apps crash. Titanium Backup Pro, CWM, Google Play, and more close immediately when I try to open them. My Swype keyboard opens in some apps but not others (fails in Chrome), I tried to restore again doing the factory reset wipe in CWM first, same issue. I tried my second nandroid backup, same issue. During this I tried clearing cache and data for the apps and they still crashed.

After trying simply a factory reset, I found I had no keyboard app (so it was hard to tell if certain things worked since I couldn't logon for Google Play). Since I use the Swype keyboard, keyboard was an app I removed (and this worked perfectly fine *before* restoring).

Why I restored:

I was pleased with the results except my BlueTooth quit working and restoring Bluetooth share 4.1.1-L710VPBLJ7 didn't fix it. I restored to my original nandroid backup to see if it had worked there (it did).

Extra Details:

When I rooted my phone I used CF-Auto-Root and Odin 3.09 successfully, then installed SuperSu which disabled KNOX for me. I had a failed attempt first, likely due to a possibly faulty USB port, using Odin 3.07 that resulted in my having to "Firmware Upgrade and Initialization" with Kies.

Links referring to most apps removed, some didn't exist on my phone and the ones listed here were NOT removed:

Exchange Services
Factory Test
Favorite Contacts 1.1
S Memo
S Memo
S Suggest 3.2.47
S Voice 10.0
USB settings 1.0
Voice Recorder


Titanium Backup Pro:
ClockworkMod Recovery: (on exiting recovery mode it does say my phone "may" not be rooted and asks if I want to try to fix it)
CF-Auto-Root File: CF-Auto-Root-m3-m3zh-gti9305.tar.md5

Phone Details:

Carrier: T-Mobile (Germany)
Model number: GT-I9305
Android Version: 4.3
Baseband version: I9305XXUEMK1
Kernel version: 3.0.31-2051278
Build number: JSS15J.I9305XXUEML5


I spent a bit of time before I finally just figured I'd try Kies to "Firmware upgrade and initialize". It worked and my phone is fine again (no root anymore or CWM anymore though).
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes