Remove All Ads from XDA
Honor View 10

[Q] Google play store not connecting! tried everything...

1 posts
Thanks Meter: 1
By LoriJean, Junior Member on 1st February 2014, 06:01 AM
Post Reply Email Thread
I have a rooted galaxy s3 i747. Originally with AT&T but unlocked and switched to T-mobile.

Two months ago google play store/any google app stopped working. I couldn't sign into anything. Factory reset it, Still didn't sign in. I recently tried to fix it buy going into etc/hosts and adding the "#" in front of the I.P address. That worked, I could sign into my google accounts.
But now Google play store wont connect. I know for sure my wi-fi is working. Browsing internet works perfectly without errors. It just keeps saying connection timed out, Retry.

I already checked my time/region. Its on automatic, everything correct.
I deleted the hosts file.. nothing. cleared cache, forced stopped, rebooted again and again. disable/enable.
I didn't save a copy of the hosts file though... Not sure if that's a problem or not. I don't know how to go about making another one.

I'm not the brightest when it comes to things like this.
please help.
The Following User Says Thank You to LoriJean For This Useful Post: [ View ] Gift LoriJean Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes