Remove All Ads from XDA
Honor 9 Lite

[Q] Problem with getting ROM on my phone

7 posts
Thanks Meter: 0
By doninckg, Junior Member on 1st February 2014, 09:49 AM
Post Reply Email Thread
Hello all,

I'm having a problem with putting a new ROM on my device. Goiung back to backup ROm has failed to as it seems the Backup wasn't complete

I thought it had something to do with S-Off, but someone from another thread said I should make a new topic as this would probably be another problem.

I wanted to go to the SuperSense DX5 ROM, but then i need to upgrade my hboot version and boot.img.
At this moment my hboot version is 1.24.0000. Also the the device is still in S-On.

When I try to load boot.img i get the following message

flash boot boot.img
sending 'boot' (4452 KB)...
OKAY [ 0.811s]
writing 'boot'...
FAILED (remote: image update error)
finished. total time: 0.811s

Fot the hboot i get following message:

flash hboot bravo_alphaspl-sense.img
sending 'hboot' (512 KB)...
OKAY [ 0.234s]
writing 'hboot'...
FAILED (remote: not allowed)
finished. total time: 0.234s

When i looked these errors up I Always ended up about S-Off or get stock recovery.img. Already got the stockrecovery.img on device but still nothing works.

Is there anyone that could help me solve this problem please? I'm completly not sure why now I'm not able to put ROM's on it anymore.

With Kind Regards,
1st February 2014, 10:11 AM |#2  
ckpv5's Avatar
Recognized Contributor
Flag Kuala Lumpur
Thanks Meter: 17,792
Donate to Me
1. You're trying to flash hboot meant for Desire not Desire X
2. Your hboot is 1.24, you cannot flash boot.img or ROM meant for hboot 1.25
3. You should flash only ICS boot.img, ICS recovery and ICS ROM

So find any ICS ROM in dev section and follow instructions there on how to flash the ROM.
Or go to general section and look for how to restore to ICS stock and update your device to JellyBean.
Then you can install all those JB ROM that you wanted to.

Remember this ? It's the same problem and the same way that you need to do to solve your problem.

Originally Posted by doninckg

Got it fixed, after some Stock rom install and then tried another ROM Shadow, and it seems to be working once again.

Sorry for my question. I might have done something wrong about the hboot version I think.

1st February 2014, 10:54 AM |#3  
GtrCraft's Avatar
Recognized Developer
Flag Nijkerk
Thanks Meter: 11,484
Donate to Me
Good thing you still have S-On or else you would have a paperweight right now
1st February 2014, 01:30 PM |#4  
OP Junior Member
Thanks Meter: 0
Ohhh OK,

I just followed the guide on the SuperSense DX5 where they refered to hboot 1.25.
But I still don't get why i'm not able to flash a boot.img. Tried the ICS ROM I Always used before "Sense Revolution+ R2

But I'm not able to get this working anymore
But I actually wanted to upgrade because I had some difficulties with this ROM about my Mobile Data. Had high hopes that it could be fixed with a JB ROM for Desire X. The only boot.img and hboot i tried to install was meant for the Desire-X. I'm also using Hassoon 3.0 for Desire-X to have the right recovery flashed for ICS of JB.

Still I must be doing something wrong I guess now, but don't know what then.

So S-On is alright for this device then? I don't need to change annything for this device to try and put it in s-off?

Sorry if I lack a bit of knowledge to root. Thought I did everything that was needed, like I used to do before.
1st February 2014, 01:38 PM |#5  
ckpv5's Avatar
Recognized Contributor
Flag Kuala Lumpur
Thanks Meter: 17,792
Donate to Me
Originally Posted by doninckg

But I actually wanted to upgrade......

1. If you have a backup of your ROM, restore that then update to JB with OTA.

2. Or use the RUU RUU_PROTO_U_ICS_40A_HTC_Europe_1.18.401.1_Radio_10 .21.40.06U_1.10.40.23_release_295191_signed.exe to restore your device then do OTA update.

Download :

3. Or for more advance user, follow this guide - but not sure whether all links still active for the needed files.

Option 2 is the best for you.


1- in fastboot mode - relock the bootloader : run command fastboot oem lock

2- in fastboot mode - flash/run/double click the RUU; follow the updater instruction - next,update,bla,bla,bla until it finish
The Following User Says Thank You to ckpv5 For This Useful Post: [ View ] Gift ckpv5 Ad-Free
1st February 2014, 02:06 PM |#6  
OP Junior Member
Thanks Meter: 0
thanks ckpv5, I will try to do this now.
1st February 2014, 02:30 PM |#7  
OP Junior Member
Thanks Meter: 0
ckpv5, this fixed everything!!! Thanks a million times for helping me out this fast.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes