Remove All Ads from XDA

[Q] Semi-Bricked HD+ -- Can't Restore

13 posts
Thanks Meter: 4
By spike095, Junior Member on 28th January 2014, 07:38 PM
Post Reply Email Thread
(For reference, I have a MAG2GA FW v6 dated 10/2012) -- yes, I have access to CWM and ADB

Had verygreen's CM11 (1-18, eMMC install) on my HD+ and it was working without any major issues -- came back home one day and the screen was frozen. Did a power + N button reboot, and now the CM logo on boot spins incredibly slowly (completely hanging at several points). After a few minutes it will either bootloop or get into CM11 -- if it does make it into CM11, the system will be very unresponsive and eventually reboot on its own [no matter what I select].

Booted into eMMC CWM, formatted /system, /data and /cache and reinstalled CM11 1-18 + PA GAPPS. On reboot, I see the exact same behavior (slow/freezing CM logo, eventual bootloop). When it does sometimes make it back into CM, I see my widgets / wallpaper for a brief moment before it bootloops again, implying that my format/wipe in CWM did nothing...?

I then booted into bokbokan's CM10.1 I had on a MicroSD lying around -- I installed the eMMC brick check app from there (which checked out fine, including a test on the full 16gb). I'm trying to do an ADB push now of leapinlar's so I can install it and try to get it replaced under warranty but it either [tried both SD-based CWM and eMMC-based CWM] :
1 - hangs forever (implying some issue with my internal storage)
2 - says transfer complete, but when I navigate to /sdcard/0/ I don't see it
3 - the one occasion I did manage to transfer stock back over and the system could actually see it, I got a '"Failed to retouch '/system/lib/'" error when installing (and yes, I'm formatting /system every time)
In additional, the eMMC CWM behaves very erratically, sometimes taking over a minute to navigate through folders or respond to a volume button click. Pretty sure my internal storage is damaged somehow.

It seems like no matter what I do in CWM, my HD+ continues to try to reboot back into my old CM11 installation. Any thoughts or ideas on what I can do next?

Edit: Okay, so using a 4GB SD card image, I tried to erase /system, /data and /cache and flash cm 10.1 and twrp just to see if anything would stick. Removed the SD after flash, reboot, and the system goes right back into CM11 boot loop. Trying to reboot into TWRP brings back up -- looks like nothing I'm doing will stick. Brought up ADB shell and ran "mke2fs -T ext4 /dev/block/mmcblk0p8" to wipe system, still reboots back into CM11 no matter what I flash in SD CWM.
31st January 2014, 10:43 AM |#2  
Junior Member
Thanks Meter: 0
226 68565523
I have the same issue, but on my HTC One S. My eMMC chip: MAG2GA.
Looks like its TRIM brick.
I can't wipe or install other rom, and recovery allways say "E:/can't mount /data"
My system works well, but after reboot the system returns to its previous state and all new data (SMS, calls, files) delete.
All it happens after 27 January after installing nightly update for CM11
1st February 2014, 04:19 AM |#3  
sandsofmyst's Avatar
Senior Member
Thanks Meter: 120
Leapinlar has the knowledge and info on fixing the partitions. Might be just refreshing them up might fix it. Trim bug can also cause physical damage... don't know which that could be here if its it.

I've played a few minutes with the 29th(?) nightly and had not received this problem though that build had quite a few issues for me. So Korshun could be on to something.
2nd February 2014, 01:20 AM |#4  
OP Junior Member
Thanks Meter: 4
Just swapped it instead -- seems like physical TRIM damage, given that nothing I changed [even writing 0s to disk] would stick.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes