Remove All Ads from XDA

[Q] Problems with CM 10.1 superuser

19 posts
Thanks Meter: 0
By TooMuchSloeGin, Junior Member on 31st January 2014, 11:35 AM
Post Reply Email Thread
I have a plain vanilla CM10.1 on my HD+. The included CM File Manager runs fine with root privilege. I've also installed a newer version of Jackpal's Term (terminal emulator) which runs fine as well with root.

However, the current version of ES File Manager will not run with root privilege. When I try to activate this, I just get the message "Sorry, test failed." Interestingly, the app is visible in Settings>Superuser as "allowed", but it still fails to acquire root. (I already uninstalled and reinstalled ES File Manager a couple of times with no success.)

Additionally, another app I tried to install (SambaDroid) gets denied root by the CM Superuser app without me even being able to say yes or no.

So something is not working as it should be...?
31st January 2014, 12:47 PM |#2  
Senior Member
Flag Weymouth
Thanks Meter: 255
Have you tried installing supersu from the market?

Sent from my PG86100 using xda app-developers app
31st January 2014, 06:14 PM |#3  
OP Junior Member
Flag Stratfield Mortimer
Thanks Meter: 0
Originally Posted by jpisini

Have you tried installing supersu from the market?

No. I'm not sure whether installing multiple superuser apps is a good idea... I may end up with a system where the two apps slug it out and
I am left without root access. (OK, I do have backups so that wouldn't be a catastrophe.)

Having said that, I would have tried installing another SU if I could get rid of the CM SU in the first place, but these days this thing is baked into the Settings app and I've found no information as to whether (and if so, how) this can be disabled.

Hints anyone?
2nd February 2014, 04:37 PM |#4  
OP Junior Member
Flag Stratfield Mortimer
Thanks Meter: 0
Seems I am the only one with that specific problem.

The solution (well, not really but probably better than mucking with the CM superuser app): I've removed ES File Manager and installed X-plore File Manager instead. The interface of the latter is not that great but it seems to do most (or all?) of what ES can do (plus it does open password-protected RAR files, a big plus for me). And of course it supports root...

Still I do not understand why ES would not work with the CM superuser but there you go.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes