Remove All Ads from XDA

[Q] Mach Speed Trio Stealth Pro 9.7'' Tablet Bricked

3 posts
Thanks Meter: 0
By jhan1984, Junior Member on 5th February 2014, 01:58 PM
Post Reply Email Thread
Hello. This is my first time asking a question in Xda-Developers. I have a bricked Machspeed Trio Stealth Pro 9.7 Tablet. It happened right after I flash the recovery to CWMod. Now the screen turns on but there is no image on it. I have been looking for a way to fix this. I have tried flashing the recovery again using ADB USB, but I must be doing something wrong or using the wrong files. I also tried livesuit flashing tool, but no results so far. Has anyone found an img file to flash this tablet? I was able to find a rom zip which is posted here :, but i have no way to use the recovery because the there is no screen output. Could anyone convert this zip file into a livesuit image for me. Maybe that could work. Any advice will be really appreciated. Thanks a lot.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes