FORUMS
Remove All Ads from XDA

[Q] x8 restarting after screen light timeout

18 posts
Thanks Meter: 0
 
By Mr Skatosakoulas, Junior Member on 3rd February 2014, 10:24 AM
Post Reply Email Thread
My xperia x8 is driving me insane. Everytime my mobile's screen turns off/times out, after 2-3 seconds it restarts. I have flashed it's stock firmware i found on the web because i was dealing with the same issue before with the difference that before the flash, it wouldn't occur only on screen timeout, but it could happen anytime, usualy exactly after the boot. I also bought a new battery just to be sure because the previous one was a little puffed but that didn't help. Please help me fix my mobile please
 
 
3rd February 2014, 10:27 AM |#2  
Member
Auckland
Thanks Meter: 22
 
More
Have you tried a different variation of the same stock firmware? If not I would give it a go. Idk what you have done, but a factory reset through flashtool should set things straight.

Sent from my ST18i
3rd February 2014, 10:36 AM |#3  
OP Junior Member
Thanks Meter: 0
 
More
his uchedrm
Quote:
Originally Posted by Guynan

Have you tried a different variation of the same stock firmware? If not I would give it a go. Idk what you have done, but a factory reset through flashtool should set things straight.

i will try a different variation.if you can, plz suggest me a link or something. Could it be a hw problem?
3rd February 2014, 12:13 PM |#4  
OP Junior Member
Thanks Meter: 0
 
More
ultsawy enjoy
tried different stock rom, same results. now what?
5th February 2014, 07:15 AM |#5  
Member
Auckland
Thanks Meter: 22
 
More
Quote:
Originally Posted by Mr Skatosakoulas

tried different stock rom, same results. now what?

Remove your battery, check the little patch behind it for water damage. That is all I can think of. Because flashing those .ftfs is literally wiping your device as clean as it will go. So it sounds like something wrong more on the hardware side of things. Because if you have an issue in one ROM, if it is software related, it should not transcend into the other.
5th February 2014, 02:21 PM |#6  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Guynan

Remove your battery, check the little patch behind it for water damage. That is all I can think of. Because flashing those .ftfs is literally wiping your device as clean as it will go. So it sounds like something wrong more on the hardware side of things. Because if you have an issue in one ROM, if it is software related, it should not transcend into the other.

i had bought a new battery because the old one was a little buffed. the upside was that it kept going until the screen timeout, when with the old battery it would restart instantly after the sony ericsson screen. Could it be kernel issue or something like that? The device was my brother's who took care of it alot. he never droped it or anything. My last guess is that he charged it with a different charger not optimal for the device, that's why the buffed battery and the hardware issue! sounds plausible?
5th February 2014, 02:25 PM |#7  
OP Junior Member
Thanks Meter: 0
 
More
i just asked him and he told me he actually did, multiple times. Does this senario stand?
5th February 2014, 03:49 PM |#8  
Pras_92's Avatar
Member
Thanks Meter: 24
 
More
Quote:
Originally Posted by Mr Skatosakoulas

My xperia x8 is driving me insane. Everytime my mobile's screen turns off/times out, after 2-3 seconds it restarts. I have flashed it's stock firmware i found on the web because i was dealing with the same issue before with the difference that before the flash, it wouldn't occur only on screen timeout, but it could happen anytime, usualy exactly after the boot. I also bought a new battery just to be sure because the previous one was a little puffed but that didn't help. Please help me fix my mobile please

I think it may be probably a kernel problem....try using SEUS or Sony PC companion and flash latest firmware in your phone..i think it will work..
5th February 2014, 08:08 PM |#9  
Member
Auckland
Thanks Meter: 22
 
More
Quote:
Originally Posted by Pras_92

I think it may be probably a kernel problem....try using SEUS or Sony PC companion and flash latest firmware in your phone..i think it will work..

It won't be a kernel issue if you have fully flashed stock .ftfs. But booting to the first Sony Erricson boot screen would usually indicate a kernel issue or problem with the chargemon.
5th February 2014, 08:56 PM |#10  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Pras_92

I think it may be probably a kernel problem....try using SEUS or Sony PC companion and flash latest firmware in your phone..i think it will work..


Quote:
Originally Posted by Guynan

It won't be a kernel issue if you have fully flashed stock .ftfs. But booting to the first Sony Erricson boot screen would usually indicate a kernel issue or problem with the chargemon.

pc companion was the first thing i tried, before buying a new battery.didn't make a difference. as i told before, is it plausible that the charging with a non sony ericsson charger caused the problem? i tried 3 stock roms, i don't think its a sw problem anymore. i am thinking of taking it to sony's tecs to give it a look but i don't want them to play smartasses on me so tracking the problem as much as possible would be a good start.
6th February 2014, 09:42 AM |#11  
mailmyinbox's Avatar
Member
Thanks Meter: 34
 
More
Quote:
Originally Posted by Mr Skatosakoulas

pc companion was the first thing i tried, before buying a new battery.didn't make a difference. as i told before, is it plausible that the charging with a non sony ericsson charger caused the problem? i tried 3 stock roms, i don't think its a sw problem anymore. i am thinking of taking it to sony's tecs to give it a look but i don't want them to play smartasses on me so tracking the problem as much as possible would be a good start.

THIS MIGHT HELP YOU......
http://forum.xda-developers.com/show...php?p=26311764
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes